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Introduction

If you have used a Microsoft Windows™ system before much of the first few section 
of this course will seem trivial. You might want to just directly to the exercises at the 
end of each section.

Note that throughout this course when we refer to “clicking” we mean with the left 
button on the mouse. We will use the expression “right click” to indicate that the 
click should be with the right hand mouse button. It is possible to switch the buttons 
over for a left-handed user and this will be described in the finial section of the 
course. Until then left handers need to fake being right handed. Sorry.

Each section of the course will have some introductory text followed by some 
exercises. Please read the whole text before you start the exercises. If you remove a 
window while reading the text on how to, and then face the exercise on resizing the 
window you are going to get stuck.



Booting & logging in

“Booting” is the name given to the process of turning a dead chunk of metal, plastic 
and silicon into an activated, functioning computer ready to help you with your 
work. It takes its name from “bootstrapping”, the magical ability to lift yourself up 
by your own boot straps.

In the simplest case a computer will boot into its one and only operating system, be 
it Microsoft Windows™ or Linux™.

The computers in this classroom can boot into either Windows or Linux, with the 
choice being made by the user at boot time.



If the computer is already running Windows then we need to reboot from Windows 
to Linux. To shut down Windows, log out and return to the login window. Then click 
the Shutdown” button and select “Shutdown and restart” from the menu offered.

As the system boots you will be offered a menu of PWF Windows and PWF Linux. 
Use the down arrow [↓] to select PWF Linux and then press Return, [↲].

Once the booting is complete you will see the RIPA1 message. You should read this 
once, but don't need to every time you log in. Click the [OK] button to continue.

You will then be asked for your username. This is also known as your login ID, your 
user ID or, in Cambridge, your CRS ID2. In the course you will be using IDs of the 
form ynnn. The demonstrator will be using y575; you should each have your own 
individual ID.

After entering your ID and pressing [↲] you will be asked for your password. For this 
course you have all been given the same (not very good) password. Enter it and 
press [↲] again. (For your own account you should have a better password and 
should not share it with anybody else.)

After about 15 seconds you should be logged in and should see the “message of the 
day” window in the middle of your screen.

Exercise

[5 minutes?]

Reboot into Linux and log in with the course id you have been given.

1 Regulation of Interception Powers Act
2 CRS: Common Registration Scheme. This is how we keep the various IDs in sync across 

Cambridge.



Desktop & window layout



After logging in you should see a page much like this one. Linux desktops do vary 
distribution to distribution but the fundamental building blocks are much the same, 
with only their placing on the screen and colour scheme varying.

This screen with a single application running is quite sufficient to demonstrate most 
of the windowing functionality. Note that almost all mouse operations have a 
keyboard equivalent.

Effect Action
Change focus The “focus” is the window that is connected to the keyboard. 

To change focus from one window to another, or from any 
window to the desktop itself, simply click on that window. 

[Alt]+[⇥] To move the focus from one window to another press [Alt]+[⇥]. If 
you hold down the [Alt] key and press the [⇥] key multiple times 
a small picture appears in the centre of the screen to indicate 
which window would have the focus if you stopped then.

Move There is no way to move a window with the keyboard.
To move a window move the mouse over the window's title bar, 
hold down the left button and move the mouse the window will 
move with it. This is called “dragging” the window. When you 
release the button the window will have its new location.

Maximise Maximising a window makes it large enough to fill the screen.
To maximise a window click the appropriate button to the right of 
its title bar. To restore it to its pre-maximised size click the button 
again.

[Alt]+[F10] To maximise the window with the focus, press [Alt]+[F10].

Minimise/Hide Minimising a window makes the window vanish but leaves the 
application driving it still running.
To minimise a window click the appropriate button to the right of 
the window's title bar.
Clicking in a window's marker in the task bar will minimize if is it 
is currently fully visible. (If it is partly or completely obscured by 
other windows the first click will raise it to the top.)
If the window is currently minimised then clicking its marker will 
restore it.

[Alt]+[F9] To minimise the window with the focus, press [Alt]+[F9].
[Alt]+[⇥] If you cycle through the windows with [Alt]+[⇥] and end on a 

minimised window then that window will be restored.

Resize We treat resizing as changing the size of a window other than by 
maximising it.
To resize a window, drag the window's border. 
If you drag the edges you are limited to resizing in one direction 
(vertically or horizontally). If you drag the corners you can resize 
in both directions at the same time.
The border is thin. You need a steady hand and good mouse skills 
to drag it.

Close Closing a window is not the same as minimising it. Closing a 
window signals to the application whose window it is that the 



Effect Action
window is no longer required. If the application only has one 
window, or if the window in question is its primary window then 
typically the application will quit.
The right-most of the three buttons on the window is the close 
button.

[Ctrl]+[W] From the keyboard the instruction to close a window can be sent 
with [Ctrl]+[W] to the window with the focus.

Applications PWF Linux's default screen provides you with short cuts to launch 
the Firefox web browser and the OpenOffice.org office suite.
Click the Firefox or OpenOffice.org icons to launch the 
corresponding application. In the last section of this course we 
will see how to add our own short cuts (or remove existing ones).

We will see the full set of applications launchable from the menus 
in a following section.

Logging out Logging out will (should) automatically close down all your active 
applications. Some of them may prompt you for instructions on 
their way out.
Clicking on the System icon creates a menu. A single click gives a 
persistent menu. The second item up lets you log off. You will get 
a confirmation (or cancellation) prompt but even if you don't 
confirm you will be logged out in 60 seconds.

Clearing the 
desktop

From time to time your desktop may get cluttered with windows 
from various applications. It can be time consuming to minimise 
every window individually to clear the desktop.
Click this icon in the task bar to minimise every window.
Click it again to restore all of them.

Exercises

[10 minutes]

Make sure you can manipulate the “message of the day” window: move it, resize it, 
maximise it, restore it to normal size, minimise it, and restore it again.

Launch Firefox from the short cut in the task bar. Move the message of the day over 
the Firefox window. Click on the Firefox title bar to bring it to the top and to get the 
keyboard focus.

Click on the message of the day item in the task bar to bring it back to the top. Click 
it again to minimise it.

Use [Alt]+[⇥] to flip between the two applications.

Use the “clear desktop” icon to minimise both windows, and to restore them both.

Finally close both application windows.



File system

All the elements of a Linux system form a hierarchy called the “file system”. This 
hierarchy is a tree of folders (typically called “directories” in the Unix world) files 
containing content. (Actually, there are other types of thing in the file system but 
we don't need to worry about them here.)

A subset of that hierarchy belongs to you and takes the form of a subset of the 
hierarchy hanging off your “home directory”. There are a number of ways to launch 
the file browser for your home directory.

etc home usr

motd y574 y576y575 bin

firefoxUnix IntroDesktop

Play Treasure Island Work

map.jpg story.txt tall ship.png



The simplest, and most commonly used, approach is to double 
click on the “home” icon.

If you don't have a steady enough hand for double clicking 
then click it once to select it (as shown) and then press the 
return key, [↲].
A third alternative is to right-click on it to reveal its menu and 
then to select “Open” from the menu's top item. (The top item 
is typically what you would get from double clicking.)

Finally there is a keyboard short cut to get that menu. If the 
home folder icon is selected simply press the menu key, [],  on 
the keyboard. This will be slightly weird as the menu appears 
wherever the pointer is, not necessarily over the icon. Then 
move up and down the items in the menu with the arrow keys, 
[↑] and [↓], to pick the top item and then press [↲].

Current working directory

For any particular application (e.g. the file browser window) at any particular time 
there is a folder the application is “in”. This is known as its “current working 



directory”).

The file browser's current directory is shown at the top of its window:

To see the full location, press the [<] button at the left:

You can also see the path in its textual form by pressing the small note pad icon to 
the far left:

Pressing it again returns to the previous view.

Changing directory

If you double click the “Unix Intro” folder it will open and the banner will show your 
new directory:

We can access any directory above the current one by clicking on its appropriate 
button in the banner, or by pressing the Up button the right number of times. The 
banner keeps a record of where you have been for easy jumping up and down. If we 
entered the Treasure Island directory and then returned to the Unix Intro directory 
our banner would look like this:



Short cuts

The left hand column of the file browser contains a standard set 
of short cuts for locations on the file system. You can add your 
own by dragging the relevant folder icon to the lower half of the 
left hand side (below the standard set).

To remove a short cut, right click on it and select Remove from 
the menu.

Renaming files

Next we are going to rename some files. We will start in the Treasure Island 
directory:

Let us suppose we want to rename the file “tall ship.png” as “hispaniola.png”3. We 
right-click on it to get a menu and select “Rename…” from the options.

3 “Hispaniola” was the ship that took Jim Hawkins, Long John Silver et al to Treasure Island.



This will highlight just the prefix component of the file's name, not the suffix:

Type the new file name in:

and hit [↲]:

Note that the icon may change its position to match its new name. It will retain the 
focus.

There is a keyboard short cut to rename a file. Select the file's icon and press [F2].

Copying and moving files

The easiest way to move a file from one directory to another is to have two file 
browsers open, one with the source directory showing and the other with the target 
and then to drag the file's icon from one to the other.



Another approach is to use Cut (or Copy) and Paste. 

To move a file, select it and then either pick Edit→Cut from the browser menu or 
press [Ctrl]+[X]. Nothing will happen to the file at this point, but a notice will appear 
at the bottom of the browser window:

You can then move to the directory where you want the file moved and either select 
Edit→Paste from the menus or press [Ctrl]+[V]. The file will then be moved.

If you started with Edit→Copy or [Ctrl]+[C] then the file would be copied rather than 
moved.

Creating folders

We can create folders by right clicking in the file browser, not on an icon, and 
selecting the top item in the menu.



This will create a new folder with its name selected for editing:

You can then type the name you want:



and press []. Note that the icon may move as its name is fixed:

Selecting multiple icons

From time to time you will want to select more than one icon at a time. In the Unix 
file browser your must press the [Ctrl] key down as you click on the second and 
later icons. Pressing [Shift] for the second click will select every icon between the 
first and the second clicked.

Deleting files and directories

To delete one or more file or directory, select them and either drag the icons to the 
waste basket icon on the desktop or simply press the [Delete] key on the keyboard.

This removes the files from visibility but does not delete them permanently. Instead, 
they have been moved to a special waste basket folder.

To see the content of the waste basket, select it from the left hand list of short cuts. 
If you are not running a browser, simply open the waste basket icon on the desktop:



Click the [Empty Wastebasket] button to permanently delete these files.

Setting preferences in the file browser

Next we will see our first customisation of the options for the file browser. We will 
use an example in the “Treasure Island” directory. When you first look at the 
directory with the file browser the file icons look like this:

with generic icons for the two graphics files and one plain text file.

We are going to edit our “preferences”, the way we want the browser to look.

Select Edit→Preferences from the file browser menus. A multi-tabbed window will 
appear. Select the Preview tab and change the “Show text in icons” and “Show 
thumbnails” options from “Local Files Only” to “Always”. (Because your home 
directory is served to your PC by a remote server the files do not count as local.)



Once you have made this change close the preferences window by either clicking 
the [×] button in the title bar or the [Close] button at the bottom right of the 
window. 

The file browser should now be showing more useful icons:

Exercises

[15 minutes?]

Launch a file browser. Navigate into the Work directory.

Within it, rename the directory Project Alpha as Project Delta.

Create a new, empty directory called Project Beta.

Copy the file abc.txt and ghi.txt into Project Beta, but not def.txt. Try to do it 
in a single operation (i.e. use multiple selection).

Move the file lorem.txt into Project Delta.

Delete nonsense.txt and empty the waste basket.

Add Project Beta to your browser's short cuts.

Configure your file browser to show thumbnail image icons. Enter Project Delta to 
check it works.



Launching applications

So far we have navigated, moved, and renamed our files. We still haven't done 
anything with them. The windowing system can select the appropriate application 
for each type of file (which it bases on the file name's suffix). As ever there a 
number of ways to do this. 

Let's use the hispaniola.jpeg (or possibly tall ship.jpeg) file in the 
Treasure Island directory as an example. 

Default applications for existing files

This file is a JPEG graphics file and the default application for viewing it is called 
“Eye of Gnome” (for reasons that need not concern us).

The typical approach is to double-click on the file's icon.

Alternatively, select the icon and press the Return key, [↲].

A third approach, and one we will return to, is to right click on the 
icon to get its menu. Then pick the top item from the menu, 
“Open with Eye of Gnome”. The default application is always 
offered at the top of the menu.

Alternatively select the icon and press the menu key to get the 
menu.

The Eye of Gnome program can be closed with with the  [Ctrl]+[W] (close window)

Alternative applications

A simple graphics viewer program has been launched. But there are alternative 
applications which we might have wanted to use. This is where we have to use the 
menu. Below the top item is a submenu of other applications the windowing system 
thinks could handle the file. And at the end of that is an option to start an arbitrary 
application for the file.



For example, if we wanted to trim the edges of the picture of the ship we would 
need to open the image in an image editor, such as the GIMP4, rather than just an 
image viewer.

Launching applications from the menu system

All of the graphical applications on a Unix system can also be launched from the 
Applications menu (as you have to do if you don't have a file to launch from). Click 
once on the applications icon to get a menu. 

On PWF Linux this gives a menu of categories, matching the set used on 
PWF Windows and PWF MacOS. Moving the mouse pointer up the menu will bring up 
the sub-menus of applications. Click on one of them to launch it. 

Note that if you hover the pointer over an application's menu item then you will get 
a “tool tip” pop up to give you a little more information.

4 GIMP: GNU Image Manipulation Program



Note that because Linux is a free operating system it has a lot of free application 
software too. Because the UCS cannot commit to supporting all of it, most of these 
sub-menus have an “Unsupported” item at the bottom that provides a sub-sub-
menu of these applications.

Text and word processing

Linux supports the editing of plain text files (whose file names typically end in .txt) 
and richer word processing files (.doc, .rtf, .odt, etc.).

The standard plain text editor is called “gedit”5 provided as Applications→Word and 
Text Processing→gedit. This editor is fairly simple to use. Simply type and the text is 
entered; click with the mouse or use the arrow keys to move the cursor within the 
document.

Plain text will only take you so far, though. Linux systems typically ship with a 
version of the OpenOffice.org suite of applications. These are essentially a clone of 
Microsoft's Office suite. The word processor is available as Applications→Word and 
Text Processing→OpenOffice.org Writer.

Standard controls

The is a standard set of control codes which work for both these applications and 
most others. The icons are copied from gedit, but similar or identical icons are used 
in every application.

5 pronounced “gee-edit”



Open a new 
(empty) file

Select the whole 
file's content

[Ctrl]+[N] [Ctrl]+[A]
File→New Edit→Select All

Open a file Copy

[Ctrl]+[O] [Ctrl]+[C]
File→Open… Edit→Copy

Print the file Cut

[Ctrl]+[P] [Ctrl]+[X]
File→Print… Edit→Cut

Save the file Paste

[Ctrl]+[S] [Ctrl]+[V]
File→Save Edit→Paste

Close the file Quit

[Ctrl]+[W] [Ctrl]+[Q]
File→Close File→Quit

Foreign characters

Linux has good support for foreign European character input using the [AltGr] key to 
the right of the space bar. These will work in any application. To illustrate them we 
will use the crib sheet at the back of these notes. This illustrates for each key the 
characters generated for the plain key, the key with [Shift], the key with [AltGr], and 
the key with [Shift]+[AltGr].

We can demonstrate this most easily in gedit.

If we press the [S] key we get the lower case character “s”. Press it in conjunction 
with the [Shift] key, [Shift]+[S], to get upper case “S”. Now press it with [AltGr], 
[AltGr]+[S], to get the eszet character “ß”. Finally press it in conjunction with both 
[Shift] and [AltGr], [Shift]+[AltGr]+[S], to get the section symbol “§”. This last one 
may take some practice. You may find it necessary to press (and hold down) the 
[AltGr] key and then press the [Shift]+[S] keys. Most of the alphabetic keys have 



[AltGr] variants and these cover most of the unaccented letter forms used for 
European languages.

[Key] [AltGr]+[Key] [AltGr]+[Shift]+[Key]

a æ Æ l/w ł Ł v “ i → ı
c ¢ © o ø Ø b ” u ↓ ↑
d ð Ð p þ Þ z « y ← ¥
f đ r ¶ ® x »
g ŋ Ŋ s ß § f ª
h ħ Ħ t ŧ Ŧ m º

The accents come from [AltGr] with the punctuation keys. The principle is to type 
the key combination for the accent followed by the letter it is to act on. So for an 
“é” we type the combination for an acute accent, [AltGr]+[;], followed by an [E]. 
Note that all keys get released between the [AltGr]+[;] and the [E]; this is two 
separate key sequences.

; á ő = ç ą
' â ǎ [ ä å
# à ă ] ã ā

Exercises

Launch the gedit text editor from the menus. Type in the following two lines of text:

The quick brown fox jumps over the lazy dog.

Sævör grét áðan því úlpan var ónýt.

These two sentences are, in English and Icelandic respectively, examples that use 
every character from the respective alphabets.

Save this file as fox.txt in your Play directory. 

Next launch the OpenOffice.org Writer application and start a new document by 
typing in your name. Follow it with the two lines above. If you speak a foreign 
language covered by the characters offered try typing a few lines in that language 
too.

Save this file as a file called fox.odt in the Play directory. (The suffix “.odt” is the 
default for OpenOffice.org's word processing files.) 

Quit the word processor and text editor. Then navigate in the file browser to the 
Play directory and open the word processing file from its icon in the browser.

Print this file (which includes your name) to the printer at the back of the classroom.



Configuring the graphical interface

We have already seen how to configure one aspect of the user interface; we set the 
file browser to use thumbnails for files' icons. We will now take this a little further 
and customize our desktop to suit our needs.

Panel short cuts

By default our task bar has short cuts to launch the Firefox web browser and the 
OpenOffice.org Writer program. Let's suppose we wanted to add another short cut, 
the OpenOffice.org spreadsheet program for example.

To add a short cut to the panel, we first locate the application in the menu system 
and then right click on the menu item to get a menu of options for that particular 
application menu item. (Alternatively, press the menu key on the keyboard while 
the OpenOffice.org Calc menu item is highlighted.)

The OpenOffice.org spreadsheet program is called Calc and can be found under 
Applications→Spreadsheets, Charts and Statistics→OpenOffice.org Calc.

Selecting this item adds an additional short cut to the panel:

The short cuts themselves also have menus of options, again found by right 
clicking. These allow for the short cuts to be moved around or removed altogether.

Multiple desktops

The next configuration is appropriate for users who tend to run very many 
applications simultaneously and who want to switch between them quickly. The idea 
is that instead of having a single desktop where all your applications have to jostle 
for space, you have multiple desktops of which just one is visible at any time. 
Applications are spread across the desktops and you switch between desktops to 
pick up a particular set of applications.

We access the concept of multiple desktops by adding a “desktop switcher” to the 
panel. First we right click on the panel (in this example near the right hand end to 



keep clear of applications) to pull up its menu:

Selecting the “Add to Panel…” item launches an application for doing precisely that. 
We scroll down to the bottom of the list to see an item for switching between 
workspaces:

We select that final item and click the [Add] button. The panel changes from this:

to this:

This shows a workspace switcher showing a single workspace, which isn't much use 
for switching between them. Next we right click on the workspace switcher to get its 
menu, from which we select the “Preferences” item:



The Preferences window simply asks how many workspaces you would like and, if 
you want them organised as a grid, how many rows you want them split over. In this 
example we will take a single row and ask for four:

The switcher now looks like this:

showing four workspaces with the first active.

Now we can click in the second of those small windows and our current set of 
applications disappears. They still exist but are visible in workspace 1; we're now 
looking at workspace 2. Start up Firefox in this workspace and we start to have 
applications spread over multiple workspaces.

We can switch between workspaces by clicking on their section in the switcher. 
However, there are keyboard short cuts which make the whole process much 
simpler, and this is where the idea of them lying in a 4×1 grid comes in. 

Starting in workspace 2 we can move to workspace 1 (to its left) by pressing the 
keys [Ctrl]+[Alt]+[←]. Similarly we could move to workspace 3 (to its right) by 
pressing [Ctrl]+[Alt]+[→]. If we had had multiple rows [Ctrl]+[Alt]+[↓] and [Ctrl]+
[Alt]+[↑] would have moved us up and down the set of workspaces too.



Individual windows can be moved between workspaces using the menu available 
from the icon in the top left of the title bar:

Exercises

Add a short cut for the OpenOffice.org equivalent of PowerPoint, Impress.

Create six workspaces as two rows of three. Start Firefox in workspace one, 
OpenOffice.org Writer in workspace two, and OpenOffice.org Impress in 
workspace three. Practice jumping between workspaces using the keyboard.

Move the Firefox window into workspace four, which should be directly beneath its 
current workspace.



The terminal

Unix started life as a purely typed, “command line” system and many of its most 
powerful features still require the use of the command line. This particular course 
will not go into any great depth about using the command line but you should at 
least know how to get one.

The simplest way to get a terminal is to select Applications→Unix Shell→ 
Gnome Terminal from the menus. You will get a simple window containing a 
“command line interpreter”, usually known as a “shell”. It will be prompting you for 
input with text like “y575@phxtr01:~>”. This is known as the “prompt” for obvious 
reasons.

If you type “ls↲” (two letters and then the return key) you will get a plain text listing 
of the files and directories in your home directory.

y575@phxtr01:~> ls
Desktop   My Pictures  Stuff       Windows NT 5.1 Workstation Profile
My Music  My Video     Unix Intro
y575@phxtr01:~>
Note the stylistic convention of putting what you type in bold face and what the 
computer prints in normal face. This is very common.

Accessing remote systems

Most computers live on the network. Unix systems typically offer a secure 
mechanism to log in to another system you have an account on. The command for 
this is ssh (“secure shell”) and as the name “shell” suggests it gives a command 
line on the remote system.

All users of the PWF can use their account on the PWF Linux servers that can be 
contacted from anywhere in the world by ssh. This course will not attempt to 
describe the cryptography used but will guide you through its implications.

The first part of ssh's security is to check that you are connecting to the system you 
think you are. In the ssh world every machine has a “fingerprint”. This appears as a 
sequence of numbers (expressed base 16 just to make it more bizarre) which can be 
securely checked from a workstation (like your PC) which has never made contact 
with it before. However, among UCS systems we arrange for the fingerprint to be 
known so you don't get bothered by them.

So we connect to the system soup.linux.pwf.cam.ac.uk with the command 
“ssh soup.linux.pwf.cam.ac.uk”. You can safely ignore the warning.

y575@pcphxtr01:~>  ssh soup.linux.pwf.cam.ac.uk
RSA host key for IP address '193.60.95.74' not in list of known hosts. 
y575@soup.linux.pwf.cam.ac.uk's password:
We enter our PWF password as we used to log in and we will connect through to 
soup. The password will not be repeated on the screen.

pcphxtr01:~>  ssh soup.linux.pwf.cam.ac.uk
RSA host key for IP address '193.60.95.74' not in list of known hosts. 
y575@soup.linux.pwf.cam.ac.uk's password:password
Welcome to PWF Linux 2008/2009. 



If you have any problems, please email Help-Desk@ucs.cam.ac.uk.
…
soup:~$ 
Notice how the machine name in the prompt has changed. (The “>” has become a 
“$” too, but that's just a bug.)

If you connect to a system which doesn't have fingerprint arrangements sorted out 
in advance you will get a challenge like this:

pcphxtr01:~>  ssh noether.csi.cam.ac.uk
The authenticity of host 'noether.csi.cam.ac.uk (131.111.10.87)' can't 
be established. 
RSA key fingerprint is 
06:d0:42:b2:ea:74:41:c5:49:80:9d:7b:31:44:00:47. 
Are you sure you want to continue connecting (yes/no)? no
(You are welcome to try to connect to noether but you should expect to fail.)

If you are moving away from your own Unix computer and you expect to be 
connecting back you need to know the fingerprint in advance. This is not a 
password; you are invited to write fingerprints down.

The ssh fingerprint for the PWF Linux servers is 
74:32:9b:4c:52:47:fd:ad:1b:0e:b8:a7:0f:31:3d:99.

Once we have accepted a fingerprint on a system we will not be challenged again. If 
the remote system changes its fingerprint (which it should only do if it has been 
successfully hacked) then our login attempts will be rejected as insecure.

The ssh command assumes we have an account on the remote system with the 
same name as the account on the workstation. If this is not the case we can give an 
account name by preceding the machine name with “user@”. 

Exercises

Start up a terminal and give the “w” command. This lists the currently logged in 
users. It should list just you.

Log in to the system soup.linux.pwf.cam.ac.uk.

Wait a minute to let the rest of the class log in and run the w command there too. 
You should see more users.

soup:~$ w
22:38:57 up 39 days, 13:01, 22 users, load average: 0.02,0.12,0.07 
USER TTY LOGIN@ IDLE JCPU PCPU WHAT 
y574 pts/1 14Jan09 6days 0.09s 0.09s w
y575 pts/3 13:20 5:08m 0.27s 0.27s -bash 
…
Then log out with [Ctrl]+[D].



OpenOffice.org PC105 UK keyboard layout

Each key is represented by a four cell column in the table.  Each column represents the following combinations:
1. Primary key
2. Shift + Primary key
3. AltGr + Primary key
4. AltGr + Shift + Primary key

1 2 3 4 5 6 7 8 9 0 - =
! " £ $ % ^ & * ( ) _ +
¹ ² ³ € ½ ¾ { [ ] } \ ç şģķļņŗ
¡ ⅛ £ ¼ ⅜ ⅝ ⅞ ™ ± ° ¿ ąęįų

q w e r t y u i o p [ ]
Q W E R T Y U I O P { }
@ ł e ¶ ŧ ← ↓ → ø þ äëïöü ã õĩ ũ
Ω Ł E ® Ŧ ¥ ↑ ı Ø Þ åů āēīōū

a s d f g h j k l ; ' #
A S D F G H J K L : @ ~
æ ß ð đ ŋ ħ j ĸ ł áćéí óúĺń âêîôû àèìòù
Æ § Ð ª Ŋ Ħ J & Ł őű č š žďěľňř ť ğă

\ z x c v b n m , . /
| Z X C V B N M < > ?
| « » ¢ “ ” n µ ??? · ???
¦ < > © ` ' N º × ÷ ıė ż

Notes:
1. Where a letter with an accent appears it comes from the key combination followed by the letter.
2. Not all accents are available on all letters.  With accented letters, all the available ones are shown,
3. Press AltGr and then Shift (while still holding down AltGr) and then the primary key (while still holding down the other two) to get the 

combination.
4. The combinations labelled “???” don't seem to do anything, either on their own or preceding another character to accent it.
5. Font used: Bitstream Vera Serif, 12pt.  
6. OO.o version: Build 2.0.0.1, Novell edition.
7. Most of these key combinations are available from xterm too.
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