Edition 2005

Copyright ©
This publication is intellectual property of Novell Inc.
Its contents can be duplicated, either in part or in whole, provided that a copyright label is visibly located on each copy.

All information found in this book has been compiled with utmost attention to detail. However, this does not guarantee complete accuracy. Neither SuSE Linux GmbH, the authors, nor the translators shall be held liable for possible errors or the consequences thereof.

Many of the software and hardware descriptions cited in this book are registered trademarks. All trade names are subject to copyright restrictions and may be registered trade marks. SUSE LINUX GmbH essentially adheres to the manufacturer’s spelling. Names of products and trademarks appearing in this book (with or without specific notation) are likewise subject to trademark and trade protection laws and may thus fall under copyright restrictions.

Please direct suggestions and comments to documentation@suse.de.

Authors: Jörg Bartsch, Marcel Hilzinger, Takashi Iwai, Stephan Kulow, Johannes Meixner, Matthias Nagorny, Siegfried Olschner, Marcus Schäfer, Jens Daniel Schmidt, Arvin Schnell, Adrian Schröter, Luis Villa
Editors: Jörg Arndt, Antje Faber, Berthold Gunreben, Roland Haidl, Jana Jaeger, Edith Parzefall, Inés Pozo, Thomas Rölz, Thomas Schraitle, Rebecca Walter
Layout: Manuela Piotrowski, Thomas Schraitle
Setting: DocBook-XML, \LaTeX

This book has been printed on 100 % chlorine-free bleached paper.
Welcome

The SUSE LINUX User Guide was written to introduce the Linux operating system and its wealth of applications to Linux novices. Get to know your choices for a Linux desktop and learn how to configure and control it. Despite its aim towards novices, it still provides a variety of information helpful for the experienced user.

The SUSE LINUX User Guide consists of six major parts featuring the following aspects of your SUSE LINUX system:

**Introducing Linux**  Get started with Linux. Learn how to manage your desktop and how to perform basic administrative tasks. A comprehensive list comparing Windows and Linux applications helps you find the appropriate Linux counterparts of your favorite Windows applications. As for the desktop, choose from two alternatives—GNOME or KDE—and learn more about their strengths and highlights. Finally, learn where to get more information and help for your Linux system.

**Office**  OpenOffice.org is a powerful substitute for any Office suite you might have used under Windows or Mac OS. Learn how to use it and how to migrate your existing data. Linux also provides two fully-fledged personal information management suites, Evolution and Kontact. Both offer e-mail, calendar, address management, and many other functionalities.

**Internet**  Linux offers two great browser alternatives: Firefox and Konqueror. Get to know how to use them and how to enjoy many smart little add-on features. A chapter about the KDE encryption tool, KGpg, shows you how to secure your Internet communication.
Multimedia  Linux offers many players both for video and audio media. You can also use Linux software to create and edit your own movies or music recordings. If digital image processing is your scene, try GIMP, which easily rivals Adobe Photoshop. Easy-to-use scanning applications and album software for your digital photo collection are also provided.

Excursions  Similar to the DOS shell, a Linux system offers a powerful shell environment that can be used to interact directly with the operating system. Learn about the basic principles behind that functionality and get some hands-on experience using the most important shell commands featured in this section.

Appendix  The SUSE LINUX FAQ contains some of the most frequently asked questions regarding SUSE LINUX. Feel free to contribute and send us your suggestions.

If looking for in-depth information about the SUSE LINUX installation process or system administration, refer to the SUSE LINUX Administration Guide. It introduces installation and configuration with YaST and gives background knowledge for many services and applications running on your Linux machine.

Changes in the User Guide

The following is a list of the changes introduced in this guide, as compared to the previous version (SUSE LINUX 9.2):

- A new chapter about basic concepts helps new users. See Chapter 1 on page 3.
- If you are new to SUSE LINUX, coming from Windows, a list of equivalent programs under Linux is a valuable aid. See Chapter 2 on page 31.
- The GNOME and KDE chapters have been revised. See Chapter 3 on page 47 and Chapter 4 on page 69.
- The help chapter has been revised. It contains more information about man and info pages, guides, books, and other resources. See Chapter 5 on page 99.
- The former chapters of KMail and KOrganizer have been transferred to the new Kontact chapter. See Chapter 8 on page 129.
Konqueror has been enhanced with information about tabbed browsing and other small improvements. See Chapter 10 on page 151.

There is a new Firefox chapter. See Chapter 11 on page 157.

The chapter about digital cameras has been updated and expanded. It contains more information about Digikam. See Chapter 16 on page 215.

Typographical Conventions

The following typographical conventions are used in this book:

- `/etc/passwd`: files or directories
- `<placeholder>`: replace the character string `<placeholder>` (including the angle brackets) with the actual value
- `PATH`: an environment variable
- `ls`: commands
- `user`: users
- `<Alt>`: a key to press
- ‘File’: menu items, buttons or other elements from a graphical user interface

Acknowledgements

With a lot of personal commitment, the Linux developers continue to promote the development of Linux. We would like to express our sincere gratitude for their efforts. Without them, this distribution would not exist. Additional thanks go to Frank Zappa and Pawar. Special thanks, of course, to Linus Torvalds.

Have a lot of fun!

Your SUSE Team
Contents

I Introducing Linux

1 First Contact

1.1 Logging In and Out ................................................. 4
   1.1.1 Introducing GDM ........................................... 4
   1.1.2 Introducing KDM ........................................... 5

1.2 The User Concept of Linux ...................................... 6

1.3 Desktop .................................................................... 7
   1.3.1 Desktop Terminology ......................................... 7
   1.3.2 Configuring Desktop Components ......................... 10
   1.3.3 Little Helpers .................................................. 13
   1.3.4 Switching Users ............................................... 14

1.4 File Management .................................................... 15
   1.4.1 The Concept behind a Linux File System ................. 15
   1.4.2 Different Flavors of Your File Manager .................. 16
   1.4.3 Searching Files ............................................... 16

1.5 Applications ......................................................... 17

1.6 Printing ................................................................. 18
   1.6.1 Managing Print Jobs in GNOME ............................ 18
   1.6.2 Managing Print Jobs in KDE ............................... 18

1.7 Basic Administrative Tasks ....................................... 22
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>8.4.3 Adding Address Books</td>
<td>138</td>
</tr>
<tr>
<td>8.5 Calendar</td>
<td>138</td>
</tr>
<tr>
<td>8.5.1 Scheduling an Event</td>
<td>139</td>
</tr>
<tr>
<td>8.5.2 Adding Calendars</td>
<td>140</td>
</tr>
<tr>
<td>8.6 Syncing Data with a Handheld</td>
<td>140</td>
</tr>
<tr>
<td>8.7 For More Information</td>
<td>140</td>
</tr>
<tr>
<td>9 Synchronizing a Handheld Computer with KPilot</td>
<td>141</td>
</tr>
<tr>
<td>9.1 Conduits Used by KPilot</td>
<td>142</td>
</tr>
<tr>
<td>9.2 Configuring the Handheld Connection</td>
<td>143</td>
</tr>
<tr>
<td>9.2.1 Configuring the Connection from within KPilot</td>
<td>143</td>
</tr>
<tr>
<td>9.2.2 Creating a /dev/pilot Link</td>
<td>144</td>
</tr>
<tr>
<td>9.3 Configuring the KAddressBook Conduit</td>
<td>144</td>
</tr>
<tr>
<td>9.4 Managing To-Do Items and Events</td>
<td>145</td>
</tr>
<tr>
<td>9.5 Working with KPilot</td>
<td>146</td>
</tr>
<tr>
<td>9.5.1 Backing Up Data from the Handheld</td>
<td>146</td>
</tr>
<tr>
<td>9.5.2 Installing Programs on the Handheld</td>
<td>147</td>
</tr>
<tr>
<td>9.5.3 Synchronizing Your Address Books and Calendars</td>
<td>147</td>
</tr>
<tr>
<td>III Internet</td>
<td>149</td>
</tr>
<tr>
<td>10 The Web Browser Konqueror</td>
<td>151</td>
</tr>
<tr>
<td>10.1 Tabbed Browsing</td>
<td>152</td>
</tr>
<tr>
<td>10.2 Saving Web Pages and Graphics</td>
<td>153</td>
</tr>
<tr>
<td>10.3 Internet Keywords</td>
<td>153</td>
</tr>
<tr>
<td>10.4 Bookmarks</td>
<td>154</td>
</tr>
<tr>
<td>10.5 Java and JavaScript</td>
<td>155</td>
</tr>
<tr>
<td>10.6 For More Information</td>
<td>155</td>
</tr>
</tbody>
</table>
11 Firefox

11.1 Navigating Web Sites .................................................. 158
11.1.1 Tabbed Browsing ..................................................... 159
11.1.2 Using the Sidebar ................................................... 159
11.2 Finding Information .................................................... 159
11.2.1 Using the Search Bar ............................................... 159
11.2.2 Using the Find Bar .................................................. 159
11.3 Managing Bookmarks .................................................. 160
11.3.1 Using the Bookmark Manager ................................... 160
11.3.2 Migrating Bookmarks ............................................... 160
11.4 Using the Download Manager ....................................... 160
11.5 Customizing Firefox ................................................... 161
11.5.1 Extensions ........................................................... 162
11.5.2 Changing Themes ................................................... 162
11.5.3 Adding Smart Keywords to Your Online Searches .......... 163
11.6 Printing from Firefox .................................................. 164
11.7 For More Information ................................................ 164

12 Encryption with KGpg .................................................. 165

12.1 Generating a New Key Pair .......................................... 166
12.2 Exporting the Public Key ............................................. 166
12.3 Importing Keys ........................................................ 168
12.3.1 Signing Keys ........................................................ 168
12.3.2 Trusting Keys ........................................................ 169
12.4 The Key Server Dialog ................................................. 170
12.4.1 Importing a Key from a Key Server ......................... 170
12.4.2 Exporting Your Keys to a Key Server ....................... 171
12.5 Text and File Encryption ............................................. 171
12.5.1 Encrypting and Decrypting the Clipboard .................. 172
12.5.2 Encrypting and Decrypting by Dragging and Dropping .... 172
12.5.3 The KGpg Editor .................................................. 173
12.6 For More Information ................................................ 173
### IV Multimedia

#### 13 Sound in Linux

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>13.1 Mixers</td>
<td>178</td>
</tr>
<tr>
<td>13.1.1 KMix</td>
<td>178</td>
</tr>
<tr>
<td>13.1.2 The GNOME Mixer Applet</td>
<td>178</td>
</tr>
<tr>
<td>13.1.3 alsamixer</td>
<td>179</td>
</tr>
<tr>
<td>13.1.4 Look and Feel of Mixer Applications</td>
<td>180</td>
</tr>
<tr>
<td>13.1.5 The Mixer for the Sound Chip Envy24</td>
<td>181</td>
</tr>
<tr>
<td>13.2 Multimedia Players</td>
<td>182</td>
</tr>
<tr>
<td>13.2.1 amaroK</td>
<td>182</td>
</tr>
<tr>
<td>13.2.2 XMMS</td>
<td>186</td>
</tr>
<tr>
<td>13.3 CDs: Playback and Ripping</td>
<td>187</td>
</tr>
<tr>
<td>13.3.1 KsCD—Audio CD Player</td>
<td>188</td>
</tr>
<tr>
<td>13.3.2 GNOME CD Player Applet</td>
<td>188</td>
</tr>
<tr>
<td>13.3.3 Compressing Audio Data</td>
<td>189</td>
</tr>
<tr>
<td>13.4 Hard Disk Recording with Audacity</td>
<td>192</td>
</tr>
<tr>
<td>13.4.1 Recording WAV Files and Importing Files</td>
<td>192</td>
</tr>
<tr>
<td>13.4.2 Editing Audio Files</td>
<td>193</td>
</tr>
<tr>
<td>13.4.3 Saving and Exporting</td>
<td>195</td>
</tr>
<tr>
<td>13.5 Direct Recording and Playback of WAV Files</td>
<td>195</td>
</tr>
</tbody>
</table>

#### 14 TV, Video, Radio, and Webcam

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>14.1 Watching TV with motv</td>
<td>198</td>
</tr>
<tr>
<td>14.1.1 Video Source and Network Search</td>
<td>198</td>
</tr>
<tr>
<td>14.1.2 Retrieving Audio Data</td>
<td>199</td>
</tr>
<tr>
<td>14.1.3 Screen Proportions and Full-Screen Mode</td>
<td>199</td>
</tr>
<tr>
<td>14.1.4 The Launcher Menu</td>
<td>200</td>
</tr>
<tr>
<td>14.2 Video Text Support</td>
<td>200</td>
</tr>
<tr>
<td>14.3 Webcams and motv</td>
<td>201</td>
</tr>
<tr>
<td>14.4 nxtvepg—The TV Magazine for Your PC</td>
<td>201</td>
</tr>
</tbody>
</table>
17 Kooka—A Scanning Application

17.1 The Preview ........................................... 229
17.2 The Final Scan ...................................... 229
17.3 The Menus .......................................... 231
17.4 The Gallery .......................................... 231
17.5 Optical Character Recognition .................... 232

18 Manipulating Graphics with The GIMP

18.1 Graphics Formats ................................... 236
18.2 Starting GIMP ........................................ 236
   18.2.1 Initial Configuration ......................... 236
   18.2.2 The Default Windows ....................... 237
18.3 Getting Started in GIMP ....................... 238
   18.3.1 Creating a New Image ..................... 238
   18.3.2 Opening an Existing Image ............... 239
   18.3.3 The Image Window ......................... 239
18.4 Saving Images ..................................... 240
18.5 Printing Images ................................... 241
18.6 For More Information ............................ 241

V Excursions

19 Working with the Shell

19.1 Introduction to Bash ............................. 246
   19.1.1 Commands .................................... 246
   19.1.2 Files and Directories ..................... 246
   19.1.3 Bash Functions .............................. 249
   19.1.4 Specifying Paths ......................... 250
   19.1.5 Wild Cards ................................. 251
   19.1.6 Less and More ............................. 252
19.1.7 Pipes .......................................... 252
Part I

Introducing Linux
This chapter guides you through the first encounter with your freshly installed Linux system. Learn all about the different components of your system environment. After this crash course, you should be fit to use and enjoy your SUSE LINUX system.
This chapter focuses on the installed system. It does not cover questions regarding the installation or hardware configuration procedures under SUSE LINUX. These procedures are covered in-depth in the *Administration Guide* and some of the most frequently encountered problems are dealt with in the SUSE LINUX FAQ at the end of this book.

## 1.1 Logging In and Out

If your computer is not run in a networking environment and you are the only person using it, your system automatically boots into the desktop environment. Once you have started your computer, there is no need for you to authenticate. This feature, called *auto login*, is only provided by the KDM display manager, however. It can be disabled at any time using the YaST user management module described in the *Administration Guide*.

If more than one user account is configured on your computer, any user must authenticate. After your SUSE LINUX system has started, you are prompted for your username and password.

Depending on the desktop environment installed, the program managing the login process and sessions is either GDM for GNOME desktops or KDM for KDE. GDM and KDM differ slightly in functionality, which is why they are treated separately. See Section 1.3 on page 7 for details on the desktop environments or refer to the separate GNOME or KDE chapters, Chapter 3 on page 47 or Chapter 4 on page 69.

### 1.1.1 Introducing GDM

A GDM login screen consists of two main components, the input field for username and password and a menu. See Figure 1.1 on the facing page.

The menu contains three items:

**Language**  Select the language to use in the following GNOME session. You may change the language temporarily for just the next session or set the choice permanently as your default.

**Session**  Determine the session type (GNOME, KDE, etc.). Change this setting only if you want to use something other than the system default. Future sessions will always be of the same type as the initial one, unless you
change the session type manually. If you change your session type manually, you will be asked whether the changes should be applied to the following sessions or whether they should be made default for all future sessions.

**Actions** Choose some system-related actions, such as shutting down the system, rebooting it, or configuring the login manager.

To terminate the session, choose ‘Log Out’ from the ‘System’ menu. Then determine whether you want to save the current state of your session, end your session and leave the system running, or restart or shut down on logout. Choose to save your session if you want to start your next one with exactly the same setup as when you leave.

### 1.1.2 Introducing KDM

A KDM login screen consists of two main elements. As shown in Figure 1.2 on the next page, it has input fields for username and password and a menu. The menu provides the following options:
Figure 1.2: A KDM Login Screen

**Session Type**  Determine the session type. Make changes only if you want to use a session type other than the default (KDE). Future sessions are automatically of the same type unless you change the session type manually.

**Menu**  ‘Remote Login’ enables you to log in on a remote machine. ‘Shutdown’ either turns the computer off completely or reboots the system.

To terminate the session, choose ‘Logout’ from the main menu. Then determine whether to end your session and leave the system running or restart or shut down on logout. If your system provides power management, you are offered to suspend the computer, making the next system start much faster than a complete boot.

## 1.2 The User Concept of Linux

Linux distinguishes between “ordinary” users and a superuser. The superuser, called **root**, takes care of all kinds of administrative tasks and has access to all
First Contact

parts of the system. Normal users lack these privileges.

All users including the superuser have their own home directories where all private data, like documents, bookmarks, or e-mail, are stored. Write access to these home directories is strictly limited to their respective owners. Folders in a home directory holding sensitive data can also be protected against read access by other users. System directories holding central configuration files or executable files can only be modified by the superuser. For more information about the Linux permission and user concept, refer to Section [19.2](#) on page [255](#).

While this concept may not look very appealing at first, it adds to security. A user without root privileges cannot damage the entire system. Any damage caused is strictly limited to the user’s own account and data. Any operation executed with root privileges may potentially harm the entire system. Anyone intending to harm a running Linux system must gain root privileges first. This is why it is much harder to create viruses for Linux systems. They have to overcome the root barrier first.

As well as offering different user identities for administrators and normal users, Linux supports multiple users working on one machine simultaneously. These users can connect to the system via different terminals or network connections.

### 1.3 Desktop

SUSE LINUX offers several choices for your desktop. GNOME and KDE, the most common desktops, provide features and functions similar to those of the desktop used in Microsoft Windows or Mac OS. This section introduces their most important features and helps you to get accustomed to your new desktop environment.

#### 1.3.1 Desktop Terminology

The following list introduces some terms often used in a desktop context, regardless of the base system. However, some of them have different meanings in different desktop environment or are even limited to one environment.

**desktop** The desktop is your primary work environment. It fills the screen, but is more than just a background. Put icons of your most frequently used applications or objects on the desktop for easy access.
Figure 1.3: An Example Desktop

**panel** The panel is a bar, typically located at the top or the bottom of the screen, that holds the menus, the quick launch area, a notification area or system tray, some little helper applications, and, in most cases, also the taskbar (called window list in GNOME). It is designed to provide all vital information needed about running applications or the system and to provide easy access to some important functions or applications. Both GNOME and KDE allow you to adjust the panel orientation (horizontal versus vertical) to your needs. In a KDE environment, you might also see “Kicker” as another word for the panel.

**menu button** Similar to the “start button” on the MS Windows desktop, Linux desktops normally contain a menu button at the left end of the panel that opens the main menu. This menu is a well-ordered structure for accessing the main applications or functions, such as “Search,” “Logout,” and “Lock Session.”

**taskbar or window list** The taskbar (window list in GNOME) is used to switch between different open windows. In Linux, it also provides an overview
of all virtual desktops available and provides a means to switch between them. The taskbar is part of the panel.

**quick launcher**  The quick launcher is part of the panel. It holds the icons for the most important functions or applications to enable you to start them without going through the applications menu.

**notification area or system tray**  The rightmost part of the panel holds the system clock, the volume control, and several other helper applications.

**applet**  An applet is a small application that is integrated into the panel. An application is a fully fledged computer program using its own window on screen.

**desktop icons**  Desktop icons reside on the desktop. They represent files, directories, applications or functions, and removable media, like CDs or DVDs. The best known desktop icon is probably the trash bin, where you can drop files you want to delete.

**virtual desktops or workspaces**  The concept of virtual desktops (workspaces in GNOME) is like having several desks at your office. You store things on all of them, but you only work at one of them at a time. You can devote each to different tasks or just use them as extra space. Virtual desktops enable you to have multiple windows open at the same time, but only look at one or some of them. Easily shift windows between virtual desktops, like shifting papers from one physical desk to another. All desktop environments offer a means to control the number and use of virtual desktops. A workspace switcher is provided in both the GNOME and the KDE panel.

**terminal**  A terminal enables you to send commands to the operating system. There are “real” (physical) terminals basically consisting of a display screen and a keyboard connected to the computer. Then there are terminal emulations, which run in a window on your desktop and offer a prompt where you can pass commands to the operating system.

**session**  Once you log in to your desktop, it starts a session for you. This session is valid until you log out again. A session includes the start-up and shutdown of certain programs on login and logout. These settings can be configured individually for each user account.
1.3.2 Configuring Desktop Components

Almost all desktop components can be configured individually. Right-clicking the respective element opens its context menu. To illustrate the procedure, we provide some examples.

Tip

Controlling the Desktop Configuration

Both GNOME and KDE feature a Control Center providing central access to all key configuration options of the desktop environment. Refer to Chapter 3 on page 47 or Chapter 4 on page 69 for details.

Configuring GNOME Desktop Components

Procedure 1.1: Adding a New Application to the Quick Launch Area

1. Right-click an empty patch of the panel where you want to add the new application.

2. Choose ‘Add to Panel’ from the menu that appears.


4. Select the application from the ‘Applications’ menu and quit the configuration.

Procedure 1.2: Changing the Desktop Background

1. Right-click the desktop.

2. Choose ‘Change Desktop Background’ from the menu that appears.

3. A dialog window appears, offering several options concerning the desktop. Either use the mouse cursor to select one of the existing wallpapers or click ‘Add’ to open a file dialog where you can add your own image. Use ‘Style’ to determine how the image should be rendered to fit into the dimensions of your display. Use ‘Remove’ to remove a selected background from the menu. If you prefer no background image at all, set a desktop color.

4. Your changes are applied automatically. Leave the dialog with ‘Close’.
**Procedure 1.3: Creating a New Desktop Icon**

1. Add a new application or service icon (called “Launcher” in GNOME):
   
   (a) Right-click the desktop to open the context menu.
   (b) Select ‘Create Launcher’ to open the appropriate dialog.
   (c) Enter ‘Name’, ‘Generic Name’, an optional ‘Comment’, and the ‘Command’ to execute. Determine whether the application should be run in a terminal and check whether ‘Type’ is set to the appropriate value, which is ‘Application’ for commands.
   (d) Apply your settings and leave the dialog with ‘OK’.

2. Add a new folder or document:
   
   (a) Right-click the desktop to open the context menu.
   (b) Select ‘Create Folder’ or ‘Create Document’ to add the new item to the desktop.
   (c) Right-click the new desktop icon and select ‘Properties’.
   (d) Enter the name of the new object in the ‘Basic’ tab. Select an appropriate icon via the ‘Emblems’ tab. Finally, determine the file system permissions assigned to this object using the ‘Permissions’ tab. Read more on file system permissions in Section 19.2 on page 255.
   (e) Close the ‘Properties’ dialog to apply your changes.

**Configuring KDE Desktop Components**

**Procedure 1.4: Adding a New Application to the Quick Launch Area**

1. Right-click an empty patch of the panel where you want to add the new application.
2. Choose ‘Add’ → ‘Application Button’ from the menu that appears.
3. Select the application from one of the categories of the submenu.

**Procedure 1.5: Changing the Desktop Background**

1. Right-click the desktop.

3. Choose ‘Background’ and determine whether your settings should be applied to one specific desktop or to all. Select a background image, disable background images, or start a slide show. ‘Options’ offers several settings for the positioning of the background image, the background color, and the blending of colored backgrounds.

4. Apply your changes and leave the dialog with ‘OK’.

Procedure 1.6: Creating a New Desktop Icon

1. Add a new folder icon:
   (a) Right-click the desktop to open the context menu.
   (b) Select ‘Create New’ → ‘Folder’.
   (c) Enter the name of the new folder when prompted to do so.
   (d) Right-click the new icon and select ‘Properties’ in the context menu that appears.
   (e) The ‘Properties’ dialog consists of four tabs: ‘General’, ‘Permissions’, ‘Meta Info’, and ‘Share’. Name and icon of the folder are set via the ‘General’ tab. Permissions are modified via ‘Permissions’. ‘Meta Info’ lists size and number of items of the new folder. ‘Share’ can be used to configure file sharing via NFS or Samba. For more information about these two protocols, refer to the Administration Guide.
   (f) Apply your changes and leave the dialog with ‘OK’.

2. Add a new file icon:
   (a) Right-click the desktop for the context menu to appear.
   (b) Select ‘Create New’.
   (c) Choose the appropriate file type from ‘HTML File’, ‘Link to Application’, ‘Link to Location’, or ‘Text File’.
   (d) Enter the name of the new file when prompted to do so.
   (e) Right-click the new icon and select ‘Properties’ in the context menu that appears.
First Contact


Apply your changes and leave the dialog with ‘OK’.

3. Add a new device icon:

(a) Right-click the desktop to open the context menu.
(b) Select ‘Create New’ → ‘Link to Device’.
(c) Choose the appropriate device type to open the ‘Properties’ dialog.
(d) The ‘Properties’ dialog consists of four tabs: ‘General’, ‘Permissions’, ‘Device’, and ‘Meta Info’. Set the name and icon of the device in the ‘General’ tab. Modify permissions in ‘Permissions’. ‘Device’ is used to set the device path, such as /media/dvd for your DVD drive, and several other options.
(e) Apply your changes and leave the dialog with ‘OK’.

1.3.3 Little Helpers

Both GNOME and KDE come with numerous little helper applications that can be included in your panel. If you want to add new ones or remove existing ones, proceed as described in Section 1.3.2 on page 10. The most prominent ones featured in both GNOME and KDE are SUSEWatcher and SUSE Hardware Tool.

**SUSEWatcher**  
SUSEWatcher is a program that is integrated into the system tray of the panel. It checks for new software updates. To be able to find any new updates, it requires an online connection. The status of SUSEWatcher is displayed in the panel by icons in different colors.

When you click the icon in the panel, a window opens, informing you about the status of your online updates and the availability of any new updates. You can also launch the check manually by clicking ‘Check for updates’. Start the online update by selecting ‘Start online update’ and entering the root password. The YaST Online Update window is displayed.

**SUSE Hardware Tool**  
The SUSE Hardware Tool keeps a list of all hardware components of your system. Left-click the panel icon to open a dialog window with a tree view featuring the major hardware categories. Configure a
new hardware item by selecting it and clicking ‘Configure’, which starts the appropriate YaST module after you provide the root password. Clicking ‘Details’ reveals all information present for the specific hardware item. As soon as new hardware is connected and recognized, a pop-up announces this new hardware.

1.3.4 Switching Users

Both GDM and KDM allow you to switch between different user accounts on the same system. You can stay logged in while other users work on your system. Your session is locked while you switch to another account, but your applications continue to run and your whole session remains unchanged.

**Switching Users in GNOME**

To open an additional session for another user, select ‘New Login’ from the GNOME ‘Applications’ menu. The other user enters username and password in GDM then another GNOME session starts. Your original session is locked automatically on the user switch. To change back into your original session, use \( \text{Ctrl-Alt-F7} \).

**Important**

**Switching Displays**

Your original session is started on the graphical console that can be reached with \( \text{Ctrl-Alt-F7} \). Additional sessions are started on the higher consoles, reachable via \( \text{F8} \) and higher.

**Switching Users in KDE**

Open an additional session in KDE via the main menu. Select ‘Switch User’ and determine whether your original session should be locked while you switch to another user account. KDM appears, requesting username and password for the new account. Enter the requested data and a new KDE session starts. To switch back to your original session, click ‘Switch User’ again. Select the session to which to switch.

Another way to start a new session is to lock your current session via ‘Lock Session’ then click ‘Switch User’ in the unlock dialog. This goes to the KDM login screen, where username and password for the new session can be entered.
1.4 File Management

A central part of your desktop environment is a file manager application, enabling you easily to create, access, and manage all files on your system. Traditional file management in Linux would have been done via the command line, requiring some deeper knowledge of several commands to list, create, delete, or edit files and their properties. A file manager provides a graphical and more intuitive way to handle these tasks. Learn more about the file managers of GNOME and KDE in Section 3.3 on page 57 and Section 4.3 on page 78.

1.4.1 The Concept behind a Linux File System

Unlike a Windows operating system, Linux does not use drive letters. In Windows, you would address the floppy drive as A: \, Windows system data is under C: \, and so on. In Linux, all files and directories are located in a tree-like structure. The topmost directory is referred to as the file system root or just / . All other directories can be accessed from here.

The following is a short guide through the Linux file system tree, introducing the most important directories:

/home/<username>    /home holds the private data of every user who has an account on your system. The files located here can only be modified by their owner or the system administrator. Your e-mail directory is located here, for example.

/media    /media generally holds any type of drive except the hard drive of your system. Your USB flash drive appears under /media once you have connected it, as does your digital camera (if it uses USB) or your DVD or CD drive. As soon as the data source is disconnected (think of an USB flash drive or your camera), the respective directory under media is removed as well.

/usr/share/doc    Under /usr/share/doc, find any kind of documentation on your Linux system and the installed packages. The manual subdirectory holds a digital copy of this manual as well as the Administration Guide and the release notes of the installed version of SUSE LINUX. The packages directory holds the documentation included in the software packages.

/windows    If you have both MS Windows and Linux installed on your system, this is where you find the MS Windows data.
Learn more about the Linux file system concept and find a more comprehensive list of directories in Section 19.1.2 on page 246.

### 1.4.2 Different Flavors of Your File Manager

Apart from organizing all your data and previewing almost any type of file, your file manager can act as a “quick finder” for personal data, system information, and network services. These modules are part of your standard desktop.

**Home Directory** Use the ‘Home’ desktop icon in GNOME or the icon depicting a small house in the KDE panel to launch your file manager (Nautilus in GNOME, Konqueror in KDE) showing all the contents of your home directory. This option allows you to quickly retrieve any personal data located in your home directory.

**Your System** If you need to know which hard drives or removable media are connected to your system, click the desktop icons ‘Computer’ (GNOME) or ‘My Computer’ (KDE). The file managers provide an overview of all drives attached to your system, including the hard drives. As you click one of the drives listed there, the file manager opens the files and directories located on this drive. This option allows you to locate data on any kind of removable device attached to your system. A digital camera appears in this list as does a USB flash or hard drive.

**Your Network** Use the ‘Places’ menu in the top GNOME panel to access network folders. In KDE, click the ‘Network Browsing’ desktop icon to gather all services provided in your network. Use this functionality to access available network shares and Windows networks, FTP servers, or any other service type that has been registered for your network.

### 1.4.3 Searching Files

If you need to search for certain file across the whole system, use the graphical search applications provided by your desktop environment. In GNOME, select ‘Places’ → ‘Search for Files’ to launch the search tool. The first dialog prompts you for the name or at least a part of the name of the file. Specify the directory to search for the file. If you know for sure the file should be located in your home directory, accept the /home/<username> path that has automatically been selected. To launch a search on the entire file system, select the file system root by
entering /. Refine your search by adding more search criteria. Click ‘Show more options’ and select any of the criteria offered there. It is even possible to use regular expressions or wild cards. As soon as you enter all data, hit ‘Find’ to launch the search and see the result in the bottom part of the window. Depending on the scope of your search, the whole process may take a considerable amount of time.

KDE contains the application KFind, which is launched from the main menu with ‘Find Files’. The search window is divided into the tabs ‘Name/Location’, ‘Contents’, and ‘Properties’. In the ‘Name/Location’ tab, enter the name of the file using wild cards, like asterisks or question marks, if needed. Enter the path to search and determine whether the search should include subfolders or be case sensitive. The ‘Contents’ tab is used to search the contents of files for certain expressions. This type of search is only supported for a limited number of file types, such as text files and OpenOffice.org or KWord formats. You can even use regular expressions if KRegExpEditor is installed (package kdeutils3-extra). To limit the scope of the search by providing attributes like file owner, file size, or modification date, use the ‘Properties’ tab.

**Tip**

### More Information about Search Patterns

For more information about search patterns and the use of wild cards or regular expressions, refer to Section 19.1 on page 246.

---

### 1.5 Applications

SUSE LINUX comes with a wealth of applications. There is a Linux option for almost any purpose. Quite often, you even find more than one suitable application for your purpose. Chapter 2 on page 31 provides a comprehensive list of applications you might look for when converting from MS Windows. There, easily find the Linux analog of your MS Windows application.

There are three different ways to launch an application in Linux. The easiest and most prominent one is the main menu of your desktop environment. Click at the leftmost edge of the panel to fold out the menu. Select the appropriate category to fold out a submenu holding the actual application names and icons.

Some applications do not appear in the main menu even though they are installed. To launch one of them, open the main menu then select ‘Run Application’ (GNOME) or ‘Run Command’ (KDE) and enter the name of the application.
in lowercase letters. Alternatively, start this dialog using Alt- F2. The third way to launch an application is to open a shell and enter the command at the shell prompt, also known as command line.

---

**Tip**

**Missing Applications**

If an application could not be started from the menu or the command line, you need to install it from your SUSE LINUX CD or DVD. See Section 1.7.1 on page 22 for details.

---

1.6 Printing

Printers can either be connected to your system locally or via a network. Either kind of configuration is made initially using YaST. For an in-depth coverage of printer configuration, refer to the printer chapter in the *Administration Guide*. As soon as a connection has been established, start using the printer. Both desktops provide applications enabling you to monitor and edit the print jobs queued at the selected printer.

1.6.1 Managing Print Jobs in GNOME

Start Cups Manager from the command line with `gnome-cups-manager` or from the main menu. A window opens showing any printers attached to your system. Double-click the icon representing the printer queue to monitor to open a window holding the list of print jobs. See Figure 1.4 on the next page.

The menu bar of the jobs window contains two menus, ‘Printer’ and ‘Edit’. Via the ‘Printer’ menu, pause the printer, print a test page, or modify the print properties (paper size and orientation, printout mode, and resolution). The ‘Jobs’ menu allows you to pause, resume, or remove any selected job that is not yet printing.

1.6.2 Managing Print Jobs in KDE

To control print jobs in KDE, use two different applications. Start and configure the print job with KPrinter then control the processing of the print job with KJob-Viewer.
Start KPrinter with the command `kprinter` from the command line. A small window opens in which to choose a printer and edit the ‘Properties’ of your print job, such as page orientation, pages per sheet, and duplex printing. To specify the file to print, the number of copies, and various other options, click ‘Expand’ at the bottom left. The window then expands and shows four tabs: ‘Files’, ‘Copies’, ‘Advanced Options’, and ‘Additional Tags’. See Figure 1.5 on the following page.

The first tab, ‘Files’, determines the file or files to print. Either drag them from the desktop and drop them into the list window or use the file dialog to locate them. ‘Copies’ determines the page selection (all pages of the selected document, the currently selected one, or a range) and the number of copies. You may also choose to print only the even or only the odd numbered pages of the selected document. Use ‘Advanced Options’ to specify any additional information for the print job. Enter any ‘Billing information’ if needed or set a custom page label at the top and bottom of the page. The ‘Job Priority’ can also be set here. The fourth tab, ‘Additional Tags’ is hardly ever needed. Once your print job has been filed, you can watch its progress using KJobViewer.

**Tip**

**Printing from KDE Applications**

The KPrinter dialog opens any time you print from a KDE application. The dialog is basically the same except for the lack of the ‘Files’ tab, which is not needed because the file to print has already been determined when you clicked the ‘Print’ button.
Start KJobViewer from the main menu or with the command `kjobviewer` from the command line. A window like that in Figure 1.6 on the next page opens, listing all the print jobs queued on your printer. As long as your print job is not active, you can edit it. Do this using the entries of the ‘Jobs’ menu.

If, for example, you want to check if you sent the correct document to the printer, you can stop the job and resume it if you decide to print it. Remove your own print jobs from the queue with ‘Remove’. To change the printer, select a different printer with ‘Move to Printer’.

First Contact

Figure 1.6: Managing Print Jobs with KJobViewer

you need the document.

‘Filter’ enables you to switch between various printers, toggle completed jobs, and limit the view to your own print jobs by selecting ‘Show Only User Jobs’. The current user is then displayed in the top right field.

‘Settings’ ➝ ‘Configure KJobViewer’ opens a configuration dialog. Here, determine the maximum number of print jobs to display. Enter a number in the field or use the slider to the right to determine a value. Press ‘OK’ to save the setting or ‘Cancel’ to exit the dialog without saving.

The icons in the toolbar correspond to the functions you can access by way of the menu. A help text explaining the function is displayed when you move the mouse pointer over one of the icons.

The job list consists of eight columns. The job ID is automatically assigned by the print system to identify the various jobs. The next column contains the login of the user who sent the job followed by the filename of the document. The status column indicates whether a job is still in the queue, currently being printed, or already completed. Next, the size of the document is displayed in kilobytes and number of pages. The default priority of 50 can be increased or reduced if necessary. Billing information can be cost centers or other company-specific information. If you right-click a job in the list, the ‘Jobs’ menu opens under the mouse pointer, allowing you to select an action. Only a few functions are available for completed jobs. If you activate ‘Keep window permanent’, KJobViewer opens automatically when you log in the next time.
1.7 Basic Administrative Tasks

In SUSE LINUX, YaST handles the system installation and configuration. The following sections introduce some frequently needed functions of this tool. Refer to the Administration Guide for a detailed description of YaST and background information about system administration.

1.7.1 Installing New Applications

To install a new application, start YaST from the main menu. Provide the root password when requested to do so. Check whether the installation source is valid in the ‘Change Source of Installation’ module. If you intend to install from the original SUSE LINUX CDs or DVDs, the active installation path should begin with cd:// or dvd://. If you intend to install from a network installation path, ask your system administrator for the full data, select ‘Add’ and the type of network source, and enter the full path. Leave the dialog with ‘Finish’.

Start the YaST ‘Install and Remove Software’ module. Enter the name of the desired application in the ‘Search’ bar and hit ‘Search’. Any packages matching your search criterion are listed in the right part of the window. If you want to install one of these packages, select the check box next to the package’s name and click ‘Accept’. YaST automatically resolves all package dependencies—if there is any additional software component required to run the application chosen, YaST automatically installs the missing package. To finish, YaST runs some scripts to update the system configuration. Leave YaST and your freshly installed application is ready to run. For a detailed description of the YaST software module, refer to the Administration Guide.

1.7.2 Retrieving and Applying Software Updates

Make sure that your system is up-to-date and contains the recent software and security fixes by constantly running SUSEWatcher. If configured accordingly, it automatically informs you about the availability of any software updates (see also Section 1.3.3 on page 13). Launch the YaST ‘Online Update’ and provide the root password. Select an appropriate installation source and hit ‘Next’. A dialog similar to the one in Section 1.7.1 on the current page opens, showing all patches that are available for update. SUSE patches may fall in any of the following three categories: security (security-sensitive patches that should always be installed to maintain a secure system), recommended (improvements to packages already
installed), and other (other patches available for update not relevant to any of
your installed packages). Security updates are marked in red and are preselected
along with the blue recommended patches. Accept this proposal to keep your
system consistent. Click ‘Accept’ to apply the updates. For more information
about the YaST Online Update, refer to the Administration Guide.

1.8 Security

If converting to a Linux system from a Microsoft Windows system, you proba-
bly experienced a fair share of trouble caused by multiple kinds of viruses and
worms spreading over the Internet via e-mail. Now that you have made the
switch to Linux, you can at least put that fear aside, because these cannot harm
a Linux system as easily as a Windows system.

As mentioned in Section 1.2 on page 6 Linux knows two different kinds of users,
a superuser (root) and normal users. root has access to all system resources
and is allowed to change all aspects of the system’s configuration. Switching from
your normal user account to root for administrative tasks and switching back
for your normal work sounds tedious and perhaps unnecessary because root
has ultimate power over the system. Still, switching back to the normal user ac-
count after accomplishing the administrative jobs adds to security, because any
mistake made as root can have severe consequences. The whole system might
be affected, not just the normal user account. Thus, preserve your system’s in-
tegrity by clearly distinguishing between the different roles (“normal user” and
“superuser”).

Keeping your system up to date by always applying the software updates pro-
vided by SUSE (see Section 1.7.2 on the preceding page) adds to the security of
your system. These updates fix possible exploits contained in the application
code.

Protect your system or your network against external “visitors” by running a fire-
wall. A preconfigured firewall is started on installation, providing maximum se-
curity to your network. If you need to add support for certain services and do
not maintain your system yourself, ask your system administrator to make the
necessary adjustments in the firewall settings. Otherwise read the chapter about
security in the Administration Guide and learn how to secure your network using
SuSEFirewall.
1.9 Networking and Mobility

GNOME and KDE offer several applications for working in a network environment or using a mobile computer. It is much more convenient and much easier to click a small icon to connect to or disconnect from a network than to manually run some script. Monitoring the power state of your mobile computer via a small icon is easier than watching obscure system messages. The following sections introduce some of these little helpers, but many more are offered by your desktop environment.

1.9.1 Networking

Network connections, even wireless ones, can be easily configured and monitored by small applications seamlessly integrating into your desktop panel. KInternet can be used to configure and monitor any kind of network connection. Network Monitor in GNOME and Wireless Network Information in KDE can be used to monitor the state of your wireless link.

**Important**

**Network Configuration**

The initial configuration of any network connection is made with YaST, the SUSE LINUX configuration management tool. Find information about this in the *Administration Guide*.

**KInternet—Connecting to the Internet**

After your network device has been configured correctly, control the Internet dial-up with KInternet. On start-up, KDE loads KInternet. The program checks whether an Internet connection can be established. If this is possible, the application icon, a plug, automatically appears in the right part of the KDE panel. Depending on the state of the network connection, the panel icon changes appearance:

- Currently there is no connection to the Internet.
- The connection is just being established or terminated.
The connection has been established.

Data is transmitted to or from the Internet.

An error has occurred. If a connection has already been configured with YaST, use ‘View Log’ to identify the reason for the error. The menu can be accessed by right-clicking the KInternet icon.

The connection is not yet active, but will be established as soon as a request is made.

Right-click the KInternet panel icon to access its configuration menu. The YaST configuration dialog can be started via ‘Settings’ → ‘Configure with YaST’. After entering the root password, YaST starts. Depending on the access type, start the modem, ISDN, network, or DSL configuration of YaST.

If you are using an ISDN connection and you have selected ‘Channel Bundling’ in YaST, a second ISDN channel can be added to an existing connection with ‘Add link’. This doubles the transfer rate (although at a higher price). Activate channel bundling if you need to download large files. The activated channel bundling is evident from the red plus symbol at the top left corner of the KInternet icon.

If your computer has more than one network device and you have configured all of them with YaST, you can use the KInternet option ‘Interface’ to switch between these interfaces. You must have selected ‘User Controlled’ device activation in the appropriate YaST network dialog to do this. If you have multiple providers as well, choose them using the ‘Provider’ switch of KInternet. Providers are also set in YaST.

Users who want to establish Internet connections automatically can use *dial on demand* (DoD). If this mode is selected, KInternet automatically connects to your Internet service provider (ISP) as soon as a request is submitted. After a certain time-out, the connection is terminated. A DoD connection is evident from the blue D at the bottom right corner of the KInternet icon.
Warning

Cost Control

Note that DoD only makes sense if you have a flat rate Internet account. If that is not the case, connecting and disconnecting all the time can become very costly.

If you intend to use a wireless network card as your connection to the Internet, configure it using YaST as described in the Administration Guide and make sure that the device activation in YaST is set to ‘User Controlled’. As soon as the interface is configured, you can use KInternet to control your wireless network connection, just as you would for normal network interfaces.

To access the WLAN functionality of KInternet, right-click the icon to open the menu. Select ‘Wireless Connection’ and a window showing two tabs opens. First, scan for suitable wireless networks you could connect to. Select the tab ‘Scan for Wireless Networks’, shown in Figure 1.7 on this page.

![Figure 1.7: KInternet: Scanning for Wireless Networks](image)

Start the scan with ‘Start Scan’. For KInternet to continuously scan the network environment, also select ‘Auto Refresh’. Acoustic feedback for each connection found can be activated via ‘Acoustic Scan’. Any connection found is displayed in the list window. Select one and click ‘Connect’ to connect to the selected network. If additional configuration efforts are needed to connect to the selected network,
click ‘Start YaST’ to launch the YaST network module for wireless network devices.

![Figure 1.8: KInternet: Status of Wireless Link](image)

The ‘Current Connection’ tab allows you to monitor the state of your current wireless connection. The left-hand view of this tab offers a summary of all connection parameters regarding network address and ESSID, signal quality, signal and noise level, channel frequency and speed, and encryption parameters, such as type of encryption and key length. Select any of these parameters in the tree structure and check the details displayed in the right part of the window.

**Monitoring Wireless Connections**

Add Network Monitor to your GNOME panel to get visual feedback on the quality of your wireless connection. Right-click the panel icon and select ‘Preferences’ to set the monitor to the correct device if you have more than one wireless device connected to your machine.

Add Wireless Network Information to your KDE panel to monitor the state of your wireless connection. Clicking the panel icon reveals the details of your wireless connection, including network name (ESSID), link quality, signal strength, noise level, bit rate, and encryption method. If you have more than one wireless device, switch between them using the drop-down menu at the top right. If you touch the panel icon with the mouse cursor, a tool tip opens showing device name, link quality, and current bit rate.
1.9.2 Mobile Computing

Working on a mobile computer requires a great deal of flexibility in adjusting to changing network and system environments. SUSE LINUX offers small helpers, like GNOME Battery Charge Monitor, KPowersave, and Profile Chooser, which assist you in adjusting the power management scheme and the system configuration of your computer.

Tip

More Information about Mobile Computing

Refer to the Administration Guide to learn more about mobile computing under SUSE LINUX. Get an introduction to the software components involved and learn how to configure your mobile devices for maximum flexibility.

Tip

Power Management

Successfully working on battery power requires a very sophisticated handling of the system resources by the operating system. Mobile hardware is optimized to allow a very flexible management of power usage by the CPU and other components. Depending on the environment in which the system is run, the power management can easily be adjusted in SUSE LINUX using GNOME Battery Charge Monitor or KDE KPowersave.

Battery Charge Monitor allows you to send your machine into a hibernation state (‘Suspend Computer’) in which the entire system state is written to disk prior to shutdown. Once reactivated, this state is recovered. Configure the power management settings via ‘Power Management Settings’. The YaST Power Management module is launched enabling you to configure all power management settings centrally.

Using KPowersave, you can start the YaST Power Management module and issue both a suspend to disk or a suspend to RAM (if configured accordingly with YaST). You may change the CPU frequency policy, meaning your system either lets the CPU frequency drop when the system is idle and adjusts it dynamically if more CPU power is needed (set the CPU frequency policy to ‘Dynamic’), permanently keeps a low CPU frequency to save power (select ‘Powersave’), or permanently keeps a high CPU frequency for maximum CPU performance (select ‘Performance’). If you change the active power management scheme (‘Set Active
First Contact

Scheme’), all components of your system are part of the powersaving effort. A power management scheme includes settings for CPU frequency scaling, throttling, hard disk control, and for the cooling of the system. To start this program in a GNOME environment, enter kpowersave at the ‘Run Application’ terminal.

Profile Management

Your system needs to adapt to changing operating environments when used for mobile computing. A lot of services depend on the environment and the underlying clients must be reconfigured. Use the system configuration profile management (SCPM) framework to create different configuration profiles for all environments your machine is used in. Change the active profile using Profile Chooser.

To modify your SCPM settings, select ‘Select YaST Profile Manager Module’ and enter the root password when prompted to do so. Start Profile Chooser in KDE using the main menu. In GNOME, enter profile_chooser at the ‘Run Application’ terminal.

1.10 Using the Shell

Most tasks in Linux can be conveniently handled via a graphical user interface. Some tasks, mainly system administrator’s ones, can be handled more efficiently on the command line from a terminal or shell. A basic understanding of how a Linux shell works and knowledge of some basic command line tools is required for this. Refer to Chapter 19 on page 245 to get to know the Bash shell and some Linux command line tools.
Getting to Know Linux Software

Linux comes with a wealth of applications, often offering more than one solution to your specific problems. The difficulty is finding the one application that suits your needs and offers a similar ease of use compared to the Windows or Mac applications you have been using so far. This chapter points out the most important and powerful Linux applications, enabling you to change into your new working environment smoothly.
The next few sections introduce some of the most powerful Linux counterparts of common Windows software. Each section is dedicated to one particular field of application and lists the tasks, Windows applications, and Linux equivalents. These applications are then discussed in further detail and links to more information are provided. This list can be by no means complete, because software development is an evolutionary process and new applications are being created every minute.

### 2.1 Office

The following section features the most popular and powerful Linux office and business software solutions. These include office suites, databases, accounting software, and project management software.

**Table 2.1: Office Software for Windows and Linux**

<table>
<thead>
<tr>
<th>Task</th>
<th>Windows Application</th>
<th>Linux Application</th>
</tr>
</thead>
<tbody>
<tr>
<td>Office Suite</td>
<td>MS Office, StarOffice, OpenOffice.org</td>
<td>OpenOffice.org, StarOffice</td>
</tr>
<tr>
<td>Word Processor</td>
<td>MS Word, StarOffice/OpenOffice.org, Writer, WordPerfect</td>
<td>OpenOffice.org/StarOffice Writer</td>
</tr>
<tr>
<td>Spreadsheet</td>
<td>MS Excel, StarOffice/OpenOffice.org Calc</td>
<td>OpenOffice.org/StarOffice Calc</td>
</tr>
<tr>
<td>Presentation</td>
<td>MS PowerPoint, StarOffice Presentation, OpenOffice.org Impress</td>
<td>OpenOffice.org Impress, StarOffice Presentation</td>
</tr>
<tr>
<td>Data Plotting</td>
<td>MS Excel, MicroCall Origin</td>
<td>OpenOffice.org Calc, Gnuplot</td>
</tr>
<tr>
<td>Local Database</td>
<td>MS Access, OpenOffice.org + MySQL</td>
<td>OpenOffice.org + MySQL, Rekall, knoda, PostgreSQL</td>
</tr>
<tr>
<td>Financial Accounting</td>
<td>MS Money, Quicken, moneyplex</td>
<td>GnuCash, moneyplex</td>
</tr>
<tr>
<td>Project Management</td>
<td>MS Project</td>
<td>Planner, Taskjuggler</td>
</tr>
</tbody>
</table>
OpenOffice.org  OpenOffice.org is the Open Source answer to MS Office. It is a very powerful office suite including a word processor (Write), a spreadsheet and database manager (Calc), a presentation manager (Impress), and a drawing program (Draw). Users familiar with the MS Office family of applications find a very similar application interface and all the functionality to which they are accustomed. Because OpenOffice.org is capable of importing data from MS Office applications, the transition from one office suite to the other is very smooth. A Windows version of OpenOffice.org even exists, enabling Windows users to switch to an Open Source alternative while still using Windows. Find more information about OpenOffice.org at [http://www.openoffice.org/](http://www.openoffice.org/) and read Chapter 6 on page 109 for an introduction to OpenOffice.org and a short guide to migrating your data from one office suite to the other.

StarOffice  StarOffice is a proprietary version of OpenOffice.org and is distributed by Sun Microsystems. It is available on multiple platforms including Windows and Solaris. It includes certain advanced features not available with the free version (OpenOffice.org). Find more information about StarOffice at [http://www.sun.com/software/star/staroffice/](http://www.sun.com/software/star/staroffice/).

Gnuplot  Gnuplot is a very powerful and portable command-line controlled data plotting software. It is also available for MacOS and Windows platforms. Plots created by Gnuplot can be exported to various formats, such as PostScript, PDF, SVG, and others, allowing you to process these plots easily. Find more information about Gnuplot at [http://www.gnuplot.info/index.html](http://www.gnuplot.info/index.html).

Rekall  Rekall is a tool to manipulate databases. Supported databases include MySQL, PostgreSQL, XBase with XBSQL, IBM DB2, and ODBC. Use Rekall to generate different sorts of reports and forms, design database queries, or import and export data to various formats. Find more information about Rekall at [http://www.thekompany.com/products/rekall/](http://www.thekompany.com/products/rekall/).

knoda  knoda is a database front-end to various different types of databases. It supports connections to MySQL, PostgreSQL, SQLite, and ODBC database servers. knoda can be used for manipulating data in tables, creating and storing queries, and importing and exporting data in CSV format. Find more information about knoda at [http://www.knoda.org/](http://www.knoda.org/).
PostgreSQL PostgreSQL is an object-relational database management system that supports an extended subset of the SQL standard, including transactions, foreign keys, subqueries, triggers, and user-defined types and functions. Find more information about PostgreSQL at http://www.postgresql.org/.

GnuCash GnuCash is a software tool to control both your personal and business finances. Keep track of income and expenses and manage your bank accounts and stock portfolios all using one piece of software. Learn more about GnuCash at http://www.gnucash.org.

moneyplex moneyplex is a tool to control your finances. All tasks from managing incoming resources and expenses and monitoring your stock portfolio to online transactions via the HBCI standard are handled by moneyplex. Keep track of your financial transactions over time using various analysis options. Because this tool is also available for Windows, users can migrate very easily without having to learn a whole new application interface. More information about moneyplex can be found at http://www.matrica.de.

Planner Planner is a project management tool aiming to provide functionality similar to the project management tools used under Windows. Among its various features are Gantt charting abilities, different kinds of views on tasks and resources, and much more. Find more information about Planner at http://www.imendio.com/projects/planner/.

Taskjuggler Taskjuggler is a lean, but very powerful project management software. Take control of your projects using the Gantt charting features or by generating all kinds of reports (in XML, HTML, or CSV format). Those users who are not comfortable with controlling applications via the command line can use a graphical front-end to Taskjuggler. Find more information about Taskjuggler at http://www.taskjuggler.org.

VYM (View Your Mind) VYM is a software for visualizing your thoughts by creating and manipulating mind maps. Most manipulations do not require more than one mouse click. Branches can be inserted, deleted, and reordered very easily. VYM also offers a set of flags allowing you to mark certain parts of the map (important, time critical, etc.). Links, notes, and images can be added to a mind map as well. VYM mind maps use an XML format, allowing you to export your mind maps to HTML easily. Find more information about VYM at http://www.insilmaril.de/vym.
2.2 Network

The following section features various Linux applications for networking purposes. Get to know the most popular Linux browsers and e-mail and chat clients.

Table 2.2: Network Software for Windows and Linux

<table>
<thead>
<tr>
<th>Task</th>
<th>Windows Application</th>
<th>Linux Application</th>
</tr>
</thead>
<tbody>
<tr>
<td>Web Browser</td>
<td>Internet Explorer, Firefox, Opera</td>
<td>Konqueror, Firefox, Opera</td>
</tr>
<tr>
<td>E-Mail Client/Personal Information Management</td>
<td>MS Outlook, Lotus Notes</td>
<td>Evolution, Kontakt</td>
</tr>
<tr>
<td>Instant Messaging/IRC Clients</td>
<td>MSN, AIM, Yahoo Messenger, XChat</td>
<td>Kopete, Gaim, XChat</td>
</tr>
<tr>
<td>Conferencing (Video and Audio)</td>
<td>NetMeeting</td>
<td>GnomeMeeting</td>
</tr>
<tr>
<td>Voice over IP</td>
<td>X-Lite</td>
<td>kphone, Skype</td>
</tr>
<tr>
<td>FTP Clients</td>
<td>leechftp, wsftp</td>
<td>gftp, kbear</td>
</tr>
</tbody>
</table>

**Konqueror** Konqueror is a multitalented application created by the KDE developers. It acts as file manager and document viewer, but is also a very powerful and highly customizable Web browser. It supports the current Web standards, such as CSS(2), Java applets, JavaScript and Netscape plug-ins (Flash and RealVideo), DOM, and SSL, for example. It offers neat helpers like an integrated search bar and supports tabbed browsing. Bookmarks can be imported from various other Web browsers like Internet Explorer, Mozilla, and Opera. Find more information about Konqueror at [http://www.konqueror.org/](http://www.konqueror.org/) and read our introduction to using Konqueror in Chapter 10 on page 151.

**Firefox** Firefox is the youngest member of the Mozilla browser family. It runs on various platforms, including Linux, MacOS, and Windows. Its main features include built-in customizable searches, pop-up blocking, RSS newsfeeds, password management, tabbed browsing, and some advanced se-
security and privacy options. Firefox is very flexible, allowing you to customize almost anything you want (searches, toolbars, skins, buttons, etc.). Neat add-ons and extensions can be downloaded from the Firefox Web site (https://addons.update.mozilla.org/?application=firefox). Find more information about Firefox at http://www.mozilla.org/products/firefox/ and read our introduction to using Firefox in Chapter 11 on page 157.

**Opera** Opera is a powerful Web browser with neat add-ons like an optional email client and a chat module. Opera offers pop-up blocking, RSS feeds, built-in and customizable searches, a password manager, and tabbed browsing. The main functionalities are easily reached via their respective panels. Because this tool is also available for Windows, it allows a much easier transition to Linux for those who have been using it under Windows. Find more information about Opera at http://www.opera.com/.

**Evolution** Evolution is personal information management software for the GNOME desktop combining mail, calendar, and address book functionality. It offers advanced e-mail filter and search options, provides sync functionality for Palm devices, and allows you to run Evolution as an Exchange or GroupWise client to integrate better into heterogenous environments. Find more information about Evolution at http://www.gnome.org/projects/evolution/ and read our introduction to using Evolution in Chapter 7 on page 117.

**Kontact** Kontact is the KDE personal information management suite. It includes e-mail, calendar, address book, and Palm sync functionalities. Like Evolution, it can act as an Exchange or GroupWise client. Kontact combines several stand-alone KDE applications (KMail, KAddressbook, KOrganizer, and KPilot) to form an entity providing all the PIM functionality you need. Find more information about Kontact at http://www.kontact.org/ and read our introduction to using Kontact in Chapter 8 on page 129.

**Kopete** Kopete is a very intuitive and easy-to-use instant messenger tool supporting protocols including IRC, ICQ, AIM, GroupWise Messenger, Yahoo, MSN, and Jabber. Find more information about Kopete at http://kopete.kde.org/ and read an introduction to using Kopete in Section 4.4.8 on page 91.

**Gaim** Gaim is a smart instant messenger program supporting multiple protocols like AIM and ICQ (Oscar protocol), MSN Messenger, Yahoo!, IRC, Jabber, SILC, and GroupWise Messenger. It is possible to log in to different ac-
counts on different IM networks and chat on different channels simultaneously. Gaim also exists in a Windows version. Find more information about Gaim at http://gaim.sourceforge.net/about.php.

**XChat**  
XChat is an IRC client that runs on most Linux and UNIX platforms as well as under Windows and MacOS X. Find more information about XChat at http://www.xchat.org/.

**GnomeMeeting**  
GnomeMeeting is the Open Source equivalent of Microsoft’s NetMeeting. It features LDAP and ILS support for address lookup and integrates with Evolution to share the address data stored there. GnomeMeeting supports PC-to-phone calls, allowing you to call another party with just your computer, sound card, and microphone without any additional hardware. Find more information about GnomeMeeting at http://www.gnomemeeting.org/.

**KPhone**  
KPhone is a program to initiate Voice over IP connections across the Internet. Find more information at http://www.wirlab.net/kphone.

**gftp**  
gftp is an FTP client using the Gtk toolkit. Its features include simultaneous downloads, resume of interrupted file transfers, file transfer queues, download of entire directories, FTP proxy support, remote directory caching, passive and nonpassive file transfers, and drag and drop support. Find more information at http://gftp.seul.org.

**kbear**  
KBear is a KDE FTP client with the ability to have concurrent connections to multiple hosts, three separate view modes, support for multiple protocols (like ftp, sftp, etc.), a site manager plug-in, firewall support, logging capabilities, and much more. Find more information at http://kbear.sourceforge.net.

### 2.3 Multimedia

The following section introduces the most popular multimedia applications for Linux. Get to know media players, sound editing solutions, and video editing tools.
### Table 2.3: Multimedia Software for Windows and Linux

<table>
<thead>
<tr>
<th>Task</th>
<th>Windows Application</th>
<th>Linux Application</th>
</tr>
</thead>
<tbody>
<tr>
<td>Audio CD Player</td>
<td>CD Player, Winamp, Windows Media Player</td>
<td>KsCD, Grip</td>
</tr>
<tr>
<td>CD Burner</td>
<td>Nero, Roxio Easy CD Creator</td>
<td>K3b</td>
</tr>
<tr>
<td>CD Ripper</td>
<td>WMPlayer</td>
<td>Grip, kaudiocreator</td>
</tr>
<tr>
<td>Audio Player</td>
<td>Winamp, Windows Media Player</td>
<td>amaroK, XMMS</td>
</tr>
<tr>
<td>Video Player</td>
<td>Winamp, Windows Media Player</td>
<td>Kaffeine, MPlayer, Xine, XMMS</td>
</tr>
<tr>
<td>Audio Editor</td>
<td>SoundForge, Cooledit, Audacity</td>
<td>Audacity</td>
</tr>
<tr>
<td>Sound Mixer</td>
<td>sndvol32</td>
<td>alsamixer, Kamix</td>
</tr>
<tr>
<td>Music Notation</td>
<td>Finale, SmartScore, Sibelius</td>
<td>Noteedit, LilyPond, Rosegarden</td>
</tr>
<tr>
<td>Video Creator and Editor</td>
<td>Windows Movie Maker, Adobe Premiere, Media Studio Pro, MainActor</td>
<td>MainActor, Kino</td>
</tr>
<tr>
<td>TV Viewer</td>
<td>AVerTV, PowerVCR 3.0, CinePlayer DVR</td>
<td>xawtv (analog), motv (analog), xawtv4, tvtime, kdetv, zapping</td>
</tr>
</tbody>
</table>

**KsCD**  KsCD is a neat little CD player application for the KDE desktop. Its user interface very much resembles that of a normal hardware CD player, guaranteeing ease of use. KsCD supports CDDB, enabling you to get any track and album information either from the Internet or your local file system. Find more information at [http://docs.kde.org/en/3.3/kdemultimedia/kscd/](http://docs.kde.org/en/3.3/kdemultimedia/kscd/).

**Grip**  Grip provides CD player and ripper functionalities for the GNOME desktop. It supports CDDB lookups for track and album data. Ripping can be done using the built-in cdparanoia capabilities or via external rippers. Find more information at [http://www.nostatic.org/grip/](http://www.nostatic.org/grip/).
K3b  K3b is a multitalented media creation tool. Create data, audio, or video CD and DVD projects by dragging and dropping. Find more information about K3b at http://www.k3b.org/ or refer to Chapter 15 on page 209.

Kaffeine  Kaffeine is a versatile multimedia application supporting a wide range of audio and video formats including Ogg Vorbis, WMV, MOV, and AVI. Import and edit playlists of various types, create screenshots, and save media streams to your local hard disk. Find more information about Kaffeine at http://kaffeine.sourceforge.net/.

amaroK  The amaroK media player handles various audio formats and plays the streaming audio broadcasts of radio stations on the Internet. The program handles all file types supported by the sound server acting as a backend—currently aRts or GStreamer. Find more information about amaroK at http://amarok.kde.org/ or refer to Section 13.2.1 on page 182.

XMMS  XMMS is the traditional choice for multimedia playback. It is focused on music playback, offering support for CD playback and Ogg Vorbis files. Users of Winamp should find XMMS comfortable because of its similarity. Find more information about XMMS at http://www.xmms.org/ or refer to Section 13.2.2 on page 186.

Audacity  Audacity is a powerful, free sound editing tool. Record, edit, and play any Ogg Vorbis or WAV file. Mix tracks at your whim and apply effects to them and export the results to WAV or Ogg Vorbis. Find more information about Audacity at http://audacity.sourceforge.net/ or refer to Section 13.4 on page 192.

Noteedit  Noteedit is a powerful score editor for Linux. Use it to create sheets of notes and to export and import scores to and from many formats, such as MIDI, MusicXML and LilyPond. Find more information about Noteedit at http://developer.berlios.de/projects/noteedit/.

LilyPond  LilyPond is a free music sheet editor. Because the input format is text-based, you can use any text editor to create note sheets. Users do not need to tackle any formatting or notation issues, like spacing, line-breaking, or polyphonic collisions. All these issues are automatically resolved by LilyPond. It supports many special notations like chord names and tablatures. The output can be exported to PNG, TeX, PDF, PostScript, and MIDI. Find more information about LilyPond at http://lilypond.org/web/.
**Rosegarden**: Rosegarden is a free music composition and editing environment. It features an audio and MIDI sequencer and a score editor. Find more information about Rosegarden at [http://rosegardenmusic.com/](http://rosegardenmusic.com/).

**MainActor**: MainActor is a fully fledged video authoring software. Because there is a Windows version of MainActor, transition from Windows is easy. Find more information about MainActor at [http://www.mainactor.com/](http://www.mainactor.com/).

**xawtv and motv**: xawtv is a TV viewer and recorder application supporting analog TV. motv is basically the same as xawtv, but with a slightly different user interface. Find more information on the xawtv project at [http://linux.bytesex.org/xawtv/](http://linux.bytesex.org/xawtv/).

**xawtv4**: xawtv4 is a successor of the xawtv application. It supports both analog and digital audio and video broadcasts. The xawtv4 package contains several useful applications apart from the TV viewer: pia4 (a command-line controlled movie player for streams recorded by xawtv4), mtt4 (a video text browser), alexplore (a DVB channel scanner; built-in), dvbradio (a DVB radio player; needs an initial channel scan), and dvbrowse (an EPG browser). For more information, refer to [http://linux.bytesex.org/xawtv/](http://linux.bytesex.org/xawtv/).

**tvtime**: tvtime is a lean TV viewer application supporting analog TV. Find more information about tvtime, including a comprehensive usage guide, at [http://tvtime.sourceforge.net/](http://tvtime.sourceforge.net/).

**kdetv**: A TV viewer and recorder application for the KDE desktop supporting analog TV. Find more information about kdetv at [http://www.kdetv.org/](http://www.kdetv.org/).

**zapping**: A TV viewer and recorder application for the GNOME desktop supporting analog TV. Find more information about Zapping at [http://zapping.sourceforge.net/cgi-bin/view/Main/WebHome](http://zapping.sourceforge.net/cgi-bin/view/Main/WebHome).

### 2.4 Graphics

The following section presents some of the Linux software solutions for graphics work. These include simple drawing applications as well as fully-fledged image editing tools and powerful rendering and animation programs.
## Getting to Know Linux Software

**Table 2.4: Graphics Software for Windows and Linux**

<table>
<thead>
<tr>
<th>Task</th>
<th>Windows Application</th>
<th>Linux Application</th>
</tr>
</thead>
<tbody>
<tr>
<td>Simple Graphic Editing</td>
<td>MS Paint</td>
<td>The GIMP</td>
</tr>
<tr>
<td>Professional Graphic Editing</td>
<td>Adobe Photoshop, Paint Shop Pro, Corel PhotoPaint, The GIMP</td>
<td>The GIMP</td>
</tr>
<tr>
<td>Creating Vector Graphics</td>
<td>Adobe Illustrator, CorelDraw, OpenOffice.org Draw, Freehand</td>
<td>OpenOffice.org Draw, Inkscape, Dia</td>
</tr>
<tr>
<td>SVG Editing</td>
<td>WebDraw, Freehand, Adobe Illustrator</td>
<td>Inkscape, Dia</td>
</tr>
<tr>
<td>Creating 3D Graphics</td>
<td>3D Studio MAX, Maya, POV-Ray, Blender</td>
<td>POV-Ray, Blender</td>
</tr>
<tr>
<td>Managing Digital Photographs</td>
<td>Software provided by the camera manufacturer</td>
<td>Digikam, gThumb</td>
</tr>
<tr>
<td>Scanning</td>
<td>Vuescan</td>
<td>Vuescan, Kooka, The GIMP</td>
</tr>
<tr>
<td>Image Viewing</td>
<td>ACDSee</td>
<td>gwenview</td>
</tr>
</tbody>
</table>

**Inkscape**  Inkscape is a free SVG editor. Users of Adobe Illustrator, Corel Draw, and Visio can find a similar range of features and a familiar user interface in Inkscape. Among its features, find SVG-to-PNG export, layering, transforms, gradients, grouping of objects, and more. Find more information about Inkscape at [http://www.inkscape.org/](http://www.inkscape.org/).

**Dia**  Dia is a Linux application aiming to be the Linux equivalent of Visio. It supports many types of special diagrams, such as network or UML charts. Export formats include SVG, PNG, and EPS. To support your own custom-made diagram types, provide the new shapes in a special XML format. Find more information about Dia at [http://www.gnome.org/projects/dia/](http://www.gnome.org/projects/dia/).

**The GIMP**  The GIMP is the Open Source alternative to Adobe Photoshop. Its feature list rivals that of Photoshop, so it is well suited for professional image manipulation. There is even a Windows version of GIMP available. Find more information at [http://www.gimp.org/](http://www.gimp.org/) or refer to Chapter 18 on page 235.
POV-Ray  The Persistence of Vision Raytracer creates three-dimensional, photo-realistic images using a rendering technique called ray tracing. Because there is a Windows version of POV-Ray, it does not take much for Windows users to switch to the Linux version of this application. Find more information about POV-Ray at http://www.povray.org/.

Blender  Blender is a powerful rendering and animation tool available on many platforms, including Windows, MacOS, and Linux. Find more information about Blender at http://www.blender3d.com/.

Digikam  Digikam is a smart digital photo management tool for the KDE desktop. Importing and organizing your digital images is a matter of a few clicks. Create albums, add tags to spare you from copying images around different subdirectories, and eventually export your images to your own Web site. Find more information about Digikam at http://digikam.sourceforge.net/Digikam-SPIP/ or refer to Chapter 16 on page 215.

gThumb  gThumb is an image viewer, browser, and organizer for the GNOME desktop. It supports the import of your digital images via gphoto2, allows you to carry out basic transformation and modifications, and lets you tag your images to create albums matching certain categories. Find more information about gThumb at http://gthumb.sourceforge.net/.

Kooka  Kooka is a scan and OCR suite for the KDE desktop. It allows you to configure the main scan parameters, choose from various export formats, and organize the scanned data. The OCR module provided by the Kooka package adds some basic text recognition features. Find more information about Kooka at http://www.kde.org/apps/kooka/ or refer to Chapter 17 on page 227.

Gwenview  Gwenview is a simple image viewer for KDE. It features a folder tree window and a file list window that provides easy navigation of your file hierarchy. Find more information at http://gwenview.sourceforge.net/home/.

2.5  System and File Management

The following section provides an overview of Linux tools for system and file management. Get to know text and source code editors, backup solutions, and archiving tools.
Table 2.5: System and File Management Software for Windows and Linux

<table>
<thead>
<tr>
<th>Task</th>
<th>Windows Application</th>
<th>Linux Application</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text Editor</td>
<td>NotePad, WordPad, (X)Emacs</td>
<td>kate, gedit, (X)Emacs, vim</td>
</tr>
<tr>
<td>PDF Creator</td>
<td>Acrobat Distiller</td>
<td>Scribus</td>
</tr>
<tr>
<td>PDF Viewer</td>
<td>AcrobatReader</td>
<td>AcrobatReader, xpdf, kpdf</td>
</tr>
<tr>
<td>Text Recognition</td>
<td>Recognita, FineReader</td>
<td>GOCR</td>
</tr>
<tr>
<td>Command Line Pack Programs</td>
<td>zip, rar, arj, lha, etc.</td>
<td>zip, tar, gzip, bzip2, etc.</td>
</tr>
<tr>
<td>Hard Disk Partitioner</td>
<td>PowerQuest, Acronis, Partition Commander</td>
<td>YaST, GNU Parted</td>
</tr>
<tr>
<td>Backup Software</td>
<td>ntbackup, Veritas</td>
<td>dar, taper, dump</td>
</tr>
</tbody>
</table>

**Kate** Kate is part of the KDE suite. It has the ability to open several files at once either locally or remotely. With syntax highlighting, project file creation, and external scripts execution, it is a perfect tool for a programmer. Find more information at [http://kate.kde.org/](http://kate.kde.org/).

**Gedit** GEdit is the official text editor of the GNOME desktop. It provides similar features to Kate. Find more information at [http://www.gnome.org/projects/gedit/](http://www.gnome.org/projects/gedit/).

**(X)Emacs** GNU Emacs and XEmacs are very professional editors. XEmacs is based on GNU Emacs. To quote the GNU Emacs Manual, “Emacs is the extensible, customizable, self-documenting real-time display editor.” Both offer nearly the same functionality with minor differences. Used by experienced developers, they are highly extensible through the Emacs Lisp language. They support many languages, like Russian, Greek, Japanese, Chinese, and Korean. Find more information at [http://www.xemacs.org/](http://www.xemacs.org/) and [http://www.gnu.org/software/emacs/emacs.html](http://www.gnu.org/software/emacs/emacs.html).

**Vim** vim (vi improved) is a program similar to the text editor vi. Users may need time to adjust to vim, because it distinguishes between command mode and insert mode. The basic features are the same as in all text editors. vim offers some unique options, like macro recording, file format detection and...
conversion, multiple buffers in a screen, and much more. Find more information at http://www.vim.org/ or in our Administration Guide.

GOOCR  GOOCR is an OCR (optical character recognition) tool. It converts scanned images of text into text files. It is also one part of Kooka, a KDE scanning tool. Find more information at http://jocr.sourceforge.net/ and in Chapter 17 on page 227.

gzip, tar, bzip2  There are plenty of packaging programs for reducing disk usage. In general, they differ only in their pack algorithm. Linux can also handle the packaging formats used on Windows. Find more information about gzip and tar in Section File Administration on page 261. bzip2 is a bit more efficient than gzip, but needs more time, depending on the pack algorithm.

GNU Parted  GNU Parted is a command-line tool for creating, destroying, resizing, checking, and copying partitions and the file systems on them. If you need to create space for new operating systems, use this tool to reorganize disk usage and copy data between different hard disks. Find more information at http://www.gnu.org/software/parted/.

dar  Dar stands for disk archive and is a hardware-independent backup solution. Dar uses catalogs (unlike tar), so it is possible to extract a single file without having to read the whole archive and it is also possible to create incremental backups. There is also a GUI version for KDE available at http://kdar.sourceforge.net. Find more information about dar at http://dar.linux.free.fr/.

taper  Taper is a backup and restore program that provides a friendly user interface to allow backup and restoration of files to and from a tape drive. Alternatively, files can be backed up to archive files. Recursively selected directories are supported. Find more information at http://taper.sourceforge.net/.

dump  The dump package contains both dump and restore. dump examines files in a file system, determines which ones need to be backed up, and copies those files to a specified disk, tape, or other storage medium. The restore command performs the inverse function of dump; it can restore a full backup of a file system. Find more information at http://dump.sourceforge.net/.
2.6 Software Development

This section introduces Linux IDEs, toolkits, and versioning systems for professional software development.

Table 2.6: Development Software for Windows and Linux

<table>
<thead>
<tr>
<th>Task</th>
<th>Windows Application</th>
<th>Linux Application</th>
</tr>
</thead>
<tbody>
<tr>
<td>Integrated</td>
<td>Borland C++, Delphi, VisualStudio, .NET</td>
<td>KDevelop, Eclipse, Mono</td>
</tr>
<tr>
<td>Development</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Environments</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Toolkits</td>
<td>MFC, Qt, GTK</td>
<td>Qt, GTK</td>
</tr>
<tr>
<td>Versioning</td>
<td>Clearcase, Perforce, SourceSafe</td>
<td>CVS, Subversion</td>
</tr>
<tr>
<td>Systems</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**KDevelop**  
KDevelop allows you to write programs for different languages (C/C++, Python, Perl, etc.). It includes a documentation browser, a source code editor with syntax highlighting, a GUI for the compiler, and much more. Find more information at [http://www.kdevelop.org](http://www.kdevelop.org).

**Eclipse**  
The Eclipse Platform is designed for building integrated development environments that can be extended with custom plug-ins. The base distribution also contains a full-featured Java development environment. Find more information at [http://www.eclipse.org](http://www.eclipse.org).

**Qt**  
Qt is a program library for developing applications with graphical user interfaces. It allows you to develop professional programs rapidly. The Qt library is available not only for Linux, but for a number of Unixes and even for Windows and Macintosh. Thus it is possible to write programs that can be easily ported to those platforms. Find more information at [http://www.trolltech.com](http://www.trolltech.com).

**GTK**  
GTK is a multiplatform toolkit for creating graphical user interfaces. It is used for all GNOME applications, The GIMP, and several others. GTK has been designed to support a range of languages, not only C/C++. Originally it was written for GIMP, hence the name “GIMP Toolkit.” Find more information at [http://www.gtk.org](http://www.gtk.org).
CVS  CVS, the Concurrent Versions System, is one of the most important version control systems for Open Source. It is a front-end to the Revision Control System (RCS) included in the standard Linux distributions. Read more about CVS in our Administration Guide. Find more information at the home page http://www.cvshome.org/.

Subversion  Subversion does the same thing CVS does but has major enhancements, like moving, renaming, and attaching meta information to files and directories. Read more about Subversion in our Administration Guide or go to the home page http://subversion.tigris.org/.

Mono  The Mono Project is an open development initiative that is working to develop an Open Source Unix version of the .NET development platform. Its objective is to enable Unix developers to build and deploy cross-platform .NET applications. The project implements various technologies that have been submitted to the ECMA for standardization. For more information, refer to http://www.mono-project.com/about/index.html.
This chapter introduces the GNOME (GNU Network Object Model Environment) desktop. It provides a brief overview of the most important elements and functionalities of your desktop, including an in-depth description of the file manager Nautilus. Finally, get to know several smart and useful applications that can help you feel at home in your new desktop environment.
GNOME has a very intuitive look and feel to it. However, users migrating to Linux from a Microsoft Windows desktop might need to get accustomed to a few things. Users migrating from a Macintosh might notice that GNOME feels very much like home, because it aims to provide a Mac-type look and feel to a Linux desktop.

Two issues are very important:

**double-click** Like a Mac desktop, a GNOME desktop is entirely ruled by the double-click. To trigger an event by clicking a desktop icon, for example, open your home folder, you need to double-click it. To open subdirectories in the file manager, double-click the parent folder.

**instant apply** Any configuration dialog opened from a GNOME application or as part of the GNOME desktop configuration follows the principle of “instant apply.” Once you enter your preferences, just click the ‘Close’ button to save them and leave the dialog. You will not find any ‘Apply’, ‘OK’, or ‘Cancel’ buttons in this kind of dialog.

### 3.1 The Desktop

The most important elements of the GNOME desktop are the icons on the desktop, the panels at the top and bottom border of the screen, and the panel menus. The mouse is your most important tool, although GNOME has built-in support for assistive technologies, such as braille, speech synthesizers, and on-screen keyboards to support handicapped users. For details on these technologies, refer to Section 3.5 on page 65.

#### 3.1.1 The Icons

The default GNOME desktop features at least the following desktop icons providing basic navigation and functionalities of your system:

**Trash** Anything you want to delete can be dropped onto the ‘Trash’ desktop icon. As long as you do not empty the trash can, these items are not deleted permanently and can still be restored.

**Home** The ‘Home’ desktop icon provides easy access to your private data.
The ‘Computer’ desktop icon can be used to quickly access any device attached to your computer. This includes hard drives, partitions, digital cameras, and USB flash drives.

Right-clicking an icon displays a menu offering file operations, like copying, cutting, or renaming. Selecting ‘Properties’ from the menu displays a configuration dialog. The title of an icon and the icon itself can be changed with ‘Use custom icon’. Use the ‘Permissions’ tab to view and modify the access, read, and write permission settings for this file for the user, the group, or others. The ‘Notes’ tab manages comments. The menu for the trash can additionally features the ‘Empty Trashcan’ option. This deletes its contents.

To remove an icon from the desktop, simply move it into the trash can. However, be careful with this option—if you throw folder icons or file icons into the trash can, the actual data is deleted. If the icons only represent links to a file or directory, only the links are deleted.

To create a link on the desktop to a folder or a file, access the object in question with Nautilus. Right-click the object and select ‘Make Link’. Drag the link from the Nautilus window and drop it on the desktop.

### 3.1.2 The Desktop Context Menu

Right-clicking a free spot on the desktop displays a menu with various options. Select ‘New Folder’ to create a new folder. Create a launcher icon for an application with ‘New Launcher’. Provide the name of the application and the command for starting it then choose an icon to represent it. The order and alignment of desktop icons are controlled via ‘Clean Up by Name’ and ‘Keep Aligned’. It is also possible to change the desktop background or reset it to its default setting. If you need a command line environment, click ‘Open Terminal’.

### 3.1.3 The Panels

On first login, the GNOME desktop starts with two panels located at the top and the bottom of the screen. The upper panel holds the three panel menus (‘Applications’, ‘Places’, and ‘Desktop’), a quick launch area providing application buttons for the most important programs, a system tray holding applet icons, and a notification area with the system clock and the volume control.
The bottom panel contains the window icons of all started applications in the taskbar. If you click the name of a window in the taskbar, it is moved to the foreground. If the program is already in the foreground, a mouse click minimizes it. Clicking a minimized application reopens the respective window.

Beside the taskbar, the ‘Workspace Switcher’ provides access to additional work areas. These virtual desktops provide extra space in which to arrange open applications and windows. For example, put an editor on one workspace, some shells on another, and your e-mail application and Web browser on a third. Move a window to another workspace by just dragging its icon in the workspace switcher from one workspace to another.

If you right-click an empty spot in the panel, a menu opens, offering help, information, and commands for GNOME and panels. Select ‘Properties’ to open a configuration dialog in which to change the position and background of the panel. If desired, add launchers, tools, and various applets to the existing panels with ‘Add to Panel’. Remove panel elements by right-clicking their icons and selecting ‘Remove’. A new panel can be added with ‘New Panel’.

The Applications Menu

The ‘Applications’ menu provides an easily accessible hierarchy of the applications installed on your system. Most of them are grouped into smaller submenus each dedicated to a category, like ‘System’, ‘Office’, and ‘Internet’. To start any application, just click ‘Applications’ to unfold the complete menu. Then select a suitable category, unfold the submenu, and click the application’s name.

Applications not in the menu can still be started via the ‘Run Application’ prompt ($\text{Alt}+F2$), if you know their command. For example, if you want to browse your digital photographs and could not find gThumb in the menu, enter $\text{gthumb}$ at the ‘Run Application’ prompt.

The Places Menu

The ‘Places’ menu provides easy access to common locations, such as the user’s home, drives, and desktop and network folders. A search function for recent documents and a file search can also be launched with this menu. For more information about file management of local and remote folders, refer to Section 3.3.2 on page 58.
The Desktop Menu

The ‘Desktop’ menu contains the basic controls for managing your desktop. Here, find ‘Lock Screen’ and ‘Log Out’ as well as an easy-to-use function for taking screenshots of your desktop. The screenshot function can alternatively be accessed just by pressing the \texttt{Print Screen} key (also known as \texttt{PrtSc}).

Applets

Applets are little applications that are nested in the panel by means of a small icon. Unlike a “real” application, they do not have their own window on screen. Some applets are already preconfigured to be in your panel on first start, but there are many more to be discovered and added to your own custom panel.

Adding a panel applet is very simple. Just right-click the panel to open the ‘Add to Panel’ dialog, shown in Figure 3.1 on the current page, scroll down until you find what you need, select the item, and click ‘Add’. A new applet is then permanently added to the panel.

\textbf{Figure 3.1: Adding a New Icon to the Panel}
3.2 Settings

Use the GNOME control center to customize your desktop. Access it with ‘Desktop’ → ‘Preferences’. The most important and prominent modules of the GNOME control center are featured in the following sections. In the individual modules, access relevant help for the options with ‘Help’. The system immediately adopts every change made in a configuration module.

3.2.1 Keyboard

The ‘Keyboard’ configuration module consists of four tabs. The ‘Keyboard’ tab determines key repeats and cursor blinking. Keyboard layouts can be configured in the second tab, specifying the keyboard model and the localized keyboard layout. ‘Layout Options’ can be used to activate special keyboard features like Win keys. Typing breaks can be configured in the fourth tab (‘Typing Break’). With this, the screen is shut down after a certain time to force you to take breaks from screen work. Exit the ‘Keyboard’ module with ‘Close’ or go the accessibility module with ‘Accessibility’. The functionality of this module is described in Section 3.2.8 on page 54.

3.2.2 Mouse Configuration

The mouse configuration consists of three tabs: ‘Buttons’, ‘Cursor’, and ‘Motion’. The configuration options of the ‘Buttons’ tab refer to the ‘Mouse Orientation’. Left-handed users should activate ‘Left-handed mouse’ to swap the right and left mouse buttons. Use the slider to determine the maximum delay (in seconds) between two clicks that the system should interpret as a double-click.

The appearance and size of the cursor can be changed under the ‘Cursor’ tab. Three different settings are available. Changes are not activated until the next login. Under ‘Locate Pointer’, activate an option that causes the cursor to be highlighted when you press (Ctrl), making it easier to find. Under ‘Motion’, set the acceleration and sensitivity of the screen cursor and the drag and drop threshold.

3.2.3 Menus and Toolbars

The settings in this module affect the menus and toolbars of all GNOME-compatible applications. Select for toolbar icons to be displayed as ‘Text Only’,
The GNOME Desktop


Activate ‘Detachable toolbars’ to allow the detachment of the toolbar from all other window elements and allow its free positioning on the desktop. This makes a grabbing area appear on the left side of the toolbar. Clicking and holding this area relocates the toolbar.

Every menu entry in any application menu can be displayed with the corresponding icon. Activating ‘Show icons in menus’ tests the settings with the provided example menu.

3.2.4 Windows

This module controls the behavior of application windows. Determine how the window should react to contact with the mouse pointer or to double-clicks on its title and define the key to hold for moving an application window.

When several application windows populate the desktop, the active one, by default, is the one last clicked. Change this behavior by activating ‘Select windows when the mouse moves over them’. If desired, activate ‘Raise selected window after an interval’ and adjust the latency time with the slider. This activates a window only when the cursor was placed within the window for a time exceeding the set latency.

Application windows can be rolled up by double-clicking the title bar, leaving only the title bar visible. This saves space on the desktop and is the default behavior. It is alternatively possible to set windows to maximize when the title bar is double-clicked.

With the radio buttons, select the modifier key to press for moving a window. The possible choices are (Ctrl), (Alt), and the (Windows) key.

3.2.5 Background

Determine a background for your desktop. By default, the changes made here are applied to all virtual desktops. If you do not want any background picture, click ‘No Wallpaper’ and define a background style. The drop-down menu offers a horizontal gradient, a vertical gradient, or no gradient at all. Use ‘Desktop Colors’ to define the desired colors in the color editor.

To use an image file as a background picture, drag it from the file manager and drop it in the ‘Desktop Wallpaper’ window. Alternatively, click ‘Add Wallpaper’ to open a dialog in which to select the desired image.
‘Style’ determines what processing steps should be applied to the selected image to adapt it optimally to the current screen resolution. The options are ‘Centered’, ‘Fill Screen’, ‘Scaled’, and ‘Tiled’.

3.2.6 Font

This module determines the font to use for the desktop. In a second step, enable optional effects for the improvement of the font quality. The upper part of the dialog window shows the fonts selected for ‘Application font’, ‘Desktop font’, ‘Window title font’, and ‘Terminal font’. Click one of the buttons to open a selection dialog in which to set the font family, style, and size. The options for ‘Font Rendering’ and the additional configuration options accessible through ‘Details’ are set to optimal values by default.

3.2.7 Theme

The style for all control elements on the desktop and of GNOME applications is set here. Choose from various preinstalled themes. Selecting a style in the list overview applies it automatically. ‘Theme Details’ opens another dialog in which to customize the style of single desktop elements, like window controls, window borders, and icons. Making changes and leaving the dialog with ‘Close’ switches the theme to ‘Custom theme’. Click ‘Save theme’ to save your modified theme under a custom name. The Internet and other sources provide many additional themes for GNOME as .tar.gz files. Install these with ‘Install theme’. New themes can simply be dragged and dropped into the ‘Theme Preferences’ window.

3.2.8 Accessibility

The settings of this module facilitate the use of the keyboard for users with motion impairments. The module consists of the three tabs ‘Basic’, ‘Filters’, and ‘Mouse Keys’. Before modifying settings, activate ‘Enable keyboard accessibility features’.

Features The keyboard accessibility functions can be deactivated automatically after a certain time. Set an appropriate time limit measured in seconds with the slider. The system can additionally provide audible feedback when the keyboard accessibility functions are activated and deactivated.
Enable Sticky Keys  Some keyboard shortcuts require that one key is kept pressed constantly (this applies to \texttt{(Alt)}, \texttt{Ctrl}, or \texttt{(Shift)}) while the rest of the shortcut is typed. When “sticky” keys are used, the system regards those keys as pressed after being hit once. For an audible feedback generated each time a modifier key (\texttt{Ctrl} or \texttt{Alt}) is pressed, activate ‘Beep when modifier is pressed’. If ‘Disable if two keys pressed together’ is selected, the keys do not stick anymore once two keys are pressed simultaneously. The system then assumes that the keyboard shortcut has been completely entered.

Enable Repeat Keys  Activate ‘Repeat Keys’ to make settings with sliders for ‘Delay’ and ‘Speed’. This determines how long a key must be pressed for the automatic keyboard repeat function to be activated and at what speed the characters are then typed.

Test the effect of the settings in the field at the bottom of the dialog window. Choose parameters that reflect your normal typing habits.

Enable Slow Keys  To prevent accidental typing, set a minimum time limit that a key must be pressed and held before it is recognized as valid input by the system. Also determine whether audible feedback should be provided for keypress events, accepted keypresses, and the rejection of a keypress.

Enable Bounce Keys  To prevent double typing, set a minimum time limit for accepting two subsequent keypress events of the same key as the input of two individual characters. If desired, activate audible feedback upon rejection of a keypress event.

Toggle Keys  It is possible to request audible feedback from the system when a keycap modifier key is pressed.

Mouse  Activates the keyboard mouse—the mouse pointer is controlled with the arrow keys of the number pad. Use the sliders to set the maximum speed of the mouse pointer, the acceleration time until the maximum speed is reached, and the latency between the pressing of a key and the cursor movement.

3.2.9  Keyboard Shortcuts

Use this module to manage global keyboard combinations. It is possible to determine the keyboard combinations to use during text input and those for objects on the desktop.
The list overview window displays a list of all currently available actions along with their keyboard shortcuts. Deactivate or change a keyboard shortcut by clicking the corresponding shortcut entry. Then enter a new shortcut or delete the current one with (Backspace). All changes take effect immediately. Restore the current keyboard shortcut by clicking its entry and leaving the dialog with ‘Close’.

### 3.2.10 Assistive Technology

Use this module to activate and configure active technology support for disabled users. First, globally activate this support via ‘Enable assistive technologies’. Because this affects various settings of your entire desktop, such as mouse and keyboard behavior or font sizes, these changes do not take effect until the next time you log in. Select the type of support you need. Choose from ‘Screenreader’, ‘Magnifier’, and ‘On-Screen keyboard’. More information about this topic can be found in Section 3.5 on page 65.

### 3.2.11 Sound (System Alerts)

This module allows the association of certain system events and application alerts with characteristic audio signals. The dialog box consists of three tabs (‘General’, ‘Sound Events’, and ‘System Bell’). The two check boxes in the ‘General’ tab must be activated to use audio signals for certain desktop events.

In ‘Sound Events’, determine which events and application alerts should be associated with which sounds. All sound associations already defined for applications are listed. Test a sound by first selecting the corresponding notice in the ‘Event’ column then clicking ‘Play’. Change the sound by clicking ‘Event’ then ‘Browse’. The dialog that appears provides a list of files from which to choose. Close it with ‘OK’.

In the ‘System Bell’ tab, determine whether an audible bell should be activated for all kinds of system events and whether to have visual feedback as well. Visual feedback could consist of a flashing window title bar or the entire screen flashing.

### 3.2.12 Default Applications

To improve the interoperability of your GNOME desktop, configure the default Web browser, mail reader, and terminal applications that should be launched whenever another GNOME application needs these functionalities. Select the application’s name and customize its command if necessary. If you, for example, set
your default browser to ‘Firefox’, this application is started when you click a link in an e-mail. These settings only apply to GNOME applications, however.

3.2.13 Sessions

The ‘Sessions’ dialog enables you to control the behavior of your desktop right from the login. In the ‘Session Options’ tab, determine whether you want to see the GNOME splash screen while the desktop is loading after login. If ‘Prompt on logout’ is checked, a confirmation dialog appears at the end of a session, asking you to confirm the logout action. Check ‘Automatically save changes to session’ if you want to have the exact state of a session restored for the subsequent login. With ‘Startup Programs’, configure any additional programs that should be started on login (certain applets or terminals, for example). The ‘Current Session’ tab lists all programs that are currently started once a session begins. Remove applications or change the order in which they are started as desired.

3.3 File Management with Nautilus

Nautilus is the file manager and viewer of GNOME. The following section provides an overview of the basic functions of Nautilus as well as a few tips on its configuration. More information can be found in the help pages for Nautilus.

3.3.1 Navigating in Nautilus

The standard window of Nautilus is shown in Figure 3.2 on the following page. The default view of a folder’s content is the icon view just featuring an icon and the filename for each file. If configured accordingly, a preview of the file’s content can be provided, as described in Section 3.3.4 on page 60. When you double-click a folder icon, a new Nautilus window opens, displaying the folder’s content.

If you prefer browser-like file navigation, switch to the Nautilus browser interface. Right-click the folder to browse and choose ‘Browse Folder’. A new Nautilus window opens, providing the normal functionality, but with a browser’s look and feel. To navigate folders and files, you can now use the ‘Back’, ‘Forward’, and ‘Up’ buttons as you would do in a Web browser. The functionalities and configuration options described below (Section 3.3.2 on the following page and Section 3.3.4 on page 60) also apply to the file browser interface.
To navigate between folders, use the drop-down menu at bottom left edge of the Nautilus window. Here, find all parent folders to the current directory up to the file system root. Select the desired folder and it opened in a new Nautilus window on top of the old one. Alternatively, open just the immediate parent of the current folder by choosing ‘File’ → ‘Open Parent’. If you want to close these parent folders, select ‘File’ → ‘Close Parent Folders’.

### 3.3.2 File Management

Nautilus supports drag and drop for file management. Any file from the desktop can simply be dragged onto an open Nautilus window and dropped to its final destination. To move files between directories, open the source directory containing the file to move. Select ‘File’ → ‘Open Location’, enter the path to the target directory, then drag the files to move to the Nautilus window holding the target directory. Files and folders can be moved to and from an open Nautilus window and the desktop.

If you need to create multiple copies of a file, use ‘Edit’ → ‘Duplicate’. For simple cut, copy, and paste of files, use the ‘Edit’ menu or right-click the file icon then selecting the appropriate item from the context menu that appears. To rename a file, right-click it and select ‘Rename’.

Nautilus supports file browsing across a network. To connect to a remote server (FTP, SSH, HTTP, Samba, etc.), click ‘File’ → ‘Connect to Server’. You are then
prompted for the type of server to which to connect and some additional information, like the name of the folder to access, the port number, and the username to use. When you leave this dialog with ‘Connect’, the remote folder is displayed as part of the ‘Places’ panel menu and appears as a desktop icon. For any future connections, just select the appropriate item from the ‘Places’ menu and provide the necessary authentication to log in to these network folders. To close these connections, right-click the desktop icon and select ‘Unmount Volume’.

Nautilus provides basic CD burning functionality. If you created a directory holding data you want to back up by just burning it to a CD, click ‘Places’ \(\rightarrow\) ‘CD Creator’ and drag the folder holding the relevant data onto the ‘CD/DVD Creator’ window. Select ‘File’ \(\rightarrow\) ‘Write to Disc’ to copy the data to CD or DVD.

### 3.3.3 Editing MIME Types

MIME types determine which application should open a file when clicked in a Web or file browser. The actual file type and the MIME type of a file are closely associated with each other. An HTML file has the file type `html` and would be registered to have a MIME type `text/html`. Nautilus has built-in support for most of the common MIME types and proposes the appropriate application when you choose to open a file. In this case, it would propose a Web browser. However, you might want to change the MIME type for certain files if you are not quite happy with the default applications suggested by Nautilus. Changing the default application assigned to a certain MIME type is very straightforward. See Figure 3.3 on the following page.

**Procedure 3.1: Editing the MIME Type**

1. Right-click a file of the MIME type in question in a Nautilus window.
2. Select ‘Properties’ from the menu that opens.
3. Choose the ‘Open With’ tab from the ‘Properties’ dialog.
4. Click ‘Add’ and ‘Browse’ to search for a suitable application.
5. Leave the dialog with ‘Close’.

If a MIME type has not yet been properly registered, the procedure is the same as described above. These modifications are applied globally, which means that any file of this type is subsequently opened by the application defined.
3.3.4 Configuring Nautilus


‘Views’ allows switching the ‘Default View’ between ‘Icon View’ and ‘List View’. A sorting order can be set for any of these options.

In ‘Behavior’, choose between single-click and double-click response and also set the handling of executable files. These can either be started on activation or have the content displayed. The operating mode of the trash is also set here. Activate a confirmation dialog before deletion, if desired. ‘Include a Delete command that
The GNOME Desktop ‘bypasses trash’ can also be set. The files are immediately deleted if this option is activated.

‘Display’ features three options for determining what information should be displayed for icons and how it should be displayed. In addition to that, the data format can also be set here. ‘List Columns’ determines what information should be revealed in the list view. In ‘Preview’, select whether to activate preview thumbnails for certain file types.

3.4 Important Utilities

GNOME has many applets and applications. They are designed to interact with the desktop and each other. This section introduces some of them. Learn how to manage little notes on your desktop, use the GNOME dictionary, chat with Gaim, and enjoy various types of multimedia applications.

3.4.1 Taking Notes with Tomboy

Tomboy is a smart little panel applet offering a note application for the GNOME desktop. Left-click the panel icon to open the Tomboy menu and select ‘Create New Note’. Enter the text of your note. Notes can be linked with each other by clicking ‘Link’. These links even survive renaming and reorganizing. A ‘Search Notes’ function located in the panel menu of Tomboy lets you search your notes. Web links and e-mail addresses can also be dropped onto Tomboy.

3.4.2 Dictionary

Dictionary (command gnome-dictionary) is a useful applet for checking the spelling and meaning of words. An Internet connection is required, because this applet accesses an online dictionary.

Enter the term to look up in ‘Word’. The menu under ‘Dictionary’ gives a choice between ‘Look Up Word’ and ‘Check Spelling’. By default, the query is sent to the dict.org server. To use a different server, select ‘Edit’ → ‘Preferences’. See a sample entry in Figure 3.4 on the next page. dict.org allows you to choose between various databases for special vocabularies, such as jargon or computer terminology. Under ‘Default strategy’, specify what to look for the exact word, parts of the word, or the prefix or suffix. Under ‘Help’, access the online manual of the application with ‘Contents’ and information about the author and version of the application with ‘About’.
3.4.3 Messaging with Gaim

Gaim (command `gaim`) is a powerful instant messenger client. It supports various protocols, such as AIM, ICQ, GroupWise, IRC, Jabber, MSN, and others. Its most popular features include the ability to log in to multiple accounts on multiple instant messaging networks at the same time, automatic text replacement, and spell checking. Gaim has buddy pounces (known as “buddy alerts” in AOL Messenger), meaning that you can configure Gaim to notify you whenever one of your buddies enters or leaves a channel to which you are currently connected. Gaim can send you a message announcing this, play a sound, or execute a command.

On first start-up, create a list of your accounts on different instant messaging networks by clicking ‘Add’ in the ‘Accounts’ window to open the appropriate dialog. Select the protocol then enter your screen name, password, and alias. Check ‘Remember password’ and ‘Auto-Login’ if you want Gaim to log in automatically on start-up. To keep track of your e-mail while using Gaim, check ‘New mail notifications’. To select a buddy icon for your account, open a file dialog and choose one. Additional options, such as proxy settings and server addresses, can be configured after clicking ‘Show more options’. Once you have completed your account settings, leave this dialog with ‘Save’.

As soon as you are done entering the account data, it is shown in the login window. To sign on, select your account from the ‘Account’ menu, enter your password, click ‘Sign on’, and start chatting.
3.4.4 Watching Movies with Totem

Totem is a multimedia player for the GNOME desktop based on Xine. It supports playback of DVDs, VCDs, and audio CDs. Start playback of a VCD or DVD via ‘Movie’ → ‘Play VCD’ or ‘Movie’ → ‘Play DVD’. Totem offers menu support for DVDs under ‘Go’. Movie streams can be fetched via the network—just enter the URL at ‘Movie’ → ‘Open Location’. Take screenshots with ‘Edit’ → ‘Take Screenshot’.

3.4.5 Managing Archives with File Roller

In GNOME, manage file archives with File Roller. This application is able to handle archives of the following types: .tar, .tar.gz, .tgz, .tar.bz, .tar.bz2, .tar.Z, .zip, .lha, .rar, .lzh, .ear, .jar, and .war. Easily view archive
contents from File Roller with other applications without needing to decompress the archives. File Roller supports drag and drop, allowing you to drag file icons from the desktop or from the file manager (Nautilus) to the File Roller window and drop them there.

To create a new archive, select ‘Archive’ ➝ ‘New’. In the next dialog, specify the directory in which to create the new archive in the left window. Enter the filename of the new archive in the input field below without the file extension. Then determine the archive type with the drop-down menu above the name field. Exit the dialog with ‘OK’ and return to the main view of File Roller. Now, add files to the archive by inserting files from the desktop or the file manager with drag and drop or by selecting ‘Edit’ ➝ ‘Add Files’. In the following dialog, select one or several files (keep Ctrl pressed to select multiple files) or directories. If necessary, set the following advanced options for the archive:

**Add only if newer**  If the archive already contains a file with the same name, the file is only added if it is newer than the one existing in the archive.

**Include subfolders**  To compress an entire directory, activate this option to include all subdirectories.

**Exclude backup files (~*)**  Avoid unnecessary data trash by disabling the inclusion of backup copies when creating an archive.

**Exclude hidden files (.* )**  Usually, hidden files do not contain any data that is relevant for the user. By default, they are not included in the archive to reduce the amount of data.

**Exclude files**  This explicitly excludes certain files from the archive. This option is useful if you want to compress entire directories but exclude certain files from the archive. Instead of filenames, you can also specify search patterns.

**Ignore case**  File Roller ignores different capitalizations of filenames and extensions, like JPEG or jpeg.

After completing the selection and configuration, exit the dialog. The archive created is available for further processing at the desired location. To decompress an archive, load it to File Roller, click ‘Edit’ ➝ ‘Extract to’, and specify the target directory.
3.5 Assistive Technology Support

GNOME offers a number of applications to support users with disabilities. These applications include an on-screen keyboard (GOK), a powerful screenreader (Gnopernicus) with magnification, speech and braille support, and a text entry interface (Dasher). Activate the support for any assistive technology via the GNOME control center that can be accessed by selecting ‘Desktop’ → ‘Preferences’.

3.5.1 GNOME On-Screen Keyboard

Gnome On Screen Keyboard (GOK) provides a virtual keyboard on screen to those users who cannot use standard mouse and keyboard devices to control their computers. With appropriate hardware support, you can use a joystick or any pointer device as the input device.

![Figure 3.6: GOK in Use](image)

The following example of using a text editor via GOK should illustrate the way how GOK works.

**Procedure 3.2: Editing a Text File via GOK**

1. Click ‘Launcher’ in the main menu. See Figure 3.6 on this page

2. Select ‘Text editor’ to launch a GNOME text editor and click ‘back’ to return to the main menu.

3. Hit ‘Compose’ to launch the actual on-screen keyboard and start entering your text. If in need of advanced editing functionality like selecting, copying, pasting, or skipping characters, words, sentences, or lines, hit ‘Edit’. To return to the keyboard window, hit ‘back’.
4. To save the text you have written, click ‘back’ to return to the main window then select ‘Menus’ to launch a window containing buttons to open any menu from the text editor’s menu bar.

5. Select ‘File’ → ‘Save as’ to open the file dialog of the text editor.

6. Hit ‘Compose’ to enter the filename via the virtual keyboard and hit ‘Return’ on the virtual keyboard.

7. To terminate the text editor, return to the main menu and select ‘Menus’ → ‘File’ → ‘Quit’.


More information about GOK can be obtained at http://www.gok.ca/, where you also find a comprehensive online help for this tool.

### 3.5.2 Gnopernicus

Gnopernicus is a powerful tool collection with various types of screen reading applications for blind and visually impaired users. It provides the following functionalities:

**Speech**  A speech synthesizer software is used to translate the actions on screen to spoken words. If your computer has a sound card, you can configure Gnopernicus to comment anything that happens on-screen.

**Braille and Braille monitor**  If a braille device is connected to your system, Gnopernicus can translate the screen directly to this device. If you activated ‘Braille Monitor’ as well, get an on-screen display of the braille output. This option might prove useful for demonstration purposes.

**Magnifier**  This module assists visually impaired users by magnifying the screen using a customizable zoom factor.

Once Gnopernicus has been started, its main menu appears in the top left corner of the screen, as shown in Figure 3.7 on the next page. Determine which functionalities should be provided when your desktop starts by opening the ‘Startup Mode’ dialog. Each active module can be configured via the ‘Preferences’ dialog.

Get more information about the Gnopernicus project at http://www.baum.ro/gnopernicus.html.
3.5.3 Dasher

Dasher is a small application enabling you to create texts without using a keyboard. You can use it on any computer device that comes without a keyboard (handheld or wearable computers) or on a normal computer that is controlled with a joystick, touchpad, head mouse, or eyetracker instead of keyboard and mouse. Dasher is driven by continuous pointer gestures. Start with one character then drag the pointer to the next one until your text input is finished. Dasher supports various languages out of the box (English and European languages, Japanese, and some African languages) and can easily be trained to support other languages. Find more information about the Dasher project at http://www.inference.phy.cam.ac.uk/dasher/.
Figure 3.8: Writing with Dasher
The KDE desktop offers an intuitive graphical interface. The following sections show you how to make efficient use of KDE’s features and how to customize the desktop to meet your personal needs. This is followed by an introduction to the file manager Konqueror and a brief description of some small but useful utilities.

4.1 Desktop Components ........................................... 70
4.2 Settings ................................................................. 73
4.3 Konqueror as a File Manager .................................... 78
4.4 Important Utilities .................................................. 83
4.1 Desktop Components

The main components are the icons on the desktop and the panel at the bottom of the screen. The mouse is your most important tool. Click a symbol or an icon once to start the associated program or the file manager Konqueror. If you right-click an icon, different menus appear, depending on the program. As well as the icons, there are two desktop menus.

4.1.1 The Desktop Menus

If you middle-click the desktop (if your mouse only has two buttons, press both buttons at the same time), a window and desktop management menu is displayed. The menu lists the various desktops and the windows opened in them. It also offers the following items:

‘Unclutter Windows’ If you have several windows on your desktop, they are placed next to each other and aligned with the top left corner.

‘Cascade Windows’ Starting from the top left corner, the windows on the desktop are placed on top of each other in such a way that only the top and left borders of the lower windows are visible.

‘Desktop x’ Desktop 1 is your default desktop. This part of the menu lists all the windows currently opened. You can bring them to the foreground by clicking one of the respective items.

‘Additional Desktops’ You can use the additional (virtual) desktops provided and switch to them with the menu or the panel. All functions are available on all desktops. This limits the number of programs and associated windows that need to be arranged on one desktop. These virtual desktops resemble additional desks in your office.

If you right-click the desktop, a more complex menu is displayed, allowing you to customize your desktop.

‘Create New’ Use this menu item to create new directories, files, or devices on the desktop. A list of possible elements is provided for selection in a submenu.
‘Bookmarks’ The bookmark editor allows you to create, group, change, or delete bookmarks. The bookmarks are used by the browser and file manager Konqueror. The bookmark editor can also import bookmarks from other browsers, such as Mozilla, Netscape, Opera, and Internet Explorer.

‘Run Command’ This menu item opens a window in which to enter a command manually. Execute the command by pressing (Enter).

‘Undo’ Use this item to undo the last action. For example, if you have just created a new directory on the desktop, clicking this item reverts the creation so the directory disappears.

‘Paste’ To keep a folder or document handy on the desktop, you can copy an icon from the file manager by right-clicking and selecting ‘Copy’ then moving the mouse to the desired location on the desktop. Right-click again and select ‘Paste’. The icon is now available on your desktop and can be moved around by dragging it with the left mouse button pressed.

‘Icons’ This allows you to rearrange the icons on the desktop. You can also change the order of the icons.

‘Windows’ This arranges the windows on the desktop, either on top of each other beginning from the top left corner or next to each other.

‘Refresh Desktop’ If the desktop appears garbled in some way, use this menu item to redraw it.

‘Configure Desktop’ This menu item starts a configuration dialog with which to configure the appearance and behavior of the desktop. Details about the configuration of the desktop are provided in Section 4.2 on page 73.

‘Start New Session’ This menu opens a dialog box asking if you want to start a new user environment. After clicking ‘Start New Session’, the current session disappears into the background and the system switches to a new login screen. Each session has a function key assigned to it: (F7) represents the first session, (F8) the second one, and so on. To switch between different sessions, press (Ctrl-Alt-Fx), where (Fx) is the function key corresponding to the desired session.

‘Lock Screen’ If you leave your workstation and do not log out, you should use this function to prevent others from gaining access to your files. Depending on the setting, the screen turns blank or starts displaying a screensaver. To continue using the computer, enter your password.
‘Logout’ Log out of your system if you are not going to use the system for some time.

4.1.2 The Main Menu

Open the main menu by clicking the icon to the far left of the panel. Alternatively, press (Alt)-F1. The main menu is subdivided into these sections: ‘Most Used Applications’, ‘All Applications’ (a menu with all applications sorted according to categories), and ‘Actions’. The following section provides information about a number of actions that can be triggered from the main menu. Detailed information about the Control Center is available in Section 4.2 on the next page.

‘Bookmarks’ By selecting ‘Edit Bookmarks’ from this menu, start an editor in which to organize your bookmarks. If you select one of the bookmarks present in the menu, the Konqueror browser starts and loads the corresponding URL.

‘Run Command’ This item opens a dialog in which to enter a command. You can use it to start an application whose command you know without navigating through the program submenus.

‘Switch User’ To start a second session with a graphical user interface on your machine, select ‘Start New Session’ from the main menu. Your current session remains active while you are taken to the login screen. Log in. You can also start another window manager. Access the first session by pressing (Ctrl)-Alt-F7. Press F8 instead of F7 to access the new session. Additional sessions can be accessed by pressing (Ctrl)-Alt-F9 to F12.

‘Lock Session’ If you leave your workstation, you can blank your screen or start a screensaver. Access to the session can only be regained with a password. To unlock, enter your normal login password. Locking the screen ensures that others cannot read or manipulate your documents or e-mail messages.

‘Log Out’ You can log out from the system by means of this menu item. However, first you are asked what should happen after the logout. If you select ‘Login as different user’, the login screen is displayed, allowing you or another user to log in to the system. You can also shut down and turn off the computer or shut it down and reboot immediately. Confirm your selection with ‘OK’ or remain logged in by clicking ‘Cancel’.
4.2 Settings

The KDE desktop can be customized according to your preferences and needs. ‘Control Center’ in the main menu opens the configuration dialog for your KDE desktop. The following section introduces a number of modules. You can also start it with the command kcontrol.

**Tip**

**Using Konqueror for Your Settings**

You can also use Konqueror to view and modify your settings. Type settings:/ in your location bar and Konqueror displays all the modules in icon view or tree view according to your configuration.

4.2.1 Using the KDE Control Center

After starting the KDE Control Center, see the main window. It has its menus at the top and a sidebar on the left. The configuration is displayed on the right.

You can change the appearance of the sidebar with the ‘View’ menu. Switch from the tree view to icon view or vice versa. To configure some shortcuts, go to ‘Settings’ → ‘Configure Shortcuts’.

The sidebar contains three tabs. The first, ‘Index’, displays all the modules according to the settings of the ‘View’ menu. The second, ‘Search’, enables you to search for some keywords. With the last tab, ‘Help’, read small help texts about the current module.

4.2.2 Appearance & Themes

This item features all fine tuning options for the appearance of your desktop. ‘Background’ lets you choose a color, picture, or slideshow for your background desktop.

If you do not like the actual color scheme, modify it in ‘Colors’. You can change the color of the window background, your menu, links, and others.

Fonts are also an essential part of your desktop. Set your default fonts with ‘Fonts’. This module displays a preview of the currently selected font in a text field. With ‘Choose’, select the font, style, and size.
‘Icons’ controls the icon style for the whole desktop. You can select the KDE Classic style, the Crystal SVG style, or others. With ‘Advanced’, fine-tune the icons’ appearance.

‘Launch Feedback’ runs a visual feedback for your mouse cursor. If an application is started, KDE shows, for example, a busy cursor. Choose the style, like blinking or bouncing. You can also try a passive cursor or disable this effect entirely.

If you do not use your computer for a specific time, a screen saver automatically appears. With the ‘Screen Savers’ module, configure all the necessary settings. Select from a lot of types, like banners, fractals, and illusions. To tweak the settings for a specific screen saver, click ‘Setup’. More options can be found in ‘Advanced Options’.

When KDE starts, it shows a small image. This image can be defined with ‘Splash Screen’. Click ‘Test’ to display the splash screen.

With ‘Style’, modify the visual appearance of user interface elements (GUI). Choose a style to preview it in the example below. ‘Effects’ and ‘Miscellaneous’ can enable some GUI effects and transparency.

Some users created configuration sets and uploaded them to a Web page. ‘Theme Manager’ let you choose and install different themes for your KDE desktop.

‘Window Decorations’ are another style setting. If you change the setting, the example below changes.

4.2.3 Desktop

‘Behavior’ allows you to change some general issues about your desktop. You can activate previews for some specific files or enable device icons.

The central place for user-defined resources is ‘KDE Resources’. Choose a resource, like Calendar, Contacts, or Notes. Then click ‘Add’. Depending on your selection, it displays a window in which to select the type of the new resource. The next step opens a new window with specific settings for this type. If you confirm with ‘Ok’, the resource can be used in other KDE applications, for example, KOrganizer.

‘Multiple Desktops’ let you choose up to 20 virtual desktops with individual names. Move the slider to change the value. Use the text fields to give your desktops names.

With the ‘Panels’ module, set the position of the panel. You can put any panel on the left, right, top, or bottom of the screen. The other tabs contain settings to hide
the panel or add special menus. It is also possible to modify the background or enable transparency.

The ‘Taskbar’ modules configure the taskbar, which provides the window list in the panel. How the taskbar groups windows is determined in ‘Group similar tasks’. You can define some actions to perform if the left, middle, or right mouse button is pressed.

With ‘Window Behavior’, customize the default KDE window manager (KWin). This controls what happens windows are moved, clicked, or resized.

‘Windows-Specific Settings’ let you customize settings that only apply for some windows. It only takes effect if you use KWin as your window manager.

### 4.2.4 Internet & Network

The modules ‘Paried Bluetooth Devices’ and ‘Bluetooth Services’ deal with how you manage your Bluetooth devices and services. KDE lets you change the timeout values for different connections in ‘Connection Preferences’.

‘Desktop Sharing’ is useful if you want to invite other people to your desktops. Only let trustworthy users take part in your session.

‘File Sharing’ can only be changed if you are an administrator. If you are root, you can add, change, or remove folders intended to be shared with others.

Use ‘Local Network Browsing’ if you want to browse a local network. It is like “Network Neighborhood.” Take into account that you need some additional software, especially the LISa daemon (see package kdenetwork3-lisa).

In ‘Proxy’, customize proxy and SOCKS servers. Normally, if your administrator does not tell you to use this, it is probably not useful for you.

The ‘Samba’ submodule should only be customized with the YaST configuration center.

For Konqueror, try the submodule ‘Web Browser’. You can customize fonts, inspect cookies, and determine Web behavior.

### 4.2.5 KDE Components

The ‘Component Chooser’ module handles basic tasks. At the moment, you can change the e-mail client, text editor, messenger, terminal, and Web browser. Whenever a KDE application needs to start an application of these types, it always calls the same component.
KDE uses ‘File Associations’ to identify a file type and start appropriate applications. With this module, customize the icon, filename patterns, description, and order of applications.

Konqueror can also behave like a file manager. The ‘File Manager’ module configures which fonts and font sizes are used, what home URL is used, if previews are allowed, and if quick copy and move actions are allowed.

An overview of all plug-ins of the KDE daemon is shown in ‘Service Manager’. This module shows two different types: services invoked on start-up and services called on demand. Normally do not change the settings of this module, because it is vital for KDE.

With ‘Spell Checker’, KDE provides support for two common spell checking utilities, ASpell and ISpell. This module sets a default configuration that can be shared with other applications.

4.2.6 Peripherals

This setting opens the configuration dialogs for the mouse, keyboard, and printer administration.

4.2.7 Power Control

This is only useful for laptops. ‘Laptop Battery’ monitors your batteries. Power management software must be installed.

4.2.8 Regional & Accessibility

‘Accessibility’ configures functions that can help individuals with difficulties in motor function or vision.

In ‘Country/Region & Language’, set your locale settings. You can add more than one language. Numbers, money, time, and dates can be customized in the respective tabs.

‘Keyboard layout’ allows use of multiple layouts for different languages. For example, you can activate a French and a German layout and switch between them. Enable this with ‘Enable keyboard layouts’, select the one or more layouts from the list, and press ‘Add’. Fine-tune them in the ‘Xkb Options’ tab.

‘Keyboard Shortcuts’ deals with key bindings. A key binding is an association between an action (for example, delete) and one or more keys.
4.2.9 Security & Privacy

To make KDE more secure, ‘Crypto’ allows you to configure SSL (secure socket layer). This is used in most KDE applications as well as others. There is also a possibility to manage your personal certificates.

The KDE password manager can be customized in the module ‘KDE Wallet’. Apart from some general settings, you can create a new wallet. This enables you to have different wallets, for example, for different actions.

To change your personal settings, go to ‘Password & User Account’. Here, set a new name, organization, e-mail address, SMTP server, or password.

The ‘Privacy’ module manages personal Web browsing data. For example, use it to clear the cache, delete the history of visited Web sites, or remove unwanted cookies.

4.2.10 Sound & Multimedia

Here, perform all settings for the playback of audio CDs and for the sound system. Under ‘System Bell’, switch from system notification to a system bell and specify the volume, pitch, and duration of the bell.

By default, system notifications are used. Use this module to determine how the system should inform you in the event of a problem, when a task is performed, or if an event requiring your immediate attention occurs. In the upper part of the dialog, select the application for which to configure the system notifications. As soon as you select a program, all events the application can send to the user are listed in the lower window. Determine the notification type for each notification in the ‘Actions’ dialog.

The default view of the system notification dialog only offers ‘Play a sound’ for audible notification. Click ‘More Options’ to access other action modes. You can log the notification to a file, execute a program, or show the message in a pop-up window. In the lower part of the dialog under ‘Quick Controls’, globally activate or deactivate the actions for all programs.

4.2.11 System Administration

If you want to install new fonts, the ‘Font Installer’ is the right tool. This module shows a list of your personal fonts. Clicking a font displays a sentence in the
respective face. Easily add new fonts with ‘Add Fonts’. To change system fonts, click ‘Administrator Mode’.

The module ‘Linux Kernel’ only takes effect if you have installed the source of your kernel. It is only useful if you are a developer compiling a new kernel and want to customize some options.

With ‘Login Manager’, change the appearance, the fonts used, the background shown, the shutdown behavior, what users are displayed, and some convenience issues for the login screen.

To change the default paths of KDE, go to ‘Paths’. You can customize three different paths: desktop, autostart, and documents.

### 4.3 Konqueror as a File Manager

Konqueror is a unified Web browser, file manager, document viewer, and image viewer. This section covers the use of Konqueror for file management. If you are interested in Konqueror as a Web browser, see Chapter [10](#) on page [151](#).

Start Konqueror by clicking the house icon in the panel or by pressing \`Alt\`+\`F2\` and entering `konqueror $HOME`. The contents of your home directory are then displayed. The file manager window consists of the menu bar at the top, the toolbar, and the location bar. The lower part of the window is split vertically into the navigation panel and the main window, which displays the contents.

#### 4.3.1 File Preview

Konqueror can show you a preview of certain files. Normally this is switched on if you browse in a directory. It only works if your icon view is activated (look into ‘View’ → ‘View Mode’). The preview function can simplify your daily work. In big directories, it gives a rough overview of what is inside the files. Sometimes this is not useful, for example, for packed files. But if you point to the respective file, Konqueror opens a tool tip with additional information, like name, owner, and size.

You can change which files have a preview. Go to ‘Settings’ → ‘Configure Konqueror’ and open the section ‘Previews & Meta-Data’. Konqueror differentiates between Internet and local protocols. Each protocol can be activated. Approve with ‘Ok’.
4.3.2 File Associations

A modern desktop system should know how to handle its file types. With Konqueror, decide which application can be used to process a file. Go to ‘Settings’ ➝ ‘Configure Konqueror’ and open the section ‘File Associations’. If you are searching for an extension, use ‘Find filename pattern’. Only file types with a matching file pattern appear in the list.

For example, to modify the application for MP3 files, enter mp3 and see an entry x-mp3. After a left-click, the setting dialog opens on the right side for this file type. You can change the icon, the filename patterns, a description, and the order of the applications. If your tool is not listed, press ‘Add’ and enter its command. Sometimes the order of the list entries is inappropriate. To change it, click the program to move then give it a higher or lower priority with ‘Move Up’ or ‘Move Down’. The application listed at the top is used by default if you click a file of this type.

Sometimes you need a file type that is not in the list. With ‘Add’, open a dialog box in which to select a group and enter a type name. The group determines the main type, for example, audio, image, text, or video. Usually your file type can be
assigned to one of those. In ‘Type name’, name your file type. After clicking ‘Ok’, determine the extensions of the filename. Put a description in the text field and decide which application to use. Approve with ‘Ok’.

4.3.3 The Konqueror Menu

‘Location’ Using ‘Location’, open additional Konqueror windows. If you click ‘New Window’, your home directory is displayed in a new window. ‘Duplicate Window’ produces a second window with the same content. You can also send a file or a link (using the browser function) by e-mail. If you click one of these menu items, the KMail composer opens. Specify the recipient and compose a text. Depending on the selected item, the file is already attached or the link is displayed in the e-mail body. You can also print directly from this menu.

‘Edit’ Most items under ‘Edit’ only become active if you select an object in the main window. Apart from the standard editing functions, like cutting, copying, pasting, renaming, moving to the trash, and deleting, there is also the ‘Create New’ item, which can be used to create directories, files, and devices. Another item in the ‘Edit’ menu lets you view and change the properties of files and directories and their permissions. With it, grant or deny the owner, a group, or all users read, write, and execute permissions. In the main window, select one or several files by moving the mouse pointer over them while keeping the left mouse button pressed or using ‘Selection’ ➔ ‘Select’.

‘View’ Use the ‘View’ menu to change views. If a directory has many objects in it, the text view or the tree view may be more efficient. To view HTML pages, activate ‘Use index.html’. If a directory contains a file with this name, Konqueror loads and displays it.

To influence the way in which the main window displays directory contents, use the items ‘Icon Size’, ‘Show Hidden Files’, ‘Sort’, and ‘Preview’. In addition, use ‘Configure Background’ to set the main window’s background to a certain color or use an image for it.

‘Go’ The ‘Go’ menu contains the navigation functions ‘Up’, ‘Back’, ‘Forward’, and ‘Home Page’. However, the same functions can be accessed more quickly and conveniently through the toolbar. You can also call applications from this menu and open all folders that have an icon on the desktop. In the lower part of the menu, find a list of the recently-viewed directories or links.
‘Bookmarks’  Bookmarks can be made for Internet addresses (URLs) and paths to specific files or directories on your host. If you select ‘Add Bookmark’, the current content of the location bar is saved as a bookmark. To access this location, simply click this bookmark. For practical reasons, arrange bookmarks in folders. The SUSE folder already exists. This folder contains bookmarks of important SUSE Web pages. ‘Edit Bookmarks’ opens the bookmark editor in which to perform tasks like deleting obsolete bookmarks, renaming bookmarks, and moving bookmarks from one folder to another.

‘Tools’  This menu includes entries for a variety of items, such as ‘Run Command’, ‘Open Terminal Window’, and ‘Find Files’. You can use ‘View Filter’ to limit the view to certain types of files. For example, one of your directories may hold graphics files of different formats, but you only want to see those in PNG format. You could then use this submenu item to hide all files that are not in PNG format.

Selecting ‘Create Image Gallery’ causes Konqueror to search the directory for any image files. The program then creates thumbnail pictures of them and combines these into an HTML page. A dialog box prompts you to set the options for the HTML page, such as the font and the number of thumbnails per line.

‘Settings’  Use the ‘Settings’ menu to configure the look and feel of Konqueror. If you do not want a menu, select ‘Hide Menubar’. Press $\text{Ctrl} + \text{M}$ to display it again. The ‘Toolbars’ submenu allows you to hide or display other elements of the file manager.

View profiles can be used to change the view according to predefined usage patterns. To switch between the available profiles, select ‘Load View Profile’. One of the profiles is the Web browser profile, which is used automatically when you click the Konqueror icon in the panel. Add your own profiles by selecting ‘Configure View Profiles’. In addition, you can specify individual keyboard shortcuts with ‘Configure Shortcuts’, customize the toolbar with ‘Configure Toolbars’, and configure global settings for the file manager with ‘Configure Konqueror’.

‘Window’  The ‘Window’ menu allows you to split the main window horizontally and vertically. It also allows you to manage the tabbed subwindows within the main window by opening or closing a tab, duplicating an existing tab, or detaching a tab into a separate window.

‘Help’  Under the ‘Help’ menu, access the Konqueror handbook or the ‘What’s This’ function. Normally this function can also be accessed with the ques-
tion mark symbol at the top right in the title bar. The mouse pointer is then displayed with a question mark. If you click an icon, a brief help text is displayed, if available. The ‘Help’ menu also provides a short introduction to Konqueror and the possibility to report bugs and other concerns to the developers. ‘About Konqueror’ and ‘About KDE’ provide information about the version, license, authors, and translators of the project.

4.3.4 The Toolbar

The toolbar provides quick access to frequently-used functions that can also be accessed via the menu. If you let the mouse pointer rest above an icon, a short description is displayed. Right-click a free space in the toolbar to open a menu with which to change the position of the toolbar, switch from icons to text, change the icon size, and display or hide the individual bars. Start the configuration dialog with ‘Configure Toolbars’. To the right, the toolbar features the Konqueror icon, which is animated while a directory or Web page is loaded.

4.3.5 The Location Bar

The location bar is preceded by a black symbol with a white X. If you click this icon, the contents of the line are deleted, allowing entry of a new location. Valid locations can be path specifications, like the one that appears when the home directory is displayed, or Web page URLs. After entering an address, press Enter or click ‘Go’ to the right of the input line. Access directories or Web pages visited recently via the black arrow to the right of the location bar. This function saves some typing if you need to access certain contents repeatedly. If there are locations that you need to view again and again, it is more convenient to create bookmarks for them.

4.3.6 The Main Window

The main window displays the content of the selected directory. If you click an icon, the respective file is displayed in Konqueror or loaded into the appropriate application for further processing. Clicking an RPM package lists the contents of the file. Selecting ‘Install package with YaST’ prompts for the root password entry, after which the package is installed.

If you right-click an icon, a menu opens. The kind of menu displayed depends on the file type and offers common actions, such as ‘Cut’, ‘Copy’, ‘Paste’, and
‘Delete’. Use ‘Open with’ to select the application with which to open the file from a list of suitable programs.

The quickest way to perform many actions is the drag and drop method. For example, easily move files from one Konqueror window to another by simply dragging them there while pressing the left mouse button. Subsequently, you are asked whether the objects should be moved or copied.

4.4 Important Utilities

The following pages introduce a number of small KDE utilities intended to assist in daily work. These applications perform various tasks, such as managing your keys for encrypting and signing files and e-mail messages, managing your clipboard, formatting floppy disks, compressing and decompressing diverse file archive types, and sharing your desktop with other users.

4.4.1 Creating an Image Gallery

If you have a large collection of images in a directory, you may find it difficult to manage them. Konqueror can help you by creating an HTML file with thumbnails. Open the respective directory in Konqueror and select ‘Tools’ → ‘Create Image Gallery’. A dialog opens in which to specify the page title, the number of thumbnails per line, the background and foreground colors, and some other details. When you are finished, select ‘Create’ to start the action. By default, Konqueror creates a file named images.html. It can be opened with Konqueror and presents a well-arranged thumbnail index of your image collection. To view an image in full size, simply click the corresponding thumbnail.

4.4.2 Managing Passwords with KWallet Manager

To remember all the passwords for protected resources to which you need to log in can be problematic. KWallet remembers them for you. It collects all passwords and stores them in an encrypted file. With a single password, open your wallet to view, search, delete, or create new entries. Normally you do not need to insert an entry manually. KDE recognizes if a resource requires authentication and KWallet starts automatically.
Important

Protect Your KWallet Password

If you forget your KWallet password, it cannot be recovered. Furthermore, anyone who knows your password can obtain all information contained in the wallet.

Configuring KWallet

When start KWallet for the first time, a dialog window appears with the welcome screen. Choose between ‘Basic setup’ and ‘Advanced setup’. ‘Basic setup’ is recommended. If you choose it, select in the next screen whether you want to store personal information. Some KDE applications, like Konqueror or KMail, can use the wallet system to store Web form data and cookies. Select ‘Yes, I wish to use the KDE wallet to store my personal information’ for this purpose and leave with ‘Finish’.

If you choose ‘Advanced setup’, you have an additional security level screen. The default settings are generally acceptable for most users, but others may wish to change them. ‘Automatically close idle wallets’ closes wallets after a period of inactivity. To separate network passwords and local passwords, activate ‘Store network passwords and local passwords in separate wallet files’. Close with ‘Finish’.

Once configured, KWallet appears in the panel. Right-click the KWallet icon and select ‘Configure Wallet’ if you want to modify the configured. A dialog window opens. Configure different settings, like how KWallet closes a wallet, which wallet is automatically selected, and two options about the wallet manager itself.

The KWallet Manager Window

To store data in your wallet or view its contents, open the manager window by right-clicking the KWallet icon in the panel and selecting ‘Configure Wallet’. The kdewallet folder is the default folder for your passwords. Click kdewallet and a window prompts for your password. After a successful login, you can see the main window. It is divided into four different parts: the top left part displays a summary, the top right part displays subfolders, the lower left part shows a list with folder entries, and the lower right part shows the contents of a selected entry. The window is shown in Figure 4.2 on the next page.
To insert a new item, proceed as follows:

**Procedure 4.1: Inserting New Entries in Your Wallet**

1. You can add a new entry to ‘Maps’ or ‘Passwords’ only. Use ‘Maps’ if you have key and value pairs. ‘Passwords’ can contain multiline entries.

2. Right-click the respective folder entry.

3. A dialog box appears and prompts for a name of the new entry. Name your entry and approve it with ‘Ok’.

4. Your new entry is sorted under your folder entry. Click the new entry to display it on the right side. Initially it is empty.

5. Insert a new key and value pair with a right-click and choose ‘New Entry’. All entries are shown in a table view.

6. Name your key. Activate ‘Show values’ to view the value row. Click to write into the cell.

7. Store your modifications with ‘Save’.

**Figure 4.2: The KWallet Manager Window**
You can always change your password with ‘File’ → ‘Change Password’.

**Advanced Features**

You probably do not need to pay very much attention to KWallet. It resides silently in the panel and is automatically activated if needed. One nice feature of KWallet is that you can move your wallet files to another computer, for example, to your laptop. To simplify this task, wallets can be dragged from the manager window to a file browser window. For example, save it on a USB stick and carry your passwords with you.

### 4.4.3 The Download Manager KGet

KGet is the download manager for KDE. It manages your transfers in a window. Stop, resume, delete, queue, and add transfers.

**Adding Transfers**

Start KGet by pressing \( \text{Alt} + F2 \) and entering the command `kget`. When the program starts for the first time, a dialog is displayed. Confirm this dialog to integrate KGet in Konqueror. When you close the dialog, KGet is integrated in the system tray of the panel as an icon with a downward arrow.

Click this arrow to open the dialog displaying your transfers. To add a transfer to the list, select ‘File’ → ‘Paste’. A dialog opens. Enter a URL in the input field and confirm with ‘OK’. Then specify the location for saving the downloaded file. After all information has been entered, the entry for the transfer is added to the main window of KGet and started.

Another way to add a transfer is by means of drag and drop. Simply drag a file, for example, from an FTP server, from Konqueror and drop it in the main window.

**Timer-Controlled Transfers**

You can also instruct KGet to perform your transfers at a specific time. Activate ‘Options’ → ‘Offline Mode’. All transfers inserted from this point are not started immediately but queued. To start the clock, double-click the respective entry. A dialog opens. Select ‘Advanced’. The dialog is expanded by the settings needed for starting the transfer at a certain time. Enter the day, month, year, time and activate the ‘Timer’ icon. Then close the window.
After making the desired settings for all your transfers, set KGet back to the online mode by deactivating ‘Options’ → ‘Offline Mode’. The transfers should start at the specified times.

**Settings**

In ‘Settings’ → ‘Configure KGet’, set preferences for the connection, determine directories for specific file extensions, and specify other settings.

### 4.4.4 The Clipboard Klipper

The KDE program Klipper serves as a clipboard for selected text, normally marked by keeping the left mouse button pressed. This text can be transferred to another application by moving the mouse pointer to the target location then pressing the middle mouse button (on a two-button mouse, press both buttons simultaneously). The text is copied to the selected location from the clipboard.

By default, Klipper is started when KDE is loaded and appears as a clipboard icon in the panel. View the contents of the clipboard by clicking this icon. The Klipper context menu and the last seven entries, also referred to as the history, are displayed. See Figure 4.3 on this page. If an extensive text was copied to Klipper, only the first line of the text is displayed. The most recent entry is listed on top and is marked as active with a black check mark. To copy an older text fragment from Klipper to an application, select it by clicking it, move the mouse pointer to the target application, then middle-click.

![Figure 4.3: The Clipboard Klipper](image)

As well as the contents of the clipboard, the context menu features the following menu items:
Enable Actions  If you click this, a black check mark is displayed in front of it. For example, if you mark a URL with the mouse when actions are enabled, a window opens, enabling you to select a browser for displaying this URL. Click ‘Enable Actions’ to disable this function.

Clear Clipboard History  Deletes all entries from the clipboard.

Configure Klipper  This opens the Klipper configuration dialog. Control the program with keyboard shortcuts or use regular expressions. Check the Klipper handbook for details. Former Windows users may appreciate the option for activating the keyboard shortcuts (Ctrl+C) and (Ctrl+X) for cutting and (Ctrl+V) for pasting under the ‘General’ tab. To use this feature, activate the entry ‘Synchronize contents of the clipboard and the selection’ in ‘Clipboard/Selection Behavior’. Subsequently, use the mouse or the keyboard shortcuts to which you are accustomed.

Help  This item opens a submenu from which to open the Klipper handbook, send a bug report to the developers, and view information about Klipper and KDE.

Quit  If you click ‘Quit’, a dialog is displayed asking whether Klipper should be started automatically the next time you log in. If you click ‘No’, start the program from the main menu the next time you want to use it. If you click ‘Cancel’, the program is not terminated.

4.4.5  Ark: Displaying, Decompressing, and Creating Archives

To save space on the hard disk, use a packer that compresses files and directories to a fraction of their original size. The application Ark can be used to manage such archives. It supports common formats, such as zip, tar.gz, tar.bz2, lha, and rar.

Start Ark from the main menu or from the command line with ark. If you already have some compressed files, move these from an open Konqueror window to the Ark window to view the contents of the archive. To view an integrated preview of the archive in Konqueror, right-click the archive in Konqueror and select ‘Preview in Archiver’. Alternatively, select ‘File’ → ‘Open’ in Ark to open the file directly. See Figure 4.4 on the next page.

To create a new archive, select ‘File’ → ‘New’. Enter the name of the new archive in the dialog that opens and specify the format using ‘Filter’. After confirming with ‘Save’ or by pressing (Enter), Ark opens an empty window. You can drag and drop files and directories from the file manager into this window. As the final step, Ark compresses everything into the previously selected archive format. For more information about Ark, select ‘Help’ → ‘Ark Handbook’.

### 4.4.6 Screenshots with KSnapshot

With KSnapshot, create snapshots of your screen or individual application windows. Start the program from the main menu or from the command line with the command `ksnapshot`. The dialog window of KSnapshot, shown in Figure 4.5 on the following page, consists of two parts. The upper area contains a preview of the current screen and three buttons for creating and saving the screenshots. In the lower part of the window, set some options to decide how the screenshot should be created.

To take a screenshot, use ‘Snapshot delay’ to determine the period in seconds to wait between when ‘New Snapshot’ is clicked and the actual creation of the screenshot. If ‘Only grab the window containing the pointer’ is active, only the window currently under the pointer is “photographed.” By default, the program creates a shot of the entire screen. To change this, select an item from ‘Capture Mode’. To save the screenshot to a file, select ‘Save as’ and set the directory...
Figure 4.5: KSnapshot

and filename in the dialog that opens. To print the screenshot right away, select ‘Print’.

4.4.7 Viewing PDF Files with KPDF

PDF is probably one of more important formats. KPDF is a KDE program that can view and print them.

Start KPDF by pressing $\text{Alt} + F2$ and entering the command $kpdf$. Load a PDF file with ‘File’ → ‘Open’. KPDF displays it in its main window. On the left side, there is a sidebar with thumbnails and a contents view. Thumbnails give an overview of the page. The contents view contains bookmarks to navigate in your document. Sometimes it is empty, meaning bookmarks are not supported by this PDF.

To view two pages in the main window, select ‘View’ → ‘Two Pages’. The view depends on what last two options you activate in the ‘View’ menu.

Another nice option is to select the area in which you are interested with the select tool from the toolbar. Draw a rectangle and choose from the pop-up menu whether you need the selected area as text or as a graphic. It is copied to the clipboard. You can even save the area to a file.
4.4.8 Chatting With Friends: Kopete

Kopete is an online messenger application allowing multiple partners connected to the Internet to chat with each other. Kopete currently supports all common messenger protocols, such as ICQ, MSN, Yahoo, SMS, Jabber, and IRC.

Configuring Kopete

Configure Kopete by entering your personal user data. Click ‘Settings’ → ‘Configure Kopete’. ‘Connections’ shows all currently available protocols. Check the desired connection type to activate it.

With ‘Accounts’, enter your user data. You must register with a provider offering instant messaging services before using such service. Click ‘New’ to open a configuration assistant that can assist you in completing your user profile.

The next step lists the available messaging services. Select the service with which you have registered and click ‘Continue’. Then enter the user data received upon registration with the messaging service. This usually consists of the nickname or e-mail address and a password. Complete the configuration of the messenger account by clicking ‘Finish’.

![Kopete Configuration Panels](image)

Figure 4.6: Kopete Configuration Panels

The next item in the configuration dialog is ‘Appearance’. It influences how Kopete is displayed. ‘Emoticons’ provides a selection of various types of smileys. Use ‘Chat window’ and ‘Colors & Fonts’ to adjust the appearance of the chat windows for communication with other participants. Choose from the classic themes
of the corresponding providers or create a custom theme by adjusting the font or color to personal preference.

**Adding Contacts**
Add contacts to chat with them. If you have already created an account on another PC, this data is imported and automatically added to your contact list. To create a contact entry manually, click ‘File’ → ‘Add contact’. A new assistant appears to help with creation. However, you must be online to add a contact to your list.

**Adding Groups**
Access this with ‘File’ → ‘Create New Group’. Name the group and confirm this with ‘OK’. A new folder appears in the contact list that can be used to store the desired contacts. Drag and drop contacts into the desired folder. Grouping contacts can give a better overview.

![Image of the Main Kopete Window]

**Figure 4.7: The Main Kopete Window**

**Using Kopete**
It is necessary to establish a connection to the Internet to be able to chat with other participants. When this is done, clicking ‘File’ → ‘Connection’ → ‘Connect
All’ then establishes a connection between Kopete and the selected messaging service.

The main application windows features a list of contacts. When you right-click a contact marked as online, a menu opens with various options. Send that person a message or start a chatting session. A chat allows invitation of additional participants for real-time discussion. Connection to all participants is closed when the creator of the chat session closes it.

Transfer files by right-clicking a username. Many options, such as ‘Delete Contact’, ‘Show User Information’, ‘Block User’, and ‘Send File’, can be found in the menu that opens. Clicking ‘Send File’ opens a dialog for selecting the desired file. Confirming with ‘OK’ sends a dialog to the recipient asking whether he wants to accept the file. If he accepts, the file transfer starts.

### 4.4.9 KDE Accessibility Tools

KDE offers handicap support for daily computer work. There are a number of options in KDE, especially ‘Regional & Accessibility’ ➜ ‘Accessibility’ in the KDE Control Center. Some additional programs also help meet particular needs.

**KMag—Magnify Your Desktop**

People with low vision have limited possibilities for improve the visibility of their desktop. The font size can be increased, but that is not always a good solution. The tool KMag solves this problem. It is a tool to magnify your desktop. Start it with the command `kmag` then see a part of the screen in the KMag window.

With the toolbar, choose some important options, such as the zoom factor, the refresh rate, and how KMag should behave. You can magnify around the mouse cursor, show a window for selecting the magnified area, or magnify the entire screen. With `F5`, halt the process. Press it again to restart it.

**KTTS—The KDE Text-to-Speech Manager**

KTTS is an implementation of a system for producing speech from text. This enables other applications to use this subsystem in a consistent manner. The capabilities of KTTS include speaking the content of a text file, KDE notification events, and all or part of the text of a Web page in Konqueror. Before configure KTTS, make sure that you have `festival` and the KDE accessibility package installed.
Note

Additional Languages

Due to incompatible licenses, only the English may be included in our distribution. For more information about festival, see http://festvox.org/.

To start KTTS, press $\text{Alt} + F2$ and type `kttsmgr`. If you have not configured KTTS yet, the talkers screen appears with an empty list. Click ‘Add’ to add a talker to the list. This opens a new dialog box. Select a speech synthesis plug-in by name or by language. When the synthesizer method is chosen, the synthesizer box and the language box are updated. For example, check the synthesizer box and choose ‘Festival Interactive’. If you leave with ‘OK’, the synthesizer automatically configures itself.

In this example, the ‘Festival Interactive’ talker is added to the list. To configure it, select it and go to ‘Edit’. A dialog box like that in Figure 4.8 on the current page appears. In it, select the voice (if more than one is available), set the volume, speed, and pitch, and test it. Approve with ‘OK’.

![Figure 4.8: Configuring Talkers](image)

KTTS has some additional tabs. With ‘General’, enable or disable the text-to-speech service. Notifications are messages routed from application to the KDE notification system. You can configure it with ‘Speak notifications (KNotify)’. To embed KTTS in the system tray, check the respective option.
The ‘Talker’ tab was already explained above. In ‘Audio’, choose between aRts and GStreamer, two sound systems. ‘Jobs’ gives an overview of your current speech jobs. You can pause, resume, restart, remove, or change the order of the jobs.

**KMouth—Speak Text with KDE**

KMouth is a program designed to speak for those who cannot. You must have installed and configured a speech synthesizer as described in Section KTTS—The KDE Text-to-Speech Manager on page 93.

When you start KMouth for the first time, a wizard opens. This enables you to specify the command to use to speak the text. If you already configured your text to speech system with KTTS, this is not necessary.

The second page lets you select some phrase books. A phrase book is a collection of frequently-used phrases. This has the advantage that the user does not need to type them in. KMouth supports different languages and different topics (courteousness, greetings, “How are you?,” and personal). You can select all or only one of them.

With the third page, define a dictionary. It is used for word completion. You can define either the KDE documentation of the respective language or the OpenOffice.org dictionary as a text basis. After leaving with ‘Finish’, KMouth generates the dictionary and opens the main dialog.

The main dialog, shown in Figure 4.9 on the current page, displays the topics of the phrase books, a history of spoken sentences, and an edit field. To speak, type the sentence in the text field or choose it from the list. Click ‘Speak’.

![Figure 4.9: Using KMouth](image)

---

**Figure 4.9: Using KMouth**
Improve the application by entering your own sentences in your phrase book. Choose ‘Phrase Books’ → ‘Edit’ and a window appears like that in Figure 4.10 on this page. You can see the phrase and the assigned shortcut. By right-clicking the phrase book or a phrase itself, open pop-up menu in which to select ‘New Phrase’. Insert your phrase in the text field. You can assign a shortcut with the keycap button. When satisfied with your settings, choose ‘File’ → ‘Save’. Your added phrase book is shown in your toolbar.

![Phrase Book Window](image)

Figure 4.10: Using Phrase Books in KMouth

### 4.4.10 Font Administration with KFontinst

By default, SUSE LINUX provides various fonts commonly available in different file formats (Bitmap, TrueType, etc.). These are known as system fonts. Users can additionally install their own fonts from various collections on CD-ROM. Such user-installed fonts are, however, only visible and available to the corresponding user.

The KDE control center provides a comfortable tool for administering system and user fonts. It is shown in Figure 4.11 on the next page.
To check which fonts are currently available, type the URL `fonts:/` into the address field of a Konqueror session. This displays two windows: Personal and System. User-installed fonts are installed to the folder Personal. Only root can install to the System folder.

To install fonts as a user, follow these steps:

1. Start the Control Center and access the appropriate module with ‘System Administration’ → ‘Font Installer’.
2. Choose ‘Add Fonts’ from the toolbar or from the menu available when right-clicking the list.
3. In the dialog that opens, select one or more fonts for installation.
4. The marked fonts are then installed to your personal font folder. Selecting a font shows a preview.

To update system fonts, first select ‘Administrator mode’ and enter your root password. Then proceed as described for user font installation.

**Figure 4.11: Font Administration from the Control Center**
SUSE LINUX comes with various sources of information and documentation. The SUSE Help Center provides central access to the most important documentation resources on your system in searchable form. These resources include online help for the installed applications, manual pages, info pages, databases on hardware and software topics, and all manuals delivered with your product.
5.1 Using the SUSE Help Center

When you start the SUSE Help Center for the first time from the main menu (‘SuSE help-center’) or with the command `susehelp` in the shell, the view as shown in Figure 5.1 on the facing page is displayed. The dialog window consists of three main areas:

**Menu Bar and Toolbar** The menu bar provides the main editing, navigation, and configuration options. ‘File’ contains the option for printing the currently displayed content. Under ‘Edit’, access the search function. ‘Go’ contains all navigation possibilities: ‘Table of Contents’ (home page of the Help Center), ‘Back’, ‘Forward’, and ‘Last Search Result’. With ‘Settings’ → ‘Build Search Index’, generate a search index for all selected information sources. The toolbar contains three navigation icons (forward, back, home) and a printer icon for printing the current contents.

**Navigation Area with Tabs** The navigation area in the left part of the window provides an input field for a quick search in selected information sources. Details regarding the search and the configuration of the search function in the ‘Search’ tab are presented in Section 5.1.2 on the next page. The ‘Contents’ tab presents a tree view of all available and currently installed information sources. Click the book icons to open and browse the individual categories.

**View Window** The view window always displays the currently selected contents, such as online manuals, search results, or Web pages.

5.1.1 Contents

The SUSE Help Center provides access to useful information from various sources. It contains special documentation for SUSE LINUX (User Guide and Administration Guide), all available information sources for your workstation environment, online help for the installed programs, and help texts for other applications. Furthermore, the SUSE Help Center provides access to SUSE’s online databases that cover special hardware and software issues for SUSE LINUX. All these sources can be searched comfortably once a search index has been generated.
5.1.2 The Search Function

To search all installed information sources of SUSE LINUX, generate a search index and set a number of search parameters. To do this, open the ‘Search’ tab. See Figure 5.2 on the following page.

If no search index has been generated, the system automatically prompts you to do so when you click the ‘Search’ tab or enter a search string and click ‘Search’.

In the dialog window for generating the search index, shown in Figure 5.3 on page 104, use the check boxes to determine the information sources to index. The index is generated when you exit the dialog with ‘Build Index’.

To limit the search base and the hit list as precisely as possible, use the three drop-down menus to determine the number of displayed hits and the selection area of sources to search. The following options are available for determining the selection area:

- **Default**: A predefined selection of sources is searched.
- **All**: All sources are searched.
- **None**: No sources selected for the search.
Figure 5.2: Configuring the Search Function

Custom Determine the sources to search by activating the respective check boxes in the overview.

When you have completed the search configuration, click ‘Search’. The relevant items are then displayed in the view window and can easily be navigated with mouse clicks.

5.2 Man Pages

Man pages are an essential part of any Linux system. They explain the usage of a command and all available options and parameters. Man pages are sorted in categories as shown in Table 5.1 on this page (taken from the man page for man itself).

Table 5.1: Man Pages—Categories and Descriptions

<table>
<thead>
<tr>
<th>Number</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Executable programs or shell commands</td>
</tr>
</tbody>
</table>
Generally, man pages are delivered with the associated command. They can be browsed in the help center or directly in a shell. To display a man page in a shell, use the `man` command. For example, to display the man page for `ls` enter `man ls`. Each man page consists of several parts labeled `NAME`, `SYNOPSIS`, `DESCRIPTION`, `SEE ALSO`, `LICENSEING`, and `AUTHOR`. There may be additional sections available depending on the type of command. With \( \circ \), exit the man page viewer.

Another possibility to display a man page is to use Konqueror. Start Konqueror and type, for example, `man:/ls`. If there are different categories for a command, Konqueror displays them as links.

### 5.3 Info Pages

Info pages are another important source of information on your system. Usually they are more verbose than man pages. You can browse an info page with an info viewer and display the different sections, called “nodes.” Use the command `info` for this task. For example, to view the info page of info itself, type `info info` in the shell.

For more convenience, use the Help Center or Konqueror. Start Konqueror and type `info:/` to view the top level. To display the info page for `grep`, type `info:/grep`. 
5.4 The Linux Documentation Project

The Linux Documentation Project (TLDP) is run by a team of volunteers who write Linux and Linux-related documentation (see http://www.tldp.org). The set of documents contains tutorials for beginners, but is mainly focused on experienced users like professional system administrators. TLDP publishes HOWTOs, FAQs, and guides (handbooks) under a free license.

5.4.1 HOWTOs

HOWTOs are usually a short, informal step-by-step guide to accomplish a specific task. It is written by experts for nonexperts in a procedural manner. For example, how to configure a DHCP server. HOWTOs can be found in the package howto and are installed under /usr/share/doc/howto

Figure 5.3: Generating a Search Index
5.4.2 Frequently Asked Questions

FAQs (frequently asked questions) are a series of questions and answers. They originate from Usenet newsgroups where the purpose was to reduce continuous reposting of the same basic questions.

5.5 Wikipedia: the Free Online Encyclopedia

Wikipedia is a “a multilingual encyclopedia designed to be read and edited by anyone” (see http://en.wikipedia.org). The content of Wikipedia is created by its users and is published under a free license (GDFL). Any visitors can edit articles, which gives the danger of vandalism, but this does not repel visitors. With over four hundred thousand articles, find an answer for nearly every topic.

5.6 Guides and Books

Linux offers a broad range of guides and books.

5.6.1 SUSE Books

SUSE provides detailed and informative books—the User Guide and Administration Guide. We provide HTML and PDF versions of our books in different languages.

If you need some basics, install the User Guide from the packages suselinux-userguide_XX and suselinux-userguide_XX-pdf (replace (XX) with your preferred language). For the Administration Guide, the package names are suselinux-adminguide_XX and suselinux-adminguide-_XX-pdf.

5.6.2 Other Manuals

The SUSE help center offers additional manuals and guides for various topics or programs. More can be found at http://www.tldp.org/guides.html.
They range from *Bash Guide for Beginners* to *Linux Filesystem Hierarchy* to *Linux Administrator’s Security Guide*. Generally, guides are more detailed and exhaustive than a HOWTO or FAQ. They are usually written by experts for experts. Some of these books are old but still valid. Install books and guides with YaST.

## 5.7 Usenet

Created in 1979 before the rise of the Internet, Usenet is one of the oldest computer networks and still in active use. The format and transmission of Usenet articles is very similar to e-mail, but is developed for a many-to-many communication.

Usenet is organized into seven topical categories: comp.* for computer related discussions, misc.* for miscellaneous topics, news.* for newsgroup-related matters, rec.* for recreation and entertainment, sci.* for science-related discussions, soc.* for social discussions, and talk.* for various controversial topics. The top levels are split in subgroups. For instance, comp.os.linux.hardware is a newsgroup for Linux-specific hardware issues.

Before you can post an article, have your client connect to a news server and subscribe to a specific newsgroup. News clients include Knode or Evolution. Each news server communicates to other news servers and exchanges articles with them. Not all newsgroups may be available on your news server.

Part II

Office
OpenOffice.org is a powerful office suite that offers tools for all types of office tasks, such as writing texts, working with spreadsheets, or creating graphics and presentations. With OpenOffice.org, use the same data across different computing platforms. You can also open and edit files in Microsoft Office formats then save them back to this format, if needed. This chapter only covers the basic skills needed to get started with OpenOffice.org. Start the application from the SUSE menu or using the command oooffice.
OpenOffice.org consists of several application modules (subprograms), which are designed to interact with each other. They are listed in Table 6.1 on the current page. The discussion in this chapter is focused on Writer. A full description of each module is available in the online help, described in Section 6.6 on page 115.

**Table 6.1: The OpenOffice.org Application Modules**

<table>
<thead>
<tr>
<th>Module</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Writer</td>
<td>Powerful word processor application</td>
</tr>
<tr>
<td>Calc</td>
<td>Spreadsheet application that includes a chart utility</td>
</tr>
<tr>
<td>Draw</td>
<td>Drawing application for creating vector graphics</td>
</tr>
<tr>
<td>Math</td>
<td>Application for generating mathematical formulas</td>
</tr>
<tr>
<td>Impress</td>
<td>Application for creating presentations</td>
</tr>
<tr>
<td>Base</td>
<td>Database application</td>
</tr>
</tbody>
</table>

The appearance of the application varies depending on which desktop or window manager is used. Additionally, the open and save dialog formats for your desktop are used. Regardless of the appearance, the basic layout and functions are the same.

### 6.1 Compatibility with Other Office Applications

OpenOffice.org is able to work with Microsoft Office documents, spreadsheets, presentations, and databases. They can be seamlessly opened like other files and saved back to that format. Because the Microsoft formats are closed and the specifics are not available to other applications, there are occasionally formatting issues. If you have problems with your documents, consider opening them in the original application and resaving in an open format, such as RTF for text documents or CSV for spreadsheets.

To convert a number of documents, such as when first switching to the application, select ‘File’ → ‘Wizard’ → ‘Document Converter’. Choose the file format
from which to convert. There are several StarOffice and Microsoft Office formats available. After selecting a format, click ‘Next’ then specify where OpenOffice.org should look for templates and documents to convert and in which directory the converted files should be placed. Before continuing, make sure that all other settings are appropriate. Click ‘Next’ to see a summary of the actions to perform, which gives another opportunity to check whether all settings are correct. Finally, start the conversion by clicking ‘Convert’.

**Important**

**Finding Windows Files**

Documents from a Windows partition are usually in a subdirectory of /windows.

**Important**

When sharing documents with others, you have several options. If the recipient only needs to read the document, export it to a PDF file with ‘File’ → ‘Export as PDF’. PDF files can be read on any platform using a viewer like Adobe Acrobat Reader. To share a document for editing, use one of the regular document formats. The default formats comply with the OASIS standard XML format, making them compatible with a number of applications. TXT and RTF formats, although limited in formatting, might be a good option for text documents. CSV is useful for spreadsheets. OpenOffice.org might also offer your recipient’s preferred format, especially Microsoft formats.

OpenOffice.org is available for a number of operating systems. This makes it an excellent tool when a group of users frequently need to share files and do not use the same system on their computers.

### 6.2 Word Processing with Writer

There are two ways to create a new document. To create a document from scratch, use ‘File’ → ‘New’ → ‘Text Document’. To use a standard format and pre-defined elements for your own documents, try a wizard. Wizards are small utilities that let you make some basic decisions then produce a ready-made document from a template. For example, to create a business letter, select ‘File’ → ‘Wizards’ → ‘Letter’. Using the wizard’s dialogs, easily create a basic document using a standard format. A sample wizard dialog is shown in Figure 6.2 on page 113.

Enter text in the document window as desired. Use the ‘Formatting’ toolbar or the ‘Format’ menu to adjust the appearance of the document. Use the ‘File’ menu
or the relevant buttons in the toolbar to print and save your document. With the options under ‘Insert’, add extra items to your document, such as a table, picture, or chart.

6.2.1 Selecting Text

To select text, click the desired beginning of the selection and, keeping the mouse button pressed, move the cursor towards the end of the range (which can be characters, lines, or entire paragraphs). Release the button when all desired text is selected. While selected, text is displayed in inverted colors. Open a context menu by right-clicking the selection. Use the context menu to change the font, the font style, and other text properties.

Selected text can be cut or copied to the clipboard. Cut or copied text can be pasted back into the document at another location. Use the context menu, ‘Edit’, or the relevant toolbar icons to access these functions.
6.2.2 Navigating in Large Documents

The Navigator displays information about the contents of a document. It also enables you to jump quickly to the different elements included. For example, use the Navigator to get a quick overview of all the chapters or to see a list of the images included in the document. Open it by selecting ‘Edit’ → ‘Navigator’. Figure 6.3 on the following page shows the Navigator in action. The elements listed in the Navigator vary according to the document loaded in Writer.

6.2.3 Formatting with Styles

The dialog opened with ‘Format’ → ‘Styles and Formatting’ can help you format text in a number of ways. If you set the drop-down list at the bottom of this dialog to ‘Automatic’, OpenOffice.org tries to offer a selection of styles adapted to the task at hand. If you select ‘All Styles’, the Stylist offers all styles from the currently active group. Select groups with the buttons at the top.
By formatting your text with this method, called *soft formatting*, text is not formatted directly. Instead, a style is applied to it. The style can be modified easily, automatically resulting in a formatting change of all the text to which it is assigned.

To assign a style to a paragraph, select the style to use then click the paint bucket icon in ‘Styles and Formatting’. Click the paragraphs to which to assign the style. Stop assigning the style by pressing (Esc) or clicking the paint bucket icon again.

Easily create your own styles by formatting a paragraph or a character as desired using the ‘Format’ menu or toolbar. Select the formatted item from which to copy the style. Then click and hold the button to the right of the bucket in ‘Styles and Formatting’ and select ‘New Style from Selection’ from the menu that opens. Enter a name for your style and click ‘OK’. This style can then be applied to other texts.

Change details of a style by selecting it in the list, right-clicking, and selecting ‘Modify’ from the menu. This opens a dialog in which all the possible formatting properties are available for modification.
6.3 Introducing Calc

Calc is OpenOffice.org’s spreadsheet application. Create a new spreadsheet with ‘File’ → ‘New’ → ‘Spreadsheet’ or open one with ‘File’ → ‘Open’. Calc can read and save in Microsoft Excel’s format.

In the spreadsheet cells, enter fixed data or formulas. A formula can manipulate data from other cells to generate a value for the cell in which it is inserted. You can also create charts from cell values.

6.4 Introducing Impress

Impress is designed for creating presentations for screen display or printing, such as on transparencies. Create a presentation from scratch with ‘File’ → ‘New’ → ‘Presentation’. To create one with the assistance of a wizard, use ‘File’ → ‘Wizards’ → ‘Presentation’. Open an existing presentation with ‘File’ → ‘Open’. Impress can open and save Microsoft PowerPoint presentations.

6.5 Introducing Base

OpenOffice 2.0 introduces a new database module. Create a database with ‘File’ → ‘New’ → ‘Database’. A wizard opens to assist in creating the database. Base can also work with Microsoft Access databases.

Tables, forms, queries, and reports can be created manually or using convenient wizards. For example, the table wizard contains a number of common fields for business and personal use. Databases created in Base can be used as data sources, such as when creating form letters.

6.6 For More Information

OpenOffice.org includes a number of information options that provide different levels of information. To get thoroughly acquainted with a topic, select ‘Help’ → ‘OpenOffice.org Help’. The help system provides in-depth information about each of the modules of OpenOffice.org (Writer, Calc, Impress, etc.).
When the application is first started, it provides ‘Tips’, short information about buttons when the mouse hovers over them, and the ‘Help Agent’, information based on actions performed. To get more extensive information about buttons than the ‘Tips’ provide, use ‘Help’ → ‘What’s This’ then hover over the desired buttons. To end ‘What’s This’ mode, click. If you frequently need this function, consider enabling the ‘Extended Tips’ in ‘Tools’ → ‘Options’ → ‘OpenOffice.org’ → ‘General’. The ‘Help Agent’ and ‘Tips’ can also be enabled and disabled here.

The OpenOffice.org Web site is http://www.openoffice.org. There, find mailing lists, articles, and bug information. This site provides the versions for various operating systems for download.
Evolution is a groupware suite that offers regular e-mail features along with extended features, like task lists and a calendar. The application also provides a complete address book, including the ability to send contact information to others in vCard format.
Start Evolution from the main menu or with `evolution`. When started for the first time, Evolution offers a configuration assistant. Its use is described in Section 7.3.1 on page 120.

**Important**

**Microsoft Exchange Accounts**

Using Evolution with Microsoft Exchange requires installation of the `ximian-connector` package. Install it with YaST.

### 7.1 Importing E-Mail from Other Mail Programs

Evolution can import e-mail from other e-mail programs, such as Netscape. To do so, select ‘File’ → ‘Import’. For mbox formats, select ‘Import a single file’. For Netscape, select ‘Import data and settings from older programs’. To work with data from programs using the maildir format, such as KMail, configure an account that accesses the mail directory.

### 7.2 Evolution Overview

The default window view is shown in Figure 7.1 on the facing page. The available menus, menu items, and the icons in the toolbar vary depending on the component open. Use the left frame to select the information to display in the right frame. Adjust the size of the frames by dragging the dividing bars.

#### 7.2.1 Mail

In this view, the upper half of the window shows the contents of the current folder. The lower half is a preview pane used to display the selected mail message. To change the folder displayed, select one from the folder list in the left frame.

Use the search bar to search the messages in a folder. If desired, click a table header for the message list to sort the messages by that header. The sort can be
7.2.2 Contacts

This view shows all the addresses in your address book. To locate a particular address, use the search bar or click the button to the right displaying the first letter of the contact’s last name. Add contacts or lists with the toolbar.

7.2.3 Calendar

The initial display shows a day view of the current day with the month and a task list shown in an additional pane to the right. Week, work week, and month views are also available from the toolbar or the ‘View’ menu. Use the search bar to find an entered appointment. Add appointments and tasks using the buttons in the toolbar. Also use the toolbar to page through the calendar or jump to a specific date.
7.2.4 Tasks

‘Tasks’ provides a list of tasks. Details of the selected task are shown in the lower part of the window. Use ‘File’ → ‘New’ → ‘Task’ to add a new task. Search the tasks with the search bar. Assign tasks to others by right-clicking the task and selecting ‘Assign Task’. ‘Open’ the task to add more details, such as due date and completion status.

7.3 Mail

The Evolution mail component can work with multiple accounts in a variety of formats. It offers useful features, such as virtual folders for showing search results and filtering for junk mail. Configure the application in ‘Edit’ → ‘Preferences’.

7.3.1 Configuring Accounts

Evolution is capable of fetching e-mail from multiple mail accounts. The account from which to send e-mail can be selected when composing a message. Configure mail accounts in ‘Edit’ → ‘Preferences’ → ‘Mail Accounts’. To modify an existing configuration, select it and click ‘Edit’. To delete an account, select it and click ‘Delete’.

To add a new account, click ‘Add’. This opens the configuration assistant. Click ‘Forward’ to use it. Enter your name and your e-mail address in the respective fields. Enter the optional information if desired. Check ‘Make this my default account’ to use this account by default when writing mails. Click ‘Forward’.

Select the appropriate incoming e-mail format for this address in ‘Server Type’. ‘POP’ is the most common format for downloading mail from a remote server. ‘IMAP’ works with mail folders on a special server. Obtain this information from your ISP or server administrator. Complete the other relevant fields displayed when the server type is selected. Click ‘Forward’ when finished. Select the desired ‘Receiving Options’, if available. Click ‘Forward’.

The next set of information to enter is about mail delivery. To submit outgoing e-mail to the local system, select ‘Sendmail’. For a remote server, select ‘SMTP’. Get the details from your ISP or server administrator. For SMTP, complete the other fields displayed after selection. Click ‘Forward’ when finished.
By default, the e-mail address is used as the name to identify the account. Enter another name if desired. Click ‘Forward’. Click ‘Apply’ to save your account configuration.

To make an account the default account for sending e-mail, select the desired account then press ‘Default’. To disable fetching e-mail from an account, select the account then click ‘Disable’. A disabled account can still be used as the address for sending, but that account is not checked for incoming e-mail. If necessary, reactivate the account with ‘Enable’.

### 7.3.2 Creating Messages

To compose a new message, click ‘New’ → ‘Mail Message’. Replying to or forwarding a message opens the same message editor. Next to ‘From’, select from which account to send the message. In the recipient fields, enter an e-mail address or part of a name or address in your address book. If Evolution can match what you enter to something in the address book, a selection list is displayed. Click the desired contact or complete your input if none match. To select directly from the address book, click ‘To’ or ‘CC’.

Evolution can send e-mail as plain text or HTML. To format HTML mail, select ‘Format’ in the toolbar. To send attachments, select ‘Attach’ or ‘Insert’ → ‘Attachment’.

To send your message, click ‘Send’. If not ready to send it immediately, make another selection under ‘File’. For example, save the message as a draft or send it later.

### 7.3.3 Encrypted E-Mail and Signatures

Evolution supports e-mail encryption with PGP. It can sign e-mail and check signed e-mail messages. To use these features, generate and manage keys with an external application, such as gpg or KGpg.

To sign an e-mail message before sending it, select ‘Security’ → ‘PGP sign’. When you click ‘Send’, a dialog prompts for the password of your secret key. Enter the password and exit the dialog with ‘OK’ to send the signed e-mail. To sign other e-mail messages in the course of this session without needing to “unlock” the secret key repeatedly, activate ‘Remember this password for the remainder of this session’.

When you receive signed e-mail from other users, a small padlock icon appears at the end of the message. If you click this symbol, Evolution starts an external
program (gpg) to check the signature. If the signature is valid, a green check mark appears next to the padlock symbol. If the signature is invalid, a broken padlock appears.

The encryption and decryption of e-mail is just as easy. After composing the e-mail message, go to ‘Security’ → ‘PGP encrypt’ and send the e-mail message. When you receive encrypted messages, a dialog opens to ask for the password of your secret key. Enter the passphrase to decrypt the e-mail message.

### 7.3.4 Folders

It is often convenient to sort e-mail messages into a variety of folders. Your folder tree is shown in the left frame. If accessing mail over IMAP, the IMAP folders are also shown in this folder bar. For POP and most other formats, your folders are stored locally, sorted under ‘Local Folders’.

Several folders are included by default. ‘Inbox’ is where new messages fetched from a server are initially placed. ‘Sent’ is used for saving copies of sent e-mail messages. ‘Outbox’ is temporary storage for e-mail that has not yet been sent. It is useful if working offline or if the outgoing mail server is temporarily unreachable. ‘Drafts’ is used for saving unfinished e-mail messages. The ‘Trash’ folder is intended for temporary storage of deleted items. ‘Junk’ is for Evolution’s junk sorting feature.

New folders can be created under ‘On This Computer’ or as subfolders of existing folders. Create as complex a folder hierarchy as desired. To create a new folder, select ‘File’ → ‘New’ → ‘Mail Folder’. In the following dialog, enter a name for the new folder. Use the mouse to determine the parent folder under which to place the new folder. Exit the dialog with ‘OK’.

To move a message into a folder, select the message to move. Right-click to open the context menu. Select ‘Move to Folder’ and, in the dialog that opens, the destination folder. Click ‘OK’ to move the message. The message header in the original folder is shown with a line through it, meaning it is marked for deletion in that folder. The message is stored in the new folder. Messages can be copied in a similar manner.

Manually moving a number of messages into different folders can be time-consuming. Filters can be used to automate this procedure.
7.3.5 Filters

Evolution offers a number of options for filtering e-mail. Filters can be used to move a message into a specific folder or to delete a message. Messages can also be moved directly to the trash with a filter. There are two options for creating a new filter: creating a filter from scratch or creating a filter based on a message to filter. The latter is extremely useful for filtering messages sent to a mailing list.

Setting Up a Filter

Select ‘Tools’ → ‘Filters’. This dialog lists your existing filters, which can be edited or deleted. Click ‘Add’ to create a new filter. To create a filter based on a message, instead select the message then ‘Tools’ → ‘Create Filter from Message’.

Enter a name for the new filter in ‘Rule Name’. Select the criteria to use for the filter. Options include sender, recipients, source account, subject, date, and status. The drop-box showing ‘Contains’ provides a variety of options, such as contains, is, and is not. Select the appropriate condition. Enter the text for which to search. Click ‘Add’ to add more filter criteria. Use ‘Execute actions’ to determine if all or only some of the criteria must be met to apply the filter.

In the lower part of the window, determine the action to take when the filter criteria are met. Messages can, for example, be moved or copied to a folder or assigned a special color. When moving or copying, select the destination folder by clicking. In the folder list that appears, select the folder. Use ‘New’ to create a new folder. Click ‘OK’ when the correct folder is selected. When finished creating the filter, click ‘OK’.

Applying Filters

Filters are applied in the order listed in the dialog accessed with ‘Tools’ → ‘Filters’. Change the order by highlighting a filter and clicking ‘Up’ or ‘Down’. Click ‘OK’ to close the filter dialog when finished.

Filters are applied to all new mail messages. They are not applied to mail already in your folders. To apply filters to messages already received, select the desired messages then select ‘Actions’ → ‘Apply Filters’.

7.4 Contacts

Evolution can use several different address books. Available books are listed in the left frame. Search for a particular contact using the search bar. Add contacts
in several formats to the Evolution address book using ‘File’ → ‘Import’. Right-click a contact to open a menu in which to select from a variety of options, such as forwarding the contact or saving it as a vCard. Double-click a contact to edit it.

**Figure 7.2: The Evolution Address Book**

### 7.4.1 Adding Contacts

Along with the name and e-mail address, Evolution can store other address and contact information about a person. The e-mail address of a sender can quickly be added by right-clicking the marked address in the message preview. To enter a completely new contact, click ‘New Contact’ in the ‘Contacts’ view. Both methods open a dialog in which to enter contact information.

In the ‘Contact’ tab, enter the contact’s name, e-mail addresses, telephone numbers, and instant messaging identities. ‘Personal Information’ is for Web addresses and other detailed information. Enter the contact’s other address information in ‘Mailing Address’. After entering all desired details for the contact, click ‘OK’ to add it to the address book.
7.4.2 Making a List

If you frequently send e-mail messages to a group of people, make this easier by creating a list. Click ‘File’ ➝ ‘New’ ➝ ‘Contact List’. The contact list editor opens. Enter a name for the list. Add addresses by typing the address in the box and clicking ‘Add’ or by dragging contacts from the ‘Contacts’ view and dropping them in the box. Toggle ‘Hide addresses’ to select whether the recipients can see who else has received the mail. Click ‘OK’ when finished. The list is now one of your contacts and appears in the composition window after the first few letters are typed.

7.4.3 Adding Address Books

Configure additional GroupWise and Exchange address books in the account configuration for that account. To add additional local or LDAP books, select ‘File’ ➝ ‘New’ ➝ ‘Address Book’. In the dialog that opens, select the type and enter the required information.

7.5 Calendars

Evolution can work with multiple calendars. With ‘File’ ➝ ‘Import’, import calendars in iCalendar format. Use the calendar to enter appointments and schedule meetings with others. If desired, be reminded of your plans.

7.5.1 Adding Appointments

To add a new appointment to your calendar, click ‘File’ ➝ ‘New’ ➝ ‘Appointment’. Under the ‘Appointment’ tab, enter the details for the appointment. Select a category, if desired, to ease searching and sorting later. Optionally set for Evolution to provide a reminder before your appointment under ‘Alarm’. If the appointment occurs regularly, set that under ‘Recurrence’. Click ‘OK’ after all settings are made. The new appointment is then shown in your calendar.

7.5.2 Scheduling a Meeting

To schedule a meeting with other people, select ‘File’ ➝ ‘New’ ➝ ‘Meeting’. Enter information as for an appointment. Add the attendees in ‘Invitations’ or
‘Scheduling’. To enter attendees from your address book, use ‘Contacts’ to open a dialog in which to select them. ‘Scheduling’ can also be used to schedule a time that fits all attendees. Press ‘Autopick’ after configuring participants to find a time.

### 7.5.3 Adding Calendars

GroupWise and Exchange calendars should be configured in the account configuration. To add additional local or Web calendars, select ‘File’ → ‘New’ → ‘Calendar’. Select the desired type and enter the required information.

### 7.6 Syncing Data with a Handheld

Evolution is designed so its data can be synced with handheld devices, such as a Palm. The synchronization uses GNOME Pilot. Select ‘Tools’ → ‘Pilot Settings’ to open the configuration wizard. Refer to the help for more information.
For More Information

Evolution offers extensive internal help pages. Use the ‘Help’ menu to access this information. For more information about Evolution, refer to the project’s Web site at http://www.gnome.org/projects/evolution/.
Kontact combines the functionality of a number of KDE applications into a convenient single interface for personal information management. These applications include KMail for e-mail, KOrganizer for the calendar, KAddressbook for contacts, and KNotes for notes. It is also possible to sync data with external devices, such as a handheld. Kontact integrates easily with the rest of the KDE desktop and connects to a variety of groupware servers. It includes extra features, such as spam and virus filtering and an RSS reader.
8.1 Importing E-Mail from Other Mail Programs

To import e-mail from other applications, select ‘Tools’ → ‘Import messages’ from the mail view in Kontakt. It currently features import filters for Outlook Express, the mbox format, e-mail text format, Pegasus Mail, and Evolution. The import utility can also be started separately with the command kmailcvt.

Select the corresponding application and confirm with ‘Continue’. A file or a folder must be provided, depending on the selected type. Kontakt then completes the process.

8.2 Kontakt Overview

The default window view, which shows the ‘Summary’, is shown in Figure 8.1 on the next page. Use the buttons in the left section to access the different components.

The ‘Summary’ provides some basic information about upcoming birthdays and to-dos, weather, and the status of KPilot. The news section can access RSS feeds to provide updated news of interest to you. Use ‘Settings’ → ‘Configure Summary View’ to configure the information displayed.

8.2.1 Mail

The folder area to the left contains a list of your mail folders (mail boxes) indicating the total number of messages and how many are still unread. To select a folder, simply click it. The messages it contains appear in the top right frame. The number of messages is also displayed in the status bar at the bottom of the application window.
The subject, sender, and time of receipt of each message are listed in header area to the right. Click a message to select it and display it in the message window. Sort the messages by clicking one of the column headers (subject, sender, date, etc.). The contents of the currently selected message are displayed in the message frame of the window. Attachments are depicted as icons at the end of the message, based on the MIME type of the attachment.

Messages can be marked with different status flags. Change the status with ‘Message’ → ‘Mark Message’. You can use this feature to highlight important messages that you do not want to forget. Display only messages with a certain status using ‘Status’ in the search bar.

### 8.2.2 Contacts

The upper left frame of this component shows all addresses in the currently activated address books. The lower left frame lists your address books and shows the
activation status for each. The right frame shows the currently selected contact. Use the search bar at the top to find a particular contact.

8.2.3 To-Do List

‘To-do List’ shows your list of tasks. Click the field at the top to add a new item to the list. Right-click in a column of an existing item to make changes to the value in that column. An item can be broken into several subitems. Right-click and select ‘New Sub-to-do’ to create a subitem.

8.2.4 Calendar

The calendar view is divided into a number of frames. By default, view a small calendar of this month and a week view of the current week. Also find a list of todos, a detailed view of the current event or to-do, and a list of calendars with the status of each. Select a different view from the toolbar or the ‘View’ menu.

8.2.5 Notes

Use this component to keep notes to yourself. If you are using KDE, use the KNote icon in the panel to make them visible on the desktop.

8.3 Mail

Kontact uses KMail as its e-mail component. To configure it, open the mail component then select ‘Settings’ → ‘Configure KMail’. It is a fully-featured e-mail client that supports a number of protocols. ‘Tools’ contains several useful tools. Use ‘Find’ to perform a detailed search for messages. ‘Anti-Spam Wizard’ can help manage unwanted commercial e-mails. ‘Anti-Virus Wizard’ helps manage virus e-mails. These two wizards work with external spam and virus software. If the options are disabled, install additional packages.

8.3.1 Configuring Accounts

Kontact can manage several e-mail addresses, such as your private e-mail address and your business address. When writing an e-mail, select one of the identities previously defined by clicking ‘View’ → ‘Identity’. To create a new identity
profile, select ‘Settings’ → ‘Configure KMail’ then ‘Identities’ → ‘New’. In the di-
alog that opens, give the new identity a name, such as “private” or “office.” Click
‘OK’ to proceed to a dialog in which to enter some additional information.

Under the ‘General’ tab, enter your name, organization, and e-mail address.
Under ‘Cryptography’, select your keys to send digitally signed or encrypted
messages. For the encryption features to work, first create a key with KGpg, de-
scribed in Chapter 12 on page 165.

Under ‘Advanced’, you can enter a reply-to and a blind carbon-copy address,
choose a dictionary, select the folders for drafts and sent messages, and define
how messages should be sent. Under ‘Signature’, decide if and how each of your
messages should be signed with an extra piece of text at the end. To activate this,
select ‘Enable Signature’ and decide whether the signature should be taken from
a file, from an input field, or from the output of a command. When you are fin-
ished with all your identity settings, confirm with ‘OK’.

The settings under ‘Network’ decide how Kontakt receives and sends e-mail.
There are two tabs, one each for sending and for receiving mail. Many of these

---

Figure 8.2: The Kontakt Mail Component
settings vary depending on the system and network in which your mail server is located. If you are not sure about the settings or items to select, consult your ISP or system administrator.

Create outgoing mail boxes under the ‘Sending’ tab by clicking ‘Add’. Choose between the server types SMTP and sendmail. SMTP is the right choice in most cases. After making this selection, a window appears in which to enter SMTP server data. Provide a name and enter the server address (as given to you by your ISP). If the server wants you to authenticate yourself, enable ‘Server requires authentication’. Security settings are under the ‘Security’ tab. Specify your preferred encryption method here.

Make settings for receiving e-mail under the ‘Receiving’ tab. Use ‘Add’ to create a new account. Choose between different methods for fetching mail, such as local (Mbox or Maildir format), POP3, or IMAP. Make the settings appropriate for your server.

### 8.3.2 Creating Messages

To compose new messages, select ‘Message’ → ‘New Message’ or click the corresponding icon in the toolbar. To send messages from different e-mail accounts, select one of the identities as described in Section 8.3.1 on page 132. In the recipient fields, enter an e-mail address or part of a name or address in your address book. If Kontact can match what you enter to something in the address book, a selection list opens. Click the desired contact or complete your input if none matches. To select directly from the address book, click ‘...’.

To attach files to your message, click the paper clip icon and select the file to attach. Alternatively, drag a file from the desktop or another folder to the ‘New Message’ window or select one of the options in the ‘Attach’ menu. Normally, the format of a file is recognized correctly. If this is not the case, right-click the icon. From the menu that appears, select ‘Properties’. This opens a dialog in which to set the format and the name of the file and add a description. In addition, decide whether the attached file should be signed or encrypted.

When you are finished composing your message, send it immediately with ‘Message’ → ‘Send’ or move it to the outbox with ‘Message’ → ‘Queue’. If you do the former, the message is copied to sent-mail after having been sent successfully. If you do the latter, it is moved to the outbox. Messages in the outbox can still be edited or deleted.
8.3.3  Encrypted E-Mail and Signatures

To encrypt your e-mail, first generate a key pair as described in Chapter 12 on page 165. To configure the details of the encryption procedure, select ‘Settings’ ➝ ‘Configure KMail’ ➝ ‘Identities’ to specify the identity under which to send encrypted and signed messages. Then press ‘Modify’. After confirming with ‘OK’, the key should be displayed in the corresponding field. Close the configuration dialog with ‘OK’.

8.3.4  Folders

Message folders help to organize your messages. By default, they are located in the directory ~/Mail. When starting KMail for the first time, the program creates several folders. inbox is where new messages fetched from a server are initially placed. outbox is used for temporary storage of messages queued for sending. sent-mail is for copies of messages sent. trash contains copies of all e-mails deleted with Del or ‘Edit’ ➝ ‘Delete’. Use drafts to save unfinished messages. If you are using IMAP, the IMAP folders are listed below the local folders.

If you want additional folders to organize your messages, create them by selecting ‘Folder’ ➝ ‘New Folder’. This opens a window in which to specify name and format of the newly created folder.

Right-click the folder for a context menu offering several folder operations. Click ‘Expiry’ to specify the expiration date for read and unread messages and what should happen with them after expiration. If you intend to use the folder to store messages from a mailing list, set the necessary options under ‘Folder’ ➝ ‘Mailing List Management’.

To move one or several messages from one folder to another, highlight the messages to move then press M or select ‘Message’ ➝ ‘Move to’. In the list of folders that appears, select the folder to which to move your messages. Messages can also be moved by dragging them from the upper window and dropping them into the appropriate folder in the left window.

8.3.5  Filters

Filters are a convenient method of automatically processing incoming mail. They use aspects of the mail, such as sender or size, to move mail to certain folders, delete unwanted mails, bounce mails back to the sender, or perform a number of other actions.
Setting Up a Filter

To create a filter from scratch, select ‘Settings’ → ‘Configure Filters’. To create a filter based on an existing message, select the desired message then select ‘Tools’ → ‘Create Filter’ and the desired filter criteria.

Select the match method for filter criteria (all or any). Then select criteria that applies only to the desired messages. In ‘Filter Actions’, set what the filter should do to the messages that meet the criteria. ‘Advanced Options’ provides control over when the filter is applied and whether additional filters should be considered for these messages.

Applying Filters

Filters are applied in the order listed in the dialog accessed with ‘Settings’ → ‘Configure Filters’. Change the order by selecting a filter and clicking the arrow buttons. Filters are only applied to new incoming messages or sent messages as specified in the filter’s advanced options. To apply filters to existing messages, select the desired messages then ‘Message’ → ‘Apply Filters’.

If your filters do not act as expected, monitor them with ‘Tools’ → ‘Filter Log Viewer’. When logging is enabled in this dialog, it shows how messages are processed by your filters and can help locate the problem.

8.4 Contacts

The contacts component uses KAddressBook. Configure it with ‘Settings’ → ‘Configure KAddressBook’. To search for a particular contact, use the search bar. With ‘Filter’, select to display only contacts in a certain category. Right-click a contact to open a menu in which to select from a variety of options, such as sending the contact information in an e-mail.

8.4.1 Adding Contacts

To add a contact with the name and e-mail address from an e-mail, right-click the address in the mail component and select ‘Open in Address Book’. To add a completely new contact, select ‘File’ → ‘New Contact’ in the address component. Both methods open a dialog in which to enter information about the contact.
In the ‘General’ tab, enter basic contact information, such as name, e-mail addresses, and telephone numbers. Categories can be used to sort addresses. ‘Details’ contains more specific information, such as birthday and spouse’s name.

If your contact uses an instant messenger, you can add these identities in ‘IM Addresses’. If you do this and have Kopete or another KDE chat program running at the same time as Kontakt, view status information about these identities in Kontakt. In ‘Crypto Settings’, enter the contact’s encryption data, such as public key.

‘Misc’ has additional information, such as a photograph and the location of the user’s Free/Busy information. Use ‘Custom Fields’ to add your own information to the contact or address book.

Contacts can also be imported in a variety of formats. Use ‘File’ → ‘Import’ and select the desired format. Then select the file to import.
8.4.2 Making a List

If you frequently send e-mail messages to a group of people, make this easier by creating a list. First, click ‘Settings’ ➝ ‘Show Extension Bar’ ➝ ‘Distribution List Editor’. In the new section that appears, click ‘New List’. Enter a name for the list then click ‘OK’. Add contacts to the list by dragging them from the address list and dropping them in the distribution list window. Use this list like regular contacts when creating a mail.

8.4.3 Adding Address Books

**Important**

**Groupware Address Books**

The best way to add groupware resources is with a separate tool. To use it, close Kontact then run `groupwarewizard` in a command line. Select the server type, such as SLOX, Groupwise, or Exchange, from the list offered then enter the address and authentication data. The wizard then adds the available resources to Kontact.

Kontact can access multiple address books, such as shared ones offered by Novell GroupWise or an LDAP server. Select ‘Settings’ ➝ ‘Show Extension Bar’ ➝ ‘Address Books’ to view the current address books. Press ‘Add’ to add one then select the type and enter the required information.

The check boxes in front of the books show the activation status of each. To stop display of a book without deleting it, uncheck it. ‘Remove’ deletes the selected book from the list.

8.5 Calendar

Kontact uses KOrganizer as its calendar component. To configure it, use ‘Settings’ ➝ ‘Configure KOrganizer’. With the calendar, enter appointments and schedule meetings with others. If desired, be reminded of upcoming events. You can also import, export, and archive calendars with the options in ‘File’.
8.5.1 Scheduling an Event

Add a new event or meeting with ‘Actions’ → ‘New Event’. Enter the desired details. Under ‘Reminder’, specify the exact time (minutes, hours, or days in advance) at which the attendees should be reminded of the event. If an event recurs, specify the interval. Another way to create an event at a specific point in the calendar is to double-click the corresponding field in one of the program’s calendar views. This opens the same dialog window as that available from the menu.

Specify the attendees of an event by entering their data manually in the dialog or by inserting data from the address book. To enter such data manually, select ‘New’. To import data from the address book, click ‘Select Addressee’ then select the corresponding entries from the dialog. To schedule the event based on the participants’ availability, go to ‘Free/Busy’ and click ‘Pick Date’.

Use the ‘Recurrence’ tab to configure an event that happens on a regular basis. ‘Attachments’ can be convenient for linking other information with the event, such as an agenda for a meeting.
8.5.2 Adding Calendars

**Important**

**Groupware Calendars**

The best way to add groupware resources is with a separate tool. To use it, close Kontakt then run `groupwarewizard` in a command line. Select the server type, such as SLOX, Groupwise, or Exchange, from the list offered then enter the address and authentication data. The wizard then adds the available resources to Kontakt.

---

The calendar module can connect to multiple calendars simultaneously. This is useful, for example, to combine a personal calendar with an organizational one. To add a new calendar, click ‘Add’ then select the calendar type. Complete the necessary fields.

The check boxes in front of the calendars show the activation status of each. To stop display of a calendar without deleting it, uncheck it. ‘Remove’ deletes the selected calendar from the list.

---

8.6 Syncing Data with a Handheld

Kontact is designed so its data can be synced with handheld devices, such as a Palm. View information about the status of KPilot in the summary. Refer to Chapter 9 on the next page for information about configuring and using KPilot.

8.7 For More Information

Handheld computers are in widespread use among users who need to have their schedules, to-do lists, and notes with them everywhere they go. Often users want the same data to be available both on the desktop and on the portable device. This is where KPilot comes in—it is a tool to synchronize data on a handheld with that used by the KDE applications KAddressBook, KOrganizer, and KNotes, which are part of Kontact.
The main purpose of KPilot is to allow sharing of data between the applications of a handheld computer and their KDE counterparts. KPilot does come with its own built-in memo viewer, address viewer, and file installer, but these cannot be used outside the KPilot environment. Independent KDE applications are available for all these functions except the file installer.

For communication between the handheld and the different desktop programs, KPilot relies on conduits. KPilot itself is the program that oversees any data exchange between the two computer devices. Using a particular function of the handheld on your desktop computer requires that the corresponding conduit is enabled and configured. For the most part, these conduits are designed to interact with specific KDE programs, so in general they cannot be used with other desktop applications.

The time synchronization conduit is special in that there is no user-visible program for it. It is activated in the background with each sync operation, but should only be enabled on computers that use a network time server to correct their own time drift.

When a synchronization is started, the conduits are activated one after another to carry out the data transfer. There are two different sync methods: a HotSync operation only synchronizes the data for which any conduits have been enabled while a backup operation performs a full backup of all data stored on the handheld.

Some conduits open a file during a sync operation, which means the corresponding program should not be running at the given time. Specifically, KOrganizer should not be running during a sync operation.

### 9.1 Conduits Used by KPilot

The conduits used by KPilot can be enabled and configured after selecting ‘Settings’ → ‘Configure KPilot’. The following is a list of some important conduits:

**Address Book**  This conduit handles the data exchange with the handheld’s address book. The KDE counterpart for managing these contacts is KAddressBook. Start it from the main menu or with the command kaddressbook.

**KNotes/Memos**  This conduit allows you to transfer notes created with KNotes to the handheld’s memo application. Start the KDE application from the main menu or with the command knotes.
Calendar (KOrganizer)  This conduit is responsible for syncing the appointments (events) of the handheld. The desktop equivalent is KOrganizer.

ToDos (KOrganizer)  This conduit is responsible for syncing to-do items. The desktop counterpart is KOrganizer.

Time Synchronization Conduit  Enabling this conduit adjusts the handheld’s clock to that of the desktop computer during each sync operation. This is only a good idea if the clock of the desktop computer itself is corrected by a time server at fairly frequent intervals.

![Figure 9.1: Configuration Dialog with the Available Conduits](image)

9.2 Configuring the Handheld Connection

To be able to use KPilot, first set up the connection with the handheld computer. The configuration depends on the type of cradle (docking unit) used with the handheld. There are two types of these: USB cradles or cables and serial cradles or cables.

9.2.1 Configuring the Connection from within KPilot

The easiest way to set up the connection is by using the configuration assistant. Select ‘Settings’ → ‘Configuration Assistant’ to start the assistant. In the first
step, enter your username and the name of the device to which the handheld is connected. The assistant attempts to detect them itself if you select ‘Autodetect Handheld & Username’. If the autodetection fails, refer to Section 9.2.2 on this page.

After confirming with ‘Next’, the assistant prompts you to specify the applications that should be used for synchronization. You can choose among the KDE application suite (default), Evolution, and none. After selecting, close the window with ‘Finish’.

### 9.2.2 Creating a /dev/pilot Link

The setup of the connection with a serial handheld cradle is different from that of a USB cradle. Depending on which cradle is used, you may or may not need to create a symbolic link named /dev/pilot.

**USB** Normally, a USB cradle is autodetected and there should be no need to create the symbolic link mentioned.

**Serial** With a serial cradle, you need to know to which serial port it is actually connected. Serial devices are named /dev/ttyS?, starting from /dev/ttyS0 for the first port. To set up a cradle connected to the first serial port, enter the command:

```
ln -s /dev/ttyS0 /dev/pilot
```

### 9.3 Configuring the KAddressBook Conduit

Initially, it should be sufficient to enable the KAddressBook conduit without changing any of the defaults. After the data has been synchronized for the first time, configure the details: what to do in case of conflicts, the way in which backup databases are saved, and how certain fields as stored on the handheld should be assigned to the fields expected by KAddressBook.
9.4 Managing To-Do Items and Events

On the KDE desktop, to-dos (tasks) and events (appointments) are managed with KOrganizer. Start the application from the main menu, with the command korganizer, or as part of Kontakt. After enabling the calendar and the to-do conduit of KPilot, set some configuration options before using them.

KOrganizer stores its files in the directory ~/.kde/share/apps/korganizer. However, given that the directory .kde/ begins with a dot, it may not be shown by the file selection dialog. In this case, enter the complete path manually or explicitly toggle the display of hidden files (dot files) in the file selection dialog. The default shortcut for this is (F8).

After opening the directory ~/.kde/share/apps/korganizer, select a file that can be used as a calendar file by KOrganizer. In this example, this is the file palm.ics. In the case of a user called tux, the complete path and filename would be /home/tux/.kde/share/apps/korganizer/palm.ics, as shown in Figure 9.3 on the next page.

KOrganizer should not be running when data is being exchanged with the handheld. Otherwise KPilot fails to carry out the sync operation.
9.5 Working with KPilot

Synchronizing the data of KDE applications with those of the handheld computer is quite easy. Simply start KPilot then press the HotSync button on the cradle or cable to initiate the sync operation.

9.5.1 Backing Up Data from the Handheld

To do a full backup, select ‘File’ → ‘Backup’. The backup is performed during the next sync operation. After that, switch back by selecting ‘File’ → ‘HotSync’ from the menu. Otherwise, the time-consuming full backup will be performed again during the next sync operation.

After a full backup, all copies of the handheld’s programs and databases are found in ~/.kde/share/apps/kpilot/DBBackup/USERNAME, where ⟨USERNAME⟩ is the name of the user registered on the handheld.

The two built-in KPilot viewers can be used for a quick lookup of addresses or memos, but they are not designed to actually manage this data. The KDE applications mentioned above are much more suited for these tasks.

Figure 9.3: Dialog Showing the Path to a KOrganizer Calendar File
9.5.2 Installing Programs on the Handheld

The ‘File Installer’ module is an interesting and useful tool for the installation of handheld programs. These programs normally have the extension .prc and they are ready to start immediately after uploading them to the handheld. Before using such add-on programs, read their licenses as well as the instructions included.

9.5.3 Synchronizing Your Address Books and Calendars

To synchronize your calendars and addresses, use the KDE tools MultiSynK. Start the tool with the command multisynk. Create a Konnector pair before you synchronize your data. Go to ‘File’ → ‘New’ and select your Konnectors. Leave it with ‘Ok’.

The name is listed in the main window. To synchronize with your handheld computer go to ‘File’ → ‘Sync’.
Part III

Internet
The Web Browser Konqueror

Konqueror is not only a versatile file manager. It is also a modern Web browser. If you start the browser with the icon in the panel, Konqueror opens with the Web browser profile. As a browser, Konqueror offers tabbed browsing, the possibility of saving Web pages with graphics, Internet keywords, bookmarks, and support for Java and JavaScript.
Start Konqueror from the main menu or by entering the command `konqueror`. To load a Web page, enter its address in the location bar, for example, `http://www.suse.com`. Konqueror now tries to reach the address and display the page. Entering the protocol at the beginning of the address (`http://` in this case) is not strictly required. The program is able to complete the address automatically, but this only works reliably with Web addresses. For an FTP address, always enter `ftp://` at the beginning of the input field.

![Konqueror Homepage](image)

**Figure 10.1: The Browser Window of Konqueror**

### 10.1 Tabbed Browsing

If you often use more than one Web page at a time, tabbed browsing may make it easier to switch between them. Load Web sites in separate tabs within one window. The advantage is that you keep more control over your desktop because you only have one main window. After logout, the KDE session management
allows for saving your Web session in Konqueror. The next time you log in, Konqueror loads the exact URLs visited last time.

To open a new tab, select ‘Window’ → ‘New Tab’ or press \(\text{Ctrl} + \text{Shift} + N\). To change the behavior of tabs, go to ‘Settings’ → ‘Configure Konqueror’. In the dialog box that opens, select ‘Web Behavior’ → ‘Tabbed Browsing’. To open new tabs instead of windows, enable ‘Open links in new tab instead of in new window’. You can also hide the tab bar with ‘Hide the tab bar when only one tab is open’. To see more options, press ‘Advanced Options’.

You can save your tabs with URLs and the position of the window in a profile. This is a bit different from the session management mentioned above. With profiles, you have your saved tabs at hand and without intensive start-up time like with session management.

In Konqueror, go to ‘Settings’ → ‘Configure View Profiles’ and give your profile a name. You can save the window size in the profile, too, with the respective option. Make sure that ‘Save URLs in profile’ is selected. Approve with ‘Save’. Next time you need your “tab collection,” go to ‘Settings’ → ‘Load View Profile’ and see the name listed in the menu. After selecting the name, Konqueror restores your tabs.

10.2 Saving Web Pages and Graphics

As in other browsers, you can save Web pages. To do this, select ‘Location’ → ‘Save as’ and specify a name for your HTML file. However, images are not saved. To archive an entire Web page including the images, select ‘Tools’ → ‘Archive Web Page’. Konqueror suggests a filename that you can usually accept. The filename ends with \(\text{.war}\), the extension for Web archives. To view the saved Web archive later, simply click the respective file and the Web page is displayed in Konqueror along with its images.

10.3 Internet Keywords

Searching the Web using Konqueror is very easy. Konqueror defines over 70 search filters for you, all with a specific shortcut. To search for a certain topic on the Internet, enter the shortcut and the keyword separated by a colon. The relevant page containing the search results is then displayed.
To see the already defined shortcuts, go to ‘Settings’ → ‘Configure Konqueror’. In the dialog box that appears, select ‘Web Shortcuts’. Now you can see the names of the search providers and the shortcuts. Konqueror defines lots of search filters: the “classical” search engines, like Google, Yahoo, and Lycos, and a number of filters for less common purposes, like an acronym database, the Internet movie database, or KDE application searches.

If you do not find your preferred search engine here, easily define a new one. For example, to search our support database for some interesting articles, normally go to http://portal.suse.com/, find the search page, and enter your query. This can be simplified by using shortcuts. In the above dialog box, select ‘New’ and give your shortcut a name in ‘Search provider name’. Enter your abbreviations in ‘URI shortcuts’. There can more than one, separated by commas. The important text field is ‘Search URI’. Pressing \(\text{Shift} + F1\) and clicking in the field opens a small help. The search query is specified as \{@\}. The challenge is inserting this at the correct position. In this case, the settings for the SUSE support database looks like this: ‘Search provider name’ is SUSE Support Database, ‘Search URI’ is (one line) https://portal.suse.com/PM/page/search.pm?q=\{@\}&t=optionSdbKeywords&m=25&l=en&x=true, and ‘URI shortcuts’ is sdb_en.

After approving with ‘Ok’ two times, enter your query in Konqueror’s location bar, for example, sdb_en:kernel. The result is displayed in the current window.

### 10.4 Bookmarks

Instead of remembering and reentering addresses for sites visited often, you can bookmark these URLs using the ‘Bookmark’ menu. Apart from Web page addresses, you can also bookmark any directories of your local disk in this way.

To create a new bookmark in Konqueror, click ‘Bookmarks’ → ‘Add Bookmark’. Any bookmarks added previously are included as items in the menu. It is a good idea to arrange the bookmark collection by subjects in a hierarchical structure, so that you do not lose track of the different items. Create a new subgroup for your bookmarks with ‘New Bookmark Folder’. Selecting ‘Bookmarks’ → ‘Edit Bookmarks’ opens the bookmark editor. Use this program to organize, rearrange, add, and delete bookmarks.

If you are using Netscape, Mozilla, or Firefox as additional browsers, it is not necessary to recreate your bookmarks. ‘File’ → ‘Import Netscape Bookmarks’ in
the bookmark editor enables you to integrate your Netscape and Mozilla bookmarks into your most current collection. The reverse is also possible via ‘Export as Netscape Bookmarks’.

Change your bookmarks by right-clicking the entry. A pop-up menu appears in which to select the desired action (cut, copy, delete, etc.). When you are satisfied with the result, save the bookmarks with ‘File’ → ‘Save’. If you only want to change the name or link, just right-click the entry in the bookmark toolbar and select ‘Properties’. Change the name and location and confirm with ‘Update’.

To save your bookmark list and have instant access to it, make your bookmarks visible in Konqueror. Select ‘Settings’ → ‘Toolbars’ → ‘Bookmark Toolbar (Konqueror)’. A bookmark panel is automatically displayed in the current Konqueror window.

10.5 Java and JavaScript

Do not confuse these two languages. Java is an object-oriented, platform-independent programming language from Sun Microsystems. It is frequently used for small programs (applets), which are executed over the Internet for things like online banking, chatting, and shopping. JavaScript is an interpreted scripting language mainly used for the dynamic structuring of Web pages, for example, for menus and other effects.

Konqueror allows you to enable or disable these two languages. This can even be done in a domain-specific way, which means that you can permit access for some hosts and block access for others. Java and JavaScript are often disabled for security reasons. Unfortunately, some Web pages require JavaScript for correct display.

10.6 For More Information

For any questions or problems that arise when working with Konqueror, refer to the application’s handbook, which is available from the ‘Help’ menu. Konqueror also has a Web page, located at http://www.konqueror.org.
Included with your SUSE LINUX is the Mozilla Firefox Web browser. With features like tabs, pop-up window blocking, and download and image management, Firefox combines the latest Web technologies. View more than one Web page in a single window. Suppress annoying advertisements and disable images that only slow you down. Its easy access to different search engines helps you find the information you need. Start the program from the main menu or by entering the command `firefox`. The main program features are described in the following sections.

11.1 Navigating Web Sites ........................................ 158
11.2 Finding Information ........................................... 159
11.3 Managing Bookmarks ......................................... 160
11.4 Using the Download Manager ................................. 160
11.5 Customizing Firefox .......................................... 161
11.6 Printing from Firefox ......................................... 164
11.7 For More Information ......................................... 164
11.1 Navigating Web Sites

Firefox has much the same look and feel as other browsers. It is shown in Figure 11.1 on this page. The navigation toolbar includes ‘Forward’ and ‘Back’ and a location bar for a Web address. Bookmarks are also available for quick access. For more information about the various Firefox features, use the ‘Help’ menu.

Figure 11.1: The Browser Window of Firefox
11.1.1 Tabbed Browsing

If you often use more than one Web page at a time, tabbed browsing may make it easier to switch between them. Load Web sites in separate tabs within one window.

To open a new tab, select ‘File’ → ‘New Tab’. This opens an empty tab in the Firefox window. Alternatively, right-click a link and select ‘Open link in new tab’. Right-click the tab itself to access more tab options. You can create a new tab, reload one or all existing tabs, or close them.

11.1.2 Using the Sidebar

Use the left side of your browser window for viewing bookmarks or the browsing history. Extensions may add new ways to use the sidebar as well. To display the Sidebar, select ‘View’ → ‘Sidebar’ and select the desired contents.

11.2 Finding Information

There are two ways to find information in Firefox: the search bar and the find bar.

11.2.1 Using the Search Bar

Firefox has a search bar that can access different engines, like Google, Yahoo, or Amazon. For example, if you want to find information about SUSE using the current engine, click in the search bar, type SUSE, and hit (Enter). The results appear in your window. To choose your search engine, click the icon in the search bar. A menu opens with a list of available search engines.

11.2.2 Using the Find Bar

To search inside a Web page, click ‘Edit’ → ‘Find in This Page’ or press (Ctrl)+(F) and the find bar opens. Usually, it is displayed at the bottom of a window. Type your query in the input field. Firefox highlights all occurrences of this phrase. With ‘Highlight’, enable and disable the highlighting.
11.3 Managing Bookmarks

Bookmarks offer a convenient way of saving links to your favorite Web sites. To add the current Web site to your list of bookmarks, click ‘Bookmarks’ ➝ ‘Bookmark This Page’. If your browser currently displays multiple Web sites on tabs, only the URL on the currently selected tab is added to your list of bookmarks.

When adding a bookmark, you can specify an alternative name for the bookmark and select a folder where Firefox should store it.

To remove a Web site from the bookmarks list, click ‘Bookmarks’, right-click the bookmark in the list, then click ‘Delete’.

11.3.1 Using the Bookmark Manager

The bookmark manager can be used to manage the properties (name and address location) for each bookmark and organize the bookmarks into folders and sections. It resembles Figure 11.2 on the next page.

To open the bookmark manager, click ‘Bookmarks’ ➝ ‘Manage Bookmarks’. A window opens and displays your bookmarks. With ‘New Folder’, create a new folder with a name and a description. If you need a new bookmark, click ‘New Bookmark’. This let you insert the name, location, keywords, and also a description. The keyword is a shortcut to your bookmark. If you need your newly created bookmark in the sidebar, check ‘Load this bookmark in the sidebar’.

11.3.2 Migrating Bookmarks

If you used a different browser in the past, you probably want to use your preferences and bookmarks in Firefox, too. At the moment, you can import from Netscape 4.x, 6, 7, Mozilla 1.x, and Opera.

To import your settings, click ‘File’ ➝ ‘Import’. Select the browser from which to import settings. After you click ‘Next’, your settings are imported. Find your imported bookmarks in a newly created folder, beginning with From.

11.4 Using the Download Manager

With the help of the download manager, keep track of your current and past downloads. To open the download manager, click ‘Tools’ ➝ ‘Downloads’. Firefox
Figure 11.2: Using the Firefox Bookmark Manager

opens a window with your downloads. While downloading a file, see a progress bar and the current file. Pause the download and resume it later, if necessary. To open a downloaded file, click ‘Open’. With ‘Remove’, erase it from the medium. If you need information about the file, right-click the filename and choose ‘Properties’.

If you need further control of the Download Manager, open the configuration window from ‘Edit’ → ‘Preferences’ and go to the ‘Downloads’ tab. Here, determine the download folder, how the manager behaves, and some configuration of file types.

11.5 Customizing Firefox

With the ability to install extensions, change themes, and add smart keywords for your online searches, Firefox can be customized extensively.
11.5.1 Extensions

Mozilla Firefox is a multifunctional application, which means you can download and install add-ons, known as extensions. For example, add a new download manager and mouse gestures. This has the advantage that Firefox itself stays small and unbloated.

To add an extension, click ‘Tools’ ➝ ‘Extensions’. In the bottom-right corner, click ‘Get More Extensions’ to launch the Mozilla extensions update Web page where you can choose from a variety of available extensions. Click the extension to install then click the install link to download and install it. When you restart Firefox, the new extension is functional. You can also look at the various extensions at http://update.mozilla.org/.

![Figure 11.3: Installing Firefox Extensions](image)

11.5.2 Changing Themes

If you do not like the standard look and feel of Firefox, install a new theme. Themes do not change the functionality, only the appearance of the browser. When installing a theme, Firefox asks for confirmation first. Allow the installation or to cancel it. After a successful installation, you can enable the new theme.

2. A new dialog appears. Click ‘Get More Themes’. If you already installed a theme, find it in the list, as in Figure 11.4 on this page.

![Figure 11.4: Installing Firefox Themes](image)


4. Choose a theme and click ‘Install Now’.

5. Confirm the download and installation.

6. After downloading the theme, a dialog appears and informs you about your list of themes. Activate the new theme with ‘Use Theme’.

7. Close the window and restart Firefox.

If a theme is installed, you can always switch to a different theme without restarting by clicking ‘Tools’ → ‘Themes’ then ‘Use Theme’. If you do not use a theme anymore, you can delete it in the same dialog with ‘Uninstall’.

### 11.5.3 Adding Smart Keywords to Your Online Searches

Searching the Internet is one of the main tasks a browser can perform for you. Firefox lets you define your own smart keywords: abbreviations to use as a “command” for searching the Web. For example, if you use Wikipedia often, use a smart keyword to simplify this task:

2. After Firefox displays the Web page, see the search text field. Right-click it then choose ‘Add a Keyword for this Search’ from the menu that opens.

3. The ‘Add Bookmark’ dialog appears. In ‘Name’, name this Web page, for example, ‘Wikipedia (en)’.

4. For ‘Keyword’, enter your abbreviation of this Web page, for example, ‘wiki’.

5. With ‘Create in’, choose the location of the entry in your bookmarks section. You can put it into ‘Quick Searches’, but any other level is also appropriate.

6. Finalize with ‘Add’.

You have successfully generated a new keyword. Whenever you need to look into Wikipedia, you do not have to use the entire URL. Just type wiki Linux to view an entry about Linux.

11.6 Printing from Firefox

Configure the way Firefox prints the content it displays using the ‘Page Setup’ dialog. Click ‘File’ ➝ ‘Page Setup’ then go to the ‘Format & Options’ tab to select the orientation of your print jobs. You can scale or make it auto-adjust. To print a background, select ‘Print Background (colors & images)’. Click the ‘Margins & Header/Footer’ tab to adjust margins and select what to include in the headers and footers.

After you configured your settings, print a Web page with ‘File’ ➝ ‘Print’. Select the printer or a file in which to save the output. With ‘Properties’, set the paper size, specify the print command, choose grayscale or color, and determine the margins. When satisfied with your settings, approve with ‘Print’.

11.7 For More Information

Get more information about Firefox from the official home page at http://www.mozilla.org/products/firefox/. Refer to the integrated help to find out more about certain options or features.
Encryption with KGpg

KGpg is an important component of the encryption infrastructure on your system. With the help of this program, generate and manage all needed keys, use its editor function for the quick creation and encryption of files, or use the applet in your panel to encrypt or decrypt by dragging and dropping. Other programs, such as your mail program (Kontact or Evolution), access the key data to process signed or encrypted contents. This chapter covers the basic functions needed for daily work with encrypted files.

12.1 Generating a New Key Pair .......................... 166
12.2 Exporting the Public Key .......................... 166
12.3 Importing Keys ........................................... 168
12.4 The Key Server Dialog ............................. 170
12.5 Text and File Encryption ............................ 171
12.6 For More Information ............................... 173
12.1 Generating a New Key Pair

To be able to exchange encrypted messages with other users, first generate your own key pair. One part of it—the public key—is distributed to your communication partners, who can use it to encrypt the files or e-mail messages they send. The other part of the key pair—the private key—is used to decrypt the encrypted contents.

**Important**

Private Key versus Public Key

The public key is intended for the public and should be distributed to all your communication partners. However, only you should have access to the private key. Do not grant other users access to this data.

Start KGpg from the main menu by selecting ‘Utilities’ ➝ ‘KGpg’ or enter `kgpg` on the command line. When you start the program for the first time, an assistant appears to guide you through the configuration. Follow the instructions up to the point where you are prompted to create a key. Enter a name, an e-mail address, and, optionally, a comment. If you do not like the default settings provided, also set the expiration time for the key, the key size, and the encryption algorithm used. See Figure 12.1 on the next page.

Confirm your settings with ‘OK’. The next dialog prompts you to enter a password twice. The program then generates the key pair and displays a summary. It is a good idea to save or print a revocation certificate right away. Such a certificate will be needed if you forget the password for your private key so need to revoke it. After you confirm with ‘OK’, KGpg displays its main window. See Figure 12.2 on page 168.

12.2 Exporting the Public Key

After generating your key pair, make the public key available to other users. This enables them to use it to encrypt or sign the messages or files they send you. To make the public key available for others, select ‘Keys’ ➝ ‘Export Public Key(s)’. The dialog that opens offers four options:
Figure 12.1: KGpg: Creating a Key

‘Email’ Your public key is sent to a recipient of your choice by e-mail. If you activate this option and confirm with ‘OK’, the dialog for creating a new e-mail message with KMail appears. Enter the recipient and click ‘Send’. The recipient receives your key and can then send you encrypted contents.

‘Clipboard’ You can place your public key here before continuing to process it.

‘Default Key Server’ To make your public key available to a wide audience, export it to one of the key servers on the Internet. For more information, refer to Section 12.4 on page 170.

‘File’ If you prefer to distribute your key as a file on a data medium instead of
12.3 Importing Keys

If you receive a key in a file (for example, as an e-mail attachment), integrate it in your key ring with ‘Import Key’ and use it for encrypted communication with the sender. The procedure is similar to the procedure for exporting keys already described.

12.3.1 Signing Keys

Keys can be signed like every other file to guarantee their authenticity and integrity. If you are absolutely sure an imported key belongs to the individual specified as the owner, express your trust in the authenticity of the key with your signature.
**Important**

**Establishing a Web of Trust**

Encrypted communication is only secure to the extent that you can positively associate public keys in circulation with the specified user. By cross-checking and signing these keys, you contribute to the establishment of a web of trust.

---

**Important**

Select the key to sign in the key list. Select ‘Keys’ → ‘Sign Keys’. In the following dialog, designate the private key to use for the signature. An alert reminds you to check the authenticity of this key before signing it. If you have performed this check, click ‘Continue’ and enter the password for the selected private key in the next step. Other users can now check the signature by means of your public key.

---

### 12.3.2 Trusting Keys

Normally, you are asked by the corresponding program whether you trust the key (whether you assume it is really used by its authorized owner). This happens each time a message needs to be decrypted or a signature must be checked. To avoid this, edit the trust level of the newly imported key.

Right-click the newly imported key to access a small context menu for key management. Select ‘Edit Key in Terminal’ from it. KGpg opens a text console in which to set the trust level with a few commands.

At the prompt of the text console (Command >), enter trust. On a scale between 1 (unsure) and 5 (complete trust) make an estimate of how much you trust that the signers of the imported key have checked the true identity of the key owner. Enter the selected value at the prompt (Your decision?). If you are really sure about the signers’ trustworthiness, enter 5. Answer the following question by entering y. Finally, enter quit to exit the console and return to the list of keys.

The key now has the trust level Ultimate.

The trust level of the keys in your key ring is indicated by a colored bar next to the key name. The lower the trust level is, the less you trust the signer of the key to have checked the true identity of the keys signed. You may be entirely sure about the signer’s identity, but he may still be lazy in regard to checking other people’s identities before signing their keys. Therefore, you could still trust him and his own key, but assign lower trust levels to the keys of others that have been signed by him. The trust level’s purpose is solely one of a reminder. It does not trigger any automatic actions by KGpg.
12.4 The Key Server Dialog

Several Internet-based key servers offer the public keys of many users. To engage in encrypted communication with a large number of users, use these servers to distribute your public key. For this purpose, export your public key to one of these servers. Similarly, KGpg enables you to search one of these servers for the keys of certain people and import their public keys from the server. Open the key server dialog with 'File' → 'Key Server Dialog'.

12.4.1 Importing a Key from a Key Server

By means of the ‘Import’ tab in the key server dialog, import public keys from one of the Internet-based key servers. Use the drop-down menu to select one of the preconfigured key servers and enter a search string (e-mail address of the communication partner) or the ID of the key to find. When you click ‘Search’, your system connects to the Internet and searches the specified key server for a key that matches your specifications. Refer to Figure 12.3 on this page.

![Figure 12.3: Search Screen for Importing a Key]

If your search on the key server is successful, a list of all retrieved server entries is displayed in a new window. Select the key to include in your key ring and click ‘Import’. See Figure 12.4 on the next page. Confirm the following message with
‘OK’ then exit the key server dialog with ‘Close’. The imported key then appears in the main overview of the key manager and is ready for use.

![Figure 12.4: Hits and Import](image)

12.4.2 Exporting Your Keys to a Key Server

To export your key to one of the freely accessible key servers on the Internet, select the ‘Export’ tab in the key server dialog. Designate the target server and the key to export by means of two drop-down menus. Then start the export with ‘Export’.

12.5 Text and File Encryption

KGpg also offers the possibility to encrypt text or clipboard contents. Click the padlock icon and find the options ‘Encrypt clipboard’ and ‘Decrypt clipboard’ as well as the option for opening the integrated editor.
12.5.1 Encrypting and Decrypting the Clipboard

Files copied to the clipboard can easily be encrypted with a few clicks. Open the function overview by clicking the KGpg icon. Select ‘Encrypt Clipboard’ and designate the key to use. A status message about the encryption procedure is displayed on the desktop. The encrypted contents can now be processed from the clipboard as needed. The decryption of clipboard contents is just as easy. Simply open the menu on the panel, select ‘Decrypt Clipboard’, and enter the password associated with your private key. The decrypted version is now available for processing in the clipboard and in the KGpg editor.

12.5.2 Encrypting and Decrypting by Dragging and Dropping

To encrypt or decrypt files, click the icons on the desktop or in the file manager, drag them to the padlock in the panel, and drop them there. If the file is not encrypted, KGpg asks for the key to use. As soon as you select a key, the file is encrypted without any further messages. In the file manager, encrypted files are designated with the suffix `.asc` and the padlock icon. These files can be decrypted by clicking the file icon, dragging it to the KGpg symbol in the panel, and dropping it there. Then select whether the file should be decrypted and saved or displayed in the editor.
12.5.3 The KGpg Editor

Instead of creating contents for encryption in an external editor then encrypting the file with one of the methods described above, you can use the integrated editor of KGpg to create the file. Open the editor (‘Open Editor’ from the context menu), enter the desired text, and click ‘Encrypt’. Then select the key to use and complete the encryption procedure. To decrypt files, use ‘Decrypt’ and enter the password associated with the key.

Generating and checking signatures is just as easy as encrypting directly from the editor. Go to ‘Signature’ ➝ ‘Generate Signature’ and select the file to sign from the file dialog. Then designate the private key to use and enter the associated password. KGpg informs about the successful generation of the signature. Files can also be signed from the editor by simply clicking ‘Sign/Verify’. To check a signed file, go to ‘Signature’ ➝ ‘Verify Signature’ and select the file to check in the following dialog. After you confirm the selection, KGpg checks the signature and reports the result of the operation. Another possibility is to load the signed file into the editor and click ‘Sign/Verify’.

12.6 For More Information

For theoretical background information about the encryption method, refer to the brief and clear introduction on the GnuPG project pages at http://www.gnupg.org/documentation/howtos.html.en. This document also provides a list of further information sources.
Part IV

Multimedia
Linux includes a wide range of sound and multimedia applications. Some of these applications are part of one of the main desktop environments. With the applications described here, control the volume and balance of playback, play CDs and music files, and record and compress your own audio data.
13.1 Mixers

Mixers provide a convenient means of controlling the volume and balance of the sound output and input of computers. The main difference between the various mixers is the outer appearance of the user interface. However, there are a number of mixers that are designed for specific hardware. One example is envy24control, a mixer for the Envy 24 sound chip. Another one is hdspmixer, which is for RME Hammerfall cards. From the mixers available, select the one that best suits your needs.

Generally, it is advisable to open a mixer application before opening other sound applications. Use the mixer to test and adjust the control settings for the input and output of the sound card.

13.1.1 KMix

KMix is the KDE mixer application. It is integrated into the KDE panel as a small panel applet located in the system tray. Click the panel icon to control the volume of your speakers with a control slider. If you right-click the icon, the context menu of KMix appears. Select ‘Mute’ to switch off the sound output. The panel icon then changes its appearance. Clicking ‘Mute’ again unmutes the volume. To fine-tune your sound settings, select ‘Show Mixer Window’ and configure ‘Output’, ‘Input’, and ‘Switches’. Each of the devices featured there has its own context menu that is opened by a right-clicking the device icon. You can mute or hide each one of them separately.

13.1.2 The GNOME Mixer Applet

GMix, the volume control applet for the GNOME desktop, is integrated into the GNOME panel. Click the panel icon to control the volume of your speakers with a simple control slider. To switch off the sound output, right-click the icon and select ‘Mute’. The volume control icon then changes its appearance. To unmute the sound output, right-click the icon again and select ‘Mute’ from the menu. Select ‘Open Volume Control’ to access the more advanced mixer features, shown in Figure 13.2 on page 180. Each sound device has its own mixer tab.
13.1.3 alsamixer

alsamixer can be run from the command line without the X environment, so is entirely controlled via keyboard shortcuts. An alsamixer window always consists of the following elements: a top row holding basic information on card and chip type, the selected view type, and the mixer item then the volume bars below the information area. Use ← and → to scroll left or right if the controls cannot be displayed in one screen. The names of the controls appear below the controls and the currently selected control is colored in red. Toggle between muted and unmuted state of any mixer control using M. A muted control has ‘MM’ written below its name. Any control that has capture (recording) capabilities has a red capture flag.

alsamixer has three different view modes: ‘Playback’, ‘Capture’, and ‘All’. By default, alsamixer is started in ‘playback’ mode, displaying only those mixer controls relevant for playback (Master Volume, PCM, CD, etc.). ‘Capture’ displays only those controls used for recording. ‘All’ displays all controls available. Switch the view modes using F3, F4, and F5.

Select channels with ← and → or $\uparrow$ and $\downarrow$. Use $\uparrow$ and $\uparrow$ or $+$ and $-$ to in-
crease and decrease the volume. Stereo channels can be controlled independently, using 'Q', 'W', and 'E' for increasing the volume and 'Z', 'X', and 'C' for decreasing the volume. The number keys between '0' and '9' can be used to change the absolute volume quickly. These correspond to zero to ninety percent of full volume.

13.1.4 Look and Feel of Mixer Applications

The look and feel of mixer applications depends on the type of sound card used. Some drivers, like SB Live!, have many controllable (tunable) mixer elements while the drivers for professional sound cards may have elements with totally different names.

On-Board Sound Chip

Most of the PCI on-board sound chips are based on AC97 codec. ‘Master’ controls the main volume from the front speakers. ‘Surround’, ‘Center’, and ‘LFE’ control the rear, center, and bass-boost speakers. Each of them has a mute switch. In addition to that, some boards have individual ‘Headphone’ and ‘Master Mono’ volumes. The latter is used for the built-in speaker on some laptops.
‘PCM’ controls the internal volume level of digital WAVE playback. PCM is an acronym for Pulse Code Modulation, one of the digital signal formats. This control has also an individual mute switch.

Other volumes, like ‘CD’, ‘Line’, ‘Mic’, and ‘Aux’, control the loopback volume from the corresponding input to the main output. They do not influence the recording level, only the playback volumes.

For recording, turn on the ‘Capture’ switch. This is the master recording switch. The ‘Capture’ volume is the input gain for recording. By default, this switch is set to zero. Choose a recording source like ‘Line’ or ‘Mic’. The recording source is exclusive, so you cannot choose two of them at the same time. ‘Mix’ is a special recording source. You can record the currently played signal from this source.

Depending on the AC97 codec chip, special effects, like 3D or bass/treble, are available, too.

**SoundBlaster Live! and Audigy Family**

SoundBlaster Live! and SB Audigy1 have numerous mixer controls for their AC97 codec chip and DSP engine. In addition to the controls already described, they have ‘Wave’, ‘Music’, and ‘AC97’ volumes to control the internal signal routing and attenuation for PCM, WaveTable MIDI, and AC97 mixing. Keep the volume at 100% to hear all of them. SB Audigy2 (depending on the model) has less controls than SB Live, but still has ‘Wave’ and ‘Music’ controls.

The recording on SB Live is similar to on-board chip. You can choose ‘Wave’ and ‘Music’ as the additional recording source to record the played PCM and WaveTable signals.

**USB Audio Devices**

USB audio devices usually have a small number of mixer controls. Sometimes they even have none at all. Most devices either have a ‘Master’ or ‘PCM’ control switch to control the playback volume.

### 13.1.5 The Mixer for the Sound Chip Envy24

envy24control is a mixer application for sound cards using the Envy24 (ice1712) chip. The flexibility of the Envy24 chip can result in varying functionalities in different sound cards. The latest details on this sound chip are available in /usr/share/doc/packages/alsa-tools/envy24control.
Figure 13.3: Monitor and Digital Mixer of envy24control

The ‘Monitor Mixer’ of envy24control shows the signal levels that can be mixed digitally in the sound card. The signals designated as ‘PCM Out’ are generated by applications that send PCM data to the sound card. The signals of the analog inputs are shown under ‘H/W In’. The ‘S/PDIF’ inputs are shown to the right. Set the input and output levels of the analog channels under ‘Analog Volume’.

Use the ‘Monitor Mixer’ sliders for digital mixing. The respective levels are displayed in the ‘Digital Mixer’. For each output channel, the ‘Patchbay’ contains a row of radio buttons for selecting the desired channel source.

Adjust the amplification for the analog-to-digital and digital-to-analog converters under ‘Analog Volume’. Use the ‘DAC’ sliders for the output channels and the ‘ADC’ sliders for the input channels.

The S/PDIF channel settings are made under ‘Hardware Settings’. The Envy24 chip reacts to volume changes with a delay that can be configured with ‘Volume Change’.

13.2 Multimedia Players

13.2.1 amaroK

The amaroK media player handles various audio formats and plays the streaming audio broadcasts of radio stations on the Internet. The program handles all
file types supported by the sound server acting as a back-end—currently aRts or GStreamer.

On first start, amaroK launches a ‘First-Run Wizard’, which helps set up amaroK. In the first step, configure your preferred look and feel for amaroK. Choose to display player and playlist in separate windows (see Figure 13.4 on the current page) or combine their functionality in one single window. In the second step, determine where amaroK should look for your music collection. amaroK scans these folders recursively (to include all their subdirectories in the scan), monitor changes to the content of the selected directories, and import any playlists located there. All the settings made with the wizard can be modified later by starting the wizard again with ‘Tools’ → ‘First-Run Wizard’.

![Figure 13.4: The amaroK Media Player](image-url)
Managing Playlists

On start-up, amaroK scans the file system for multimedia files according to the settings made in the wizard. The right part of the playlist window lists any playlists found. Play titles listed in it in the order of your choice. If no playlist is found, create one. The best way to do this is by using the sidebar to the left of the window. To the far left, there are a number of tabs that can be used to open different views. From each of these views, drag individual titles or entire directories and drop them into the playlist to include them in the list. The following is a description of the function of each tab.

Context  With this tab, view information about your collection and the current artist. For example, the view informs you about your favorite titles, the newest titles added to the collection, and other details. The ‘Home’ view provides statistics on your listening habits, listing your favorite, newest, and least-played tracks. ‘Current Track’ provides data related to the track currently being played, such as the album cover (see Section The Cover Manager on the facing page), the listening statistics related to this track, and much more. If you are interested in the lyrics of the track, display them using the ‘Lyrics’ tab.

Collection Browser  Use this view to manage and display your personal collection of titles. The collection view may include files from different locations. The wrench icon in the toolbar lets you determine what locations should be scanned for music files. Once you select the directories, the scan starts automatically. The result is displayed as a tree structure. Using ‘Primary’ and ‘Secondary’, organize the two top branches of the tree according to the criteria ‘Album’, ‘Artist’, ‘Genre’, and ‘Year’. Once the tree view is ready, find titles simply by typing them into the input field. The selection in the tree view jumps to the first matching entry automatically as you type. To update your collection data, initiate a rescan of the file system using ‘Tools’ → ‘Rescan Collection’.

Playlist Browser  The playlist browser is divided into two parts. The upper part lists all your custom playlists created by dragging tracks into the playlist window and clicking ‘Save Playlist As’. View the contents of them by clicking the ‘+’ next to the playlist’s name. Modify these playlists using drag and drop. To load one of them, double-click the playlist.
Important

Sharing Playlists with Other Players

Save playlists in m3u or pls format, so you can share them with any other players using these formats.

Important

amaroK can compile useful playlists (“Smart Playlists”) on the fly. Use the bottom part of the playlist browser to select one of the smart playlists or click ‘Create Smart Playlist’ to define a custom smart playlist. Enter a name, search criteria, order, and optional track limit.

File Browser

This tab opens a file browser. It corresponds to the standard KDE file selector dialog with the usual controls for navigating the file system. Enter a URL or directory directly into the text input field. From the contents displayed, drag elements to the playlist to include them. You can also perform a recursive search for a file in a given directory. To do so, enter a text string for the title and the location at which to start the search. Then select ‘Search’ and wait for the results to appear in the lower section of the window.

The Cover Manager

amaroK features a cover manager to enable you to keep matching music and image data on the albums you play. Start the ‘Cover Manager’ with ‘Tools’ ➔ ‘Cover Manager’. A tree view in the left part of the window lists all the albums of your collection. The covers retrieved from Amazon are displayed in the right part of the window. With ‘View’, choose what is displayed in the cover list view. ‘All albums’ lists all albums of your collection, regardless of whether they have a cover image. ‘Albums with cover’ lists only those with a cover and ‘Albums without cover’ lists those lacking a cover. To retrieve cover data, choose your ‘Amazon Locale’ then click ‘Fetch Missing Covers’. amaroK then tries to get covers for all albums contained in your collection.

Effects

Select the ‘FX’ button in the player window or use the amaroK application menu to open a dialog in which to enable and configure several sound effects, such as an equalizer, the stereo balance, and a hall effect. Select the desired effects and adjust the settings, if available, for each of them.
Visualizations

amaroK comes with a number of visualizations that display a graphical effect for the music played. Native amaroK visualizations are displayed in the player window. Cycle through the various available display modes by clicking the animation.

In addition to the above, amaroK also supports the visualization plug-ins of the XMMS media player. To use these, first install the `xmms-plugins` package then select ‘Visualizations’ from the amaroK menu. This opens a window listing the available plug-ins. XMMS plug-ins are always displayed in an extra window. In some cases, there is an option to display them in fullscreen mode. For some plug-ins, you may not get a smooth visual effect unless you use a 3D-accelerated graphics card.

13.2.2 XMMS

XMMS is another full-featured media player with robust audio support, so that pops or breaks during playback should be very rare. The application is easy to use. The button for displaying the menu is located in the upper left corner of the program window. For those preferring a GNOME-like look and feel, there is a GTK2 version of XMMS available, the Beep Media Player. Just install the package `bmp`. However, not all XMMS plug-ins are supported by this port of XMMS.

Select the output plug-in module with ‘Options’ ➝ ‘Preferences’ ➝ ‘Audio I/O Plugins’. If the `xmms-kde` package is installed, the aRts sound server can be configured here.

**Important**

**Using the Disk Writer Plug-In**

XMMS automatically redirects its output to the ‘Disk Writer Plugin’ if it is not able to find a configured sound card. In this case, the played files are written to the hard disk as WAV files. The time display then runs faster than when playing the output through a sound card.

**Important**

Start various visualization plug-ins with ‘Options’ ➝ ‘Preferences’ ➝ ‘Visualization Plugins’. If you have a graphics card with 3D acceleration, select an application such as the OpenGL spectrum analyzer. If the `xmms-plugins` package is installed, try the Infinity plug-in.
To the left under the menu button, there are five buttons with different letters on them. These buttons allow quick access to additional menus, dialog, and configurations. Open the playlist with ‘PL’ and the equalizer with ‘EQ’.

13.3 CDs: Playback and Ripping

There are many ways to listen to your favorite music tracks. Either play a CD or play digitalized versions of them. The following section features some CD player applications as well as some applications that can be used for the ripping and encoding of audio CDs.
**Important**

**CDDA and Analog CD Playback**

There are two different ways of playing back audio CDs. CD and DVD drives capable of analog CD playback read out the audio data and send it to the sound output device. Some external drives connected via PCMCIA, FireWire, or USB need to use CDDA (Compact Disk Digital Audio) to extract the audio data first then play it as digital PCM. The players featured in the following sections do not support CDDA. Use XMMS if you need CDDA support.

### 13.3.1 KsCD—Audio CD Player

KsCD is an easy-to-use audio CD player. It integrates into the KDE taskbar and can be configured to start playing automatically after a CD has been inserted. To access the configuration menu, select ‘Extras’ → ‘Configure KsCD’. Fetch album and track information from a CDDB server on the Internet if KsCD is configured accordingly. You can also upload CDDB information to share it with others. Use the ‘CDDB’ dialog for information retrieval and upload.

![The KsCD User Interface](image)

**Figure 13.6: The KsCD User Interface**

### 13.3.2 GNOME CD Player Applet

This is a simple applet that integrates into a GNOME panel. Using the tools icon, configure its behavior and select a theme. Control the playback with the buttons
at the bottom of the player window or using the context menu opened by right-clicking the panel icon or player window.

### 13.3.3 Compressing Audio Data

Audio compression can be handled by various tools. The following sections feature a command-line approach to encoding and playing audio data as well as some graphical applications capable of audio compression.

#### Command Line Tools for Encoding and Playback of Audio Data

Ogg Vorbis (package `vorbis-tools`) is a free audio compression format that is now supported by the majority of audio players. The Web page of the project is [http://www.xiph.org/ogg/vorbis](http://www.xiph.org/ogg/vorbis).

SUSE LINUX comes with several tools supporting Ogg Vorbis. `oggenc` is a command line tool used for encoding WAV files to Ogg. Just run `oggenc ⟨myfile.wav⟩` to transform a given `.wav` file into Ogg Vorbis. The option `-h` displays an overview of the other parameters. `oggenc` supports encoding with a variable bit rate. In this way, an even higher degree of compression can be achieved. Instead of the bit rate, specify the desired quality with the parameter `-q`. `-b` determines the average bit rate. `-m` and `-M` specify the minimum and maximum bit rate.

`ogg123` is a command-line Ogg player. Start it with a command like `ogg123 mysong.ogg`.

#### Compressing Audio Data Using Grip

Grip is a GNOME CD player and ripper (see Figure 13.7 on the next page). The CD player functionality is entirely controlled by the buttons in the bottom part of the window. Control the ripping and encoding functionality using the tabs at the top of the window. To view and edit the track and album information or to select the tracks to rip, open the ‘Tracks’ tab. Select a track by clicking the check box next to the track title. To edit the track information, click ‘Toggle disc editor’ and submit your modifications. The ‘Rip’ tab selects the preferred rip mode and controls the ripping process. Access the entire Grip configuration under the ‘Config’ tab. Use ‘Status’ to check the status of the application.
Compressing Audio Data Using KAudioCreator

KAudioCreator is a lean CD ripper application (see Figure 13.8 on the facing page). Once started, it lists all the tracks of your CD in the 'CD Tracks' tab. Select the tracks to rip and encode. To edit the track information, use the 'Album Editor' under 'File' → 'Edit Album'. Otherwise just start the ripping and encoding with 'File' → 'Rip Selection'. Watch the progress of these jobs using the 'Jobs' tab.

If configured accordingly, KAudioCreator also generates playlist files for your selection that can be used by players, like amaroK or XMMS.

Compressing Audio CDs Using Konqueror

Before you start the actual ripping process with Konqueror, configure the handling of audio CDs and the Ogg Vorbis encoder in the KDE Control Center. Select 'Sound & Multimedia' → 'Audio CDs'. The configuration module is divided into
Figure 13.8: Ripping Audio CDs with KAudioCreator

three tabs: ‘General’, ‘Names’, and ‘Ogg Vorbis Encoder’. Normally, a suitable CD device is detected automatically. Do not change this default setting unless the autodetection failed and you need to set the CD device manually. Error correction and encoder priority can also be set here. The tab ‘Ogg Vorbis Encoder’ determines the quality of the encoding. To configure online lookup of album, track, and artist information for your ripped audio data, select ‘Add Track Information’.

Start the ripping process by inserting the CD into the CD-ROM drive and enter audiocd:/ at the ‘Location’ bar. Konqueror then lists the tracks of the CD and some folders (see Figure 13.9 on the next page).

To keep uncompressed audio data on your disk, just select the .wav files and drag them into another Konqueror window to copy them over to their final destination. To start the Ogg Vorbis encoding, drag the OggVorbis folder to another Konqueror window. The encoding starts as soon as you drop the Ogg Vorbis folder to its destination.
13.4 Hard Disk Recording with Audacity

With audacity (package audacity), record and edit audio files. This is called hard disk recording. When you start the program for the first time, select a language. At other times, change the language setting under ‘File’ ➝ ‘Preferences’ ➝ ‘Interface’. The language change is then effective the next time you start the program.

13.4.1 Recording WAV Files and Importing Files

Click the red recording button to create an empty stereo track and start the recording. To change the standard parameters, make the desired settings under ‘File’ ➝ ‘Preferences’. ‘Audio I/O’ and ‘Quality’ are important for the recording. Even if tracks already exist, pressing the recording button creates new tracks. Initially, this may be confusing, because these tracks cannot be seen in the standard-size program window.
To import audio files, select ‘Project’ → ‘Import Audio’. The program supports the WAV format and the compressed Ogg Vorbis format. See Section 13.3.3 on page 189 for more information about this format.

### 13.4.2 Editing Audio Files

Open the ‘AudioTrack’ menu to the left of the track. This menu offers various options for different views and basic editing operations. To rename the track, select ‘Name’ and enter a new name. The different view modes offered by Audacity include ‘Waveform’, ‘Waveform (dB)’, ‘Spectrum’, and ‘Pitch’. Choose the one suiting your needs. If you want to edit each channel of a stereo track separately, select ‘Split Track’. Each channel can then be treated as a separate track. Set ‘Sample Format’ (in bit) and ‘Sample Rate’ (in Hz) for each track.

Before you can use most of the tools offered in the ‘Edit’ menu, first select the channel and the segment of the track to edit. After making your selection, you can apply all kinds of modifications and effects to it.
Depending on the chosen file type, various view formats for segment selections are offered under ‘View’ → ‘Set Selection Format’. With ‘Set Snap-To Mode’, the segment boundaries can automatically be adapted to the selected view format. For example, if you select ‘PAL frames’ as the view format and activate ‘Snap-To’, the segment boundaries are always selected in multiples of frames.

All editing tools come with tool tips, so should be easy to use. The ‘Undo History’ function, accessed with ‘View’ → ‘History’, is a useful feature for viewing recent editing steps and undoing them by clicking in the list. Use ‘Discard’ with caution, because it deletes editing steps from the list. Once discarded, these steps can no longer be undone.

![The Spectrum](image)

**Figure 13.11: The Spectrum**

The built-in spectrum analyzer assists in quickly tracking down any noises. View the spectrum of the selected segment with ‘View’ → ‘Plot Spectrum’. Select a logarithmic frequency scale in octaves with ‘Log frequency’. If you move the mouse pointer within the spectrum, the frequencies of the peaks are automatically displayed together with the respective notes.

Remove unwanted frequencies with ‘Effect’ → ‘FFT Filter’. In connection with the filtering process, it may be necessary to readjust the signal amplitude with ‘Amplify’. Additionally, use ‘Amplify’ to check the amplitude. By default, the ‘New
Peak Amplitude’ is set to 0.0 dB. This value represents the highest possible amplitude in the selected audio format. ‘Amplification’ shows the value needed to amplify the selected segment to this peak amplitude. A negative value indicates overamplification.

13.4.3  Saving and Exporting

To save the entire project, select ‘File’ –> ‘Save Project’ or ‘Save Project As’. This generates an XML file with the extension .aup, which describes the project. The actual audio data is saved in a directory named after the project with _data appended.

The entire project or the currently selected segment can also be exported as a stereo WAV file. To export the project in Ogg Vorbis format, refer to the information in Section [13.3.3] on page [189].

13.5  Direct Recording and Playback of WAV Files

arecord and aplay from the alsa package provide a simple and flexible interface to the PCM devices. arecord and aplay can be used to record and play audio data in the WAV format and other formats. The command arecord -d 10 -f cd -t wav mysong.wav records a WAV file of 10 seconds in CD quality (16 bit, 44.1 kHz). List all options of arecord and aplay by running them with the --help option.

qaRecord (package kalsatools) is a simple recording program with a graphical interface and level display. Because this program uses an internal buffer of about 1 MB (configurable with --buffersize), it enables uninterrupted recordings even on slow hardware, especially if it is run with real-time priority. During the recording, the currently-used buffer size is displayed in the status line under ‘Buffer’ and the maximum buffer size required so far for this recording is displayed under ‘Peak’.

SUSE LINUX
Figure 13.12: QARecord—A Simple Hard Disk Recording Application
This chapter introduces some basic Linux video, radio, and webcam applications. Learn how to configure and use motv for watching analog TV, using a webcam, and browsing video text. Use xawtv4 for digital video broadcasts. Webcams can be run using gqcam. EPG information can be accessed using nxtvepg or xawtv4.
14.1 Watching TV with motv

motv is an improved successor to xawtv. It incorporates all essential functions into the user interface. Start the application with ‘Multimedia’ → ‘Video’ → ‘motv’. Start it at the command line with motv. Initially, only a TV window appears after the application starts. Open a menu window by right-clicking it.

Figure 14.1: The TV Application motv

14.1.1 Video Source and Network Search

In ‘Settings’ → ‘Input’, select the video source. If you select ‘Television’ here, set up the broadcasting network before starting the application. This automatically takes place with the network search, also found under the ‘Settings’ menu. If you click ‘Save settings’, the network found is entered into the .xawtv file in your home directory and will be available the next time you start the application.
Selecting Channels

If you do not want to browse for all available channels, find the next channel with \( \text{Ctrl} \uparrow \). If needed, subsequently adjust the broadcast frequency with \( \leftrightarrow \).

14.1.2 Retrieving Audio Data

The audio output of the TV card is connected to the line input of your sound card, to the speakers, or to an amplifier. Some TV cards can change the volume of the audio output. The volume can then be set with the sliders that appear after selecting ‘Settings’ → ‘Slider’. This window also provides the sliders for brightness, contrast, and color.

To use your sound card for audio playback, check the mixer settings using gamix, described in Section 13.1 on page 178. For sound cards meeting the AC97 specifications, set ‘Input-MUX’ to ‘Line’. The volume can then be adjusted with the ‘Master’ and ‘Line’ sliders.

14.1.3 Screen Proportions and Full-Screen Mode

Most television images have a height and width ratio of 4:3. These proportions can be set with ‘Tools’ → ‘Screen Dimensions’. If ‘4:3’ is selected here (this is the default setting), the screen dimensions are retained automatically, even when the display size is changed.

With \( F \) or ‘Tools’ → ‘Fullscreen’, switch to full-screen mode. If the TV image in full-screen mode is not scaled to the full monitor size, some fine-tuning is required. Many graphics cards can scale the full-screen mode television image to the full monitor size without changing the graphical mode. If your card does not support this function, the graphics mode must be switched to 640x480 for the full-screen mode. Create the related configuration in ‘Settings’ → ‘Configuration’. After restarting motv, the monitor mode is also changed if you have switched to full-screen mode.
Tip

Storing the Configuration in .xawtv

The .xawtv file is created automatically and updated by clicking ‘Settings’ → ‘Save settings’. Here, the broadcasters are saved along with the configuration. More information about the configuration file can be found in the man page for xawtvrc.

14.1.4 The Launcher Menu

Use the launcher menu to start other applications to use with motv. Start the audio mixer gamix and the video text application alevt, for example, using a keyboard shortcut. Applications to launch from motv must be entered in the .xawtv file. The entries should look like this:

[launch] Gamix = Ctrl+G, gamix AleVT = Ctrl+A, alevt

The shortcut then the command used to start the application should follow the application name itself. Start the applications entered under [launch] via the ‘Tool’ menu.

14.2 Video Text Support

Use alevt to browse video text pages. Start the application with ‘Multimedia’ → ‘Video’ → ‘alevt’ or at the command line with alevt.

The application saves all the pages of the selected station just activated with motv. Browse pages by entering the desired page number or by clicking a page number. Move forward or backward through the pages by clicking ‘<’ or ‘>’, located in the lower window margin.

Recent versions of motv and its successor xawtv4 include their own video text viewer applications: mtt (motv) and mtt4 (xawtv4). mtt4 even supports DVB cards.
14.3 Webcams and motv

If your webcam is already supported by Linux, access it with motv. Find a summary of the supported USB devices at http://www.linux-usb.org. If you have already used motv to access the TV card prior to accessing the webcam, the bttv driver is loaded. The webcam driver is loaded automatically when your webcam is connected to the USB. Start motv at the command line with the parameter \(-c /dev/video1\) to access the webcam. Access the TV card with \(\text{motv} -c /dev/video0\).

When connecting the webcam to the USB before the bttv driver has been automatically loaded (for example, by starting a TV application), \(/dev/video0\) is reserved for the webcam. In this case, if you start motv with the \(-c /dev/video1\) parameter to access the TV card, you might get an error message, because the bttv driver was not automatically loaded. Solve this problem by loading the driver separately with \(\text{modprobe bttv}\) as the user root. Access an overview of the configurable video devices on your system with \(\text{motv} -\text{hwscan}\).

14.4 nxtvepg—The TV Magazine for Your PC

From some broadcasters, an EPG signal (Electronic Program Guide) is transmitted along with the video text signal. Easily view this electronic guide using the program nxtvepg. To do this, however, you must have a TV card supported by the bttv driver and be able to receive one of the channels broadcast with an EPG.

With nxtvepg, the broadcasts are sorted according to channel and topic, such as ‘movie’ and ‘sport’, and filtered according to criteria, such as Live, Stereo, or Subtitle. Start the application with ‘Multimedia’ \(\rightarrow\) ‘Video’ \(\rightarrow\) ‘nxtvepg’ or at the command line with \(\text{nxtvepg}\).

14.4.1 Importing the EPG Database

To set up and update the program database via the EPG signal, set the tuner of your TV card to a station that broadcasts EPG. This can be done using a TV application, such as motv or nxtvepg. Only one application at a time can access the tuner.
If you set an EPG broadcaster in motv, nxtvepg immediately begins importing the current list of TV programs. The progress is displayed.

![Figure 14.2: The Electronic TV Magazine nxtvepg](image)

If you have not started a TV application, let nxtvepg search for EPG broadcasters. To do this, use ‘Configure’ → ‘Provider scan’. ‘Use .xatv’ is activated by default. This indicates that nxtvepg is accessing the broadcasters saved in this file.

**Tip**

**Troubleshooting**

If there are problems, check to see if the proper video source has been chosen under ‘TV card input’.

Select from the EPG providers found in ‘Configure’ → ‘Select Provider’. ‘Configure’ → ‘Merge Providers’ even creates flexible associations between the various provider databases.

**14.4.2 Sorting the Programs**

nxtvepg provides a convenient filter function for managing even the most extensive program offerings. Activate a network selection list with ‘Configure’ →
`Show networks`. The `Filter` menu offers plenty of filter functions. Right-click the program list to open a special filter menu in which to activate contextual filter functions.

Of particular interest is the `Navigate` menu. This is built directly from the EPG data. It appears in the language provided by the network.

### 14.5 Watching Digital Video Broadcasts with `xawtv4`

As your hardware has been properly configured with YaST, start `xawtv4` from the main menu (`Multimedia` ➔ `Video` ➔ `xawtv4`). Before you can actually start watching your favorite broadcasts, build a database of DVB stations.

![Figure 14.3: Running xawtv4](image)

Right-click the start window to open the control window (see Figure 14.3 on the current page). Start a scan for available DVB stations with `Edit` ➔ `Scan DVB`. A channel scanner and browser window open. Select a bouquet to prepare the scan.
This can be done manually with ‘Commands’ → ‘Tune manually’ if you already know the tuning parameters of the bouquet or by requesting them from a built-in database of xawtv4 via ‘Database’ → ‘_country_’ → ‘_channel number_’ (replace _country_ and _channel_number_ by the actual values for your location).

As soon as the scanner is tuned-in, the first data is displayed in the browser window. Launch a full scan of all available stations with ‘Command’ → ‘Full Scan’. While the scanner is running, you can select your favorite stations and add them to the station list by simply dragging them into the control window. Leave the channel scanner and select one of the channels to start watching the broadcast.

### Tip

**Editing the Station List**

Using keyboard shortcuts, control the channel selection using your keyboard. To set a shortcut for any station contained in your station list, select the station, click ‘Edit’ → ‘Edit Station’. A dialog called ‘TV Station Properties’ opens. Enter the shortcut and leave the dialog with ‘OK’. This dialog also allows you to define submenus holding groups of stations (such as ‘news’ or ‘private’).

The xawtv4 software package contains several more useful stand-alone multimedia applications:

- **pia4** A lean command-line–controlled movie player that can be used to play any movie streams recorded by xawtv4.

- **mtt4** A video text browser (see Figure 14.4 on the facing page).

- **alexplore** A stand-alone DVB channel scanner application. Its functionality is integrated into xawtv4.

- **dvbradio** A DVB radio player. Use it to listen to DVB-S radio streams after you have completed the initial station scan (see Figure 14.5 on page 206).

- **dvbrowse** An EPG browser application. Use it to get EPG information after you have completed the initial station scan.
14.6 Webcam Operation with gqcam

gqcam is a webcam application that assists in taking snapshots or automatic picture series with webcams. To use gqcam, your webcam must be supported by Video4Linux. Many USB webcams, like the Logitech Quickcam Express, are automatically recognized. Grayscale and color cameras can be used. TV cards that support Video4Linux can also be used as an image source. An overview of the supported USB devices is maintained at http://www.linux-usb.org. A graphical user interface is not compulsory because gqcam can also run from the command line.
14.6.1 Operation

Connect your camera to the USB port of your computer before starting gqcam. Then run gqcam. The current picture of your webcam is automatically shown in the upper part of the application window. The lower part has sliders for adjusting the brightness, white balance, contrast, tint, and color saturation as needed. The brightness is automatically preset. This feature can be set in ‘General’ in ‘File’ ➝ ‘Preferences’. ‘Filters’ features false color correction switches because some cameras swap the red and blue channels in transmission.

If you operate more than one webcam, use ‘File’ ➝ ‘Open New Camera’ to switch to another camera. Select the new device from the dialog that opens. The first camera is attached to the device /dev/video0, the second is attached to /dev/video1, and so on.

14.6.2 Snapshots

To take a snapshot with a camera, click ‘Snap Picture’. Select a filename and picture format in the dialog that opens. Create a picture series with ‘Camera’ ➝ ‘Set Timer’. Set the capturing frequency in seconds or minutes along with the properties of the images in ‘Set image information’. An optional script to run after every capture event can be chosen with ‘Run command after snap’. This could, for example, be used to upload the captured image onto an FTP server.

14.6.3 Command Line

gqcam can also be run without its graphical user interface. This may be interesting, for instance, for automatic surveillance controlled by a cron job. This requires
that all the necessary settings be passed to the application as parameters. Running `gqcam -t JPEG -s -d webcam.jpg` saves the current image captured by the camera with the filename `webcam.jpg`. The option `-t` defines the file format. Possible values are JPEG, PNG, and PPM. The command line switch `-s` activates the color correction. The filename for saving is passed with the option `-d`. If more than one webcam is operated, the name of the device must be passed. If no device is given, the default device `/dev/video0` is used. To capture an image from the second camera, the option `-v /dev/video1` must be added. List all options with `gqcam --help`. 
K3b—The KDE Burning Application

K3b is a comprehensive program for writing data and audio CDs and DVDs. Start the program from the main menu or by entering the command k3b. The following sections brief you on how to start a basic burning process to get your first Linux-made CD or DVD.

15.1 Creating a Data CD ................................................. 210
15.2 Creating an Audio CD .............................................. 212
15.3 Copying a CD ....................................................... 213
15.4 Writing ISO Images .................................................. 213
15.5 For More Information ............................................... 213
15.1 Creating a Data CD

To create a data CD, go to ‘File’ → ‘New Project’ → ‘New Data Project’. The project view appears in the lower part of the window, as shown in Figure 15.1 on this page. Drag the desired directories or individual files from your home directory to the project folder and drop them there. Save the project under a name of your choice with ‘File’ → ‘Save as’.

Figure 15.1: Creating a New Data CD

Then select ‘Burn’ from the toolbar. A dialog with five tabs offering various options for writing the CD opens. See Figure 15.2 on the next page.

The ‘Writing’ tab has various settings for the burning device, the speed, and the burning options. The detected writer is displayed under ‘Burning Device’ in the burning dialog. Set the burning speed in ‘Speed’. The following options are offered here:

‘Writing Mode’ This option determines how the laser writes a CD. In DAO (disk at once) mode, the laser is not deactivated while the CD is written. This mode is recommended for the creation of audio CDs. However, it is not supported by all CD writers. In the TAO mode (track at one), a separate
Figure 15.2: Customizing the Burning Process

The write process is used for each individual track. The RAW mode is not used very often, because the writer does not perform any data corrections. The best setting is ‘Auto’, because it allows K3b to use the most suitable settings.

‘Simulate’ This function can be used to check if your system supports the selected writing speed. The writing is performed with the laser deactivated to test the system.

‘On the fly’ Burns the desired data without first creating an image file (do not use this feature on low-performance machines). An image file—also known as an ISO image—is a file containing the entire CD content that is subsequently written to the CD exactly as it is.

‘Burnfree’ This option was formerly known as burn-proof. It helps to avoid buffer underruns of a CD writer. If burnfree is selected, the CD writer marks the current position and can return here in the event of a buffer underrun. However, this causes small data gaps that are audible in audio CDs.
It is preferable to select a suitable burning speed that avoids buffer under-
runs.

‘Only create image’ This option creates an image file. Set the path for this file
under ‘Temporary File’. The image file can be written to CD at a later time.
To do this, use ‘Tools’ → ‘CD’ → ‘Burn CD Image’. If this option is used, all
other options in this section are deactivated.

‘Remove image’ Remove the temporary image file from hard disk when fin-
ished.

‘Verify written data’ Check the integrity of the written data by comparing the
MD5 sums of the original and the burned data.

The ‘Settings’ tab features options needed for the creation of CDs with multiple
data or audio tracks (multisession CDs). In the ‘Volume Desc’ tab, enter some
general information that can be used to identify this particular data project, its
publisher and preparer, and the application and operating system used in the cre-
ation of this project. Under ‘File system’, specify settings for the file system on
the CD (RockRidge, Joliet, UDF). Also determine how symbolic links, file per-
missions, and blanks are treated. In the ‘Advanced’ tab, experienced users can
specify additional settings.

After adjusting all settings to your needs, start the actual burning process us-
ing ‘Burn’. Alternatively, save these settings for future use and adjustment with
‘Save’.

15.2 Creating an Audio CD

Basically, there are no significant differences between creating an audio CD and
creating a data CD. Select ‘File’ → ‘New Audio Project’. Drag and drop the indi-
vidual audio tracks to the project folder. The audio data must be in WAV or Ogg
Vorbis format. Determine the sequence of the tracks by moving them up or down
in the project folder.

The dialog for burning an audio CD is not very different from the dialog for
burning a data CD. However, the ‘Disc at once’ and the ‘Track at once’ modes
have greater importance. The ‘Track at once’ mode inserts an intermission of two
seconds after each track.
Tip

Preserving Data Integrity
When burning audio CDs, choose a lower burning speed to reduce the risk of burning errors.

15.3 Copying a CD

Select ‘Tools’ → ‘CD’ → ‘Copy CD’ or the copy CD button from the toolbar. In the dialog that opens, make the settings for the reading and writing device as shown in Figure 15.3 on the following page. The writing options discussed are also available here. An additional function enables the creation of several copies of the CD.

Check ‘On the fly’ to burn the CD as soon as it has been read or select ‘Only create image’ to create an image in the path specified in ‘Temp Directory’ → ‘Write image file to’ and burn the image later.

15.4 Writing ISO Images

If you already have an ISO image, go to ‘Tools’ → ‘CD’ → ‘Burn CD image’. A window opens in which to enter the location of the ‘Image to Burn’. K3b calculates a check sum and displays it in ‘MD5 Sum’. If the ISO file was downloaded from the Internet, this sum shows if the download was successful.

Use the ‘Options’ and ‘Advanced’ tabs to set your preferences. To burn the CD, click ‘Start’.

15.5 For More Information

Apart from the two main functions described above, K3b offers other functions, such as the creation of DVD copies, reading audio data in WAV format, rewriting CDs, and the integrated audio player. A detailed description of all available program features is available at http://k3b.sourceforge.net.
Figure 15.3: Copying a CD
Digital Cameras and Linux

Managing photos from your camera can be fun, if you have the right tools. Linux offers several handy utilities to sort and organize your photographs. This chapter covers the use of gphoto, gtkam, Konqueror, and Digikam.
A comprehensive list of supported cameras is available at http://www.gphoto.org/. If gphoto2 is installed, retrieve the list with the command gphoto2 --list-cameras. Get information about the available commands with gphoto2 --help.

**Tip**

**Unsupported Cameras**

If you do not find your camera in the list from gphoto, do not despair. It is likely that your camera is supported as a USB mass storage device. Find more information in Section 16.2 on the current page.

---

### 16.1 Connecting to the Camera

The fastest and most convenient way to connect digital cameras to the computer is USB, provided the kernel, the camera, and the computer support it. The standard SUSE kernel provides this support. A suitable cable is also required.

Simply connect the camera to the USB port and turn on the camera. You may need to switch your camera to a special data transfer mode. For this procedure, consult the manual of your digital camera.

---

### 16.2 Accessing the Camera

There are three possibilities for accessing the pictures on the camera. It depends on your camera and which protocol it supports. Usually it is USB mass storage, which is handled by the hotplug system, PTP (Picture Transfer Protocol), and some proprietary protocols by gphoto2.

The easiest way is if your camera supports USB mass storage. Read the documentation of your camera if you are unsure if this is possible. Some support two protocols, like both PTP and USB mass storage. Unfortunately, there are also some that communicate with a proprietary protocol, which can complicate the tasks. If your camera does not support USB mass storage or PTP, the following descriptions will not work. Try gphoto2 --list-cameras and the information at http://www.gphoto.org/.
If your camera can be switched to a USB mass storage device, select this option. After you connect it with the USB port of your computer and turn it on, it is detected by the hotplug system. This takes care of mounting the device automatically, so it is easily accessible. The KDE desktop shows a camera icon after a successful mount.

After the camera is successfully mounted, see a new directory under /media, beginning with usb and lots of numbers. Each vendor and product has a number, so when you connect a device on your computer it has always the same name. Depending on what you have connected to the USB bus, find different entries. The only problem left is to find the correct entry for your camera. Try to list one of these directories and see what happens. Each camera has a different tree structure, so there is no general rule. If you can see JPEG files in a directory, you probably found it.

After you find your correct directory, you can copy, move, or delete the files of your camera with a file manager like Konqueror or simple shell commands (see Section 19.3 on page 260 and the Administration Guide).

### 16.3 Installing the Programs

Use YaST to install the gtkam package. The other required packages are selected automatically. Digikam is included in the default installation. If it is not installed, use YaST to install it, if desired.

### 16.4 Using Konqueror

KDE users can easily access digital cameras by means of the familiar Konqueror interface. Connect your camera to the USB port. A camera icon should appear on the desktop. Click this icon to open the camera in Konqueror. The camera can also be accessed by entering the URL `camera:/` in Konqueror. Navigate through the camera’s directory structure until the files are shown. Use the usual Konqueror file management features to copy the files as desired. More information about using Konqueror is available in Chapter 10 on page 151.
16.5 Using gtKam

gtKam is a graphical interface for downloading and deleting pictures from a digital camera. To adjust or edit your pictures, use GIMP as described in Chapter 18 on page 235.

Connect your camera to the appropriate port and turn on the camera. Start gtKam with the command `gtkam &`. From the menu, select ‘Camera’ → ‘Select Camera’. In the dialog that opens, select the camera model or use ‘Detect’. Select the appropriate port if the detection fails.

The main gtKam window is divided into three sections—the menu and toolbars, the left pane with index settings and camera and directory selection, and the right pane for displaying an index listing with or without thumbnails. The icons in the toolbar provide the main functions needed. The disk icon saves the selected images. The trash icon deletes them. The icon with the arrows loads the image index displayed in the right pane. The icon with the paper and pencil opens the camera configuration options. The door icon exits the program.

Your camera should be listed in the left pane. Use the plus sign (+) to the left to expand the tree display of the directory structure. Your exact directory structure depends on the camera type and model. Continue expanding until you reach the entries that cannot be expanded. These are the index listings of the pictures. Click an item to select it. If ‘View Thumbnails’ is activated, the picture names and thumbnails are displayed in the right window pane. Otherwise, the names and an icon are displayed.

Images in the right pane can be selected or deselected by clicking them. Select all images with ‘Select’ → ‘All’ or (Shift)+(A). To save the selected images, use the disk icon in the toolbar, select ‘File’ → ‘Save Selected Photos’, or use the shortcut (Ctrl)+(S). The ‘Save’ dialog has a number of options. Under ‘What to Save’, select whether to save the thumbnails, the images, or both. With ‘Open image(s) with’, save the image and open it in another program. To open the images in GIMP immediately, enter `gimp`. Using the filenames suggested by the camera is recommended.

If you need more features, try gThumb. With this application, you can organize and sort your photographs.
16.6 Using Digikam

Digikam by Renchi Raju is a KDE program for downloading photographs from digital cameras. The first time it is run, Digikam asks where to store your photo album. If you enter a directory that already contains a collection of photographs, Digikam treats each subfolder of the folder as an Album.

On start-up, Digikam presents a window with two sections: your albums are displayed to the left and the respective photographs available are displayed to the right. See Figure 16.1 on the current page.

![Figure 16.1: The Main Window of Digikam](image)

16.6.1 Configuring Your Camera

To set up a camera in Digikam, select ‘Camera’ → ‘Add Camera’. First, try to autodetect the camera with ‘Auto-Detect’. If this fails, browse the list for your model with ‘Add’. If your camera model is not included in the list, try an older model or use ‘USB Mass Storage’ or ‘USB PTP Class Camera’. Normally, this should work. Confirm with ‘Ok’.
16.6.2 Downloading Pictures from Your Camera

After your camera has been configured correctly, connect to your camera with the ‘Camera’ menu and the name that you gave in the dialog from Section 16.6.1 on the preceding page. Digikam opens a window and begins to download thumbnails and displays them as in Figure 16.2 on the current page. Right-click an image to open a pop-up menu with the options to ‘View’, display some ‘Properties’ and ‘EXIF Information’, ‘Download’, or ‘Delete’ the image. With ‘Advanced ’, select renaming options and how the camera-provided information (EXIF) should be handled.

The renaming options can be very convenient if your camera does not use meaningful filenames. You can let Digikam rename your photographs automatically. Give a unique prefix, and optionally give a date, time, or sequence number. The rest is done by Digikam.

Select all photographs to download from the camera by pressing the left mouse button or clicking individual photographs with (Ctrl) pressed. Selected photographs appear with inverted colors. Click ‘Download’. Select the destination from the list or by creating a new album with ‘New Album’. This automatically suggests a filename with the current date. Confirm with ‘Ok’ to start the download process.

Figure 16.2: Downloading Pictures from Camera
16.6.3 Getting Information

Getting information about the photograph is not difficult. A short summary is displayed as a tool tip if you point with the mouse cursor at the thumbnail. For longer information, right-click the photograph and choose ‘Properties’ from the menu. A dialog box opens with three tabs, ‘General’, ‘EXIF’, and ‘Histogram’. ‘General’ lists the name, type, owner, and some other basic information. The more interesting part is the ‘EXIF’ tab. The camera stores some metadata for each photograph. Digikam reads these properties and displays them in this list. Find the exposure time, pixel dimensions, and others. To get more information for the selected list entry, press \((\text{Shift})-(\text{F1})\). This shows a small tool tip. The last tab, ‘Histogram’, shows some statistical information.

16.6.4 Managing Albums

Digikam inserts a ‘My Albums’ folder by default, which collects all your photographs. You can store these into subfolders later. The albums can be sorted by their directory layout, by the collection name that has been set in the album properties or by the date that the albums were first created (this date can also be changed in the properties of each album).

To create a new album, you have some possibilities:

- Uploading new photographs from the camera
- Creating a new album by clicking the ‘New Album’ button in the toolbar
- Importing an existing folder of photographs from your hard disk (select ‘Album’ \(\rightarrow\) ‘Import’ \(\rightarrow\) ‘Import Folders’)
- Right-clicking ‘My Albums’ and selecting ‘New Album’

After selecting to create and album in your preferred way, a dialog box appears. Give your album a title. Optionally, choose a collection, insert some comments, and select an album date. The collection is a way of organizing your albums by a common label. This label is used when you select ‘View’ \(\rightarrow\) ‘Sort Albums’ \(\rightarrow\) ‘By Collection’. The comment is shown in the banner at the top of the main window. The album date is used when you select ‘View’ \(\rightarrow\) ‘Albums’ \(\rightarrow\) ‘By Date’.

Digikam uses the first photograph in the album as the preview icon in the ‘My Albums’ list. To select a different one, right-click the respective photograph and select ‘Set as Album Thumbnail’ from the context menu.
16.6.5 Managing Tags

Managing lots of different photographs with different albums can sometimes be complex. To organize individual photographs, Digikam provides the ‘My Tag’ system.

For example, you have photographed your friend John at different times and you want to collect all images, independent of your album. This let you find all photographs very easily. First, create a new tag by clicking ‘My Tags’ ➝ ‘People’. From the context menu, choose ‘New Tag’. In the dialog box that appears, enter ‘John’ as title and optionally set an icon. Confirm with ‘Ok’.

After creating your tag, assign it to the desired pictures. Go to each album and select the respective photographs. Right-click and choose ‘Assign Tag’ ➝ ‘People’ ➝ ‘John’ from the menu that appears. Alternativly, drag the photographs to the tag name under ‘My Tags’ and drop them there. Repeat as necessary with other albums. View all the images by clicking ‘My Tags’ ➝ ‘People’ ➝ ‘John’. You can assign more than one tag to each photograph.

Editing tags and comments can be tedious. To simplify this task, right-click a photograph and select ‘Edit Comments & Tags’. This opens a dialog box with a preview, a comment field, and a tag list. Now you can insert all the needed tags and add a comment. With ‘Forward’ and ‘Back’, navigate in your album. Store your changes with ‘Apply’ and leave with ‘Ok’.

16.6.6 Useful Tools

Digikam provides several tools to simplify some tasks. Find them in the ‘Tools’ menu. The following is a small selection of the available tools.

Creating a Calendar

If you want to please someone, a custom calendar can be a nice gift. Go to ‘Tools’ ➝ ‘Create Calendar’, which opens a wizard dialog like that in Figure 16.3 on the facing page.

Customize the settings (paper size, image position, font, etc.) and confirm with ‘Next’. Now you can enter the year and select the images to use. After clicking ‘Next’ again, see a summary. The final ‘Next’ opens the KDE Printer dialog. Here, decide if you want to see a preview, save as PDF, or just print directly.
Finding Duplicate Photographs

Sometimes you photograph similar scenes repeatedly and want to keep only the best shots. This is the perfect task for the ‘Find Duplicate’ plug-in.

Go to ‘Tools’ → ‘Find Duplicate Images’, which opens a window similar to Figure 16.4 on the next page. Select the albums or tags to handle. Under ‘Method & Cache’, choose the search method: a more accurate or a faster method. After you confirm with ‘Ok’, Digikam proceeds with the investigation.

If it finds some duplicates, it shows the result in a window like Figure 16.5 on page 225. Decide which images to delete by activating the desired check boxes then clicking ‘Delete’. Leave the window with ‘Close’.

Figure 16.3: Creating a Template for a Calendar
Batch Processes

Digikam also provides some batch processes that perform a specific task on lots of files. This can be renaming, converting, resizing, and much more. Find them under ‘Tools’ → ‘Batch Processes’.

16.7 For More Information

For more information about using digital cameras with Linux, refer to the following Web sites:

- http://digikam.sourceforge.net/ Information about Digikam
- http://gphoto.sourceforge.net Information about gPhoto, gPhoto2, and gPhoto2-compatible GUIs
Figure 16.5: Results of Find

Kooka—A Scanning Application

Kooka is a KDE application for scanning. This chapter explains the user interface and the functionality of the application. In addition to creating image files from printed media, like photographs or magazines, Kooka has character recognition capabilities. This means it can help convert written text to a text file that can be edited.
Start Kooka from the main menu or enter the command `kooka`. When started, Kooka opens a three-frame window with a menu bar to the upper left and a toolbar directly below it. All windows can be freely readjusted or rearranged with the mouse. It is also possible to completely detach single frames from the Kooka window for deliberate placement on the desktop. To move the frames, click and drag the thin double line right above the frame. Any frame, except the main window, can be placed within any other frame aligned to the left, right, top, bottom, or center. Centered windows have the same size, are stacked, and can be brought to the foreground with tabs.

The ‘Image Viewer’ and the ‘Scan Preview’ frames share a window by default. Tabs allow switching between them. The left frame provides the gallery. This is a small file browser for accessing the scanned images. The frame to the lower right is shared by OCR (optical character recognition) and the thumbnails, which can be loaded into the image viewer with a simple click of the mouse. See Figure 17.1 on the current page.

![Figure 17.1: The Kooka Main Window](image)

---

228
17.1 The Preview

A preview should always be created when the object to scan is smaller than the total scanning area. Set a few parameters to the left of the preview frame. Select the scanning size with ‘Custom’ or one of the standard formats. See Figure 17.2 on this page. The ‘Custom’ setting is the most flexible, because it allows selection of the desired area with the mouse. Once the settings have been made, request the preview of the image to scan by clicking ‘Preview Scan’ in ‘Scan Parameters’.

Figure 17.2: The Kooka Preview Window

17.2 The Final Scan

If you selected ‘Custom’ for the scanning size, use the mouse to select the rectangular area to scan. The selected area is confined by a dotted border.
Choose between color and black-and-white scanning and set the resolution with the slider. See Figure [17.3] on the current page. The higher the resolution, the better the quality of the scanned image is. However, this also results in a correspondingly larger file and the scanning process can take a very long time at high resolutions. Activate ‘Use custom gamma table’ and click ‘Edit’ to change the settings for brightness, contrast, and gamma.

![The Kooka Scanning Parameters]

*Figure 17.3: The Kooka Scanning Parameters*

Once all settings have been made, click ‘Final Scan’ to scan the image. The scanned image is then displayed in the image viewer and as a thumbnail. When prompted, select the format in which to save the image. To save all the future images in that same format, check the corresponding box. Confirm with ‘OK’.
17.3  The Menus

Some of the functions of the toolbar are also available in the ‘File’ and ‘Image’ menus. Modify preference settings for Kooka in ‘Settings’.

**File**  Use this menu to start the KPrinter printing assistant, create a new folder for your images, and save, delete, and close files. The OCR results of a scanned text document can be saved here. Also use this menu to close Kooka.

**Image**  The ‘Image’ menu allows starting a graphics application for postprocessing or optical character recognition of an image. The recognized text from an OCR operation is displayed in its own frame. Various tools for scaling, rotating, and flipping an image are available. These functions can also be accessed from the toolbar. ‘Create From Selection’ allows saving an area of an image previously marked with the mouse.

**Settings**  ‘Settings’ adjusts of the look and feel of Kooka. The toolbar and status bar can be switched on and off and keyboard shortcuts for menu entries can be defined. ‘Configure Toolbars’ provides a list of all the functions available to the toolbar. ‘Configure Kooka’ opens a configuration dialog in which to modify the look and feel of Kooka. Normally, however, the defaults are sufficient. In ‘Tool Views’, enable and disable the thumbnail viewer, the preview, the gallery, the scanning parameters, and the OCR result window.

**Help**  The ‘Help’ menu provides access to the online help manual for Kooka. Also use it to access a feedback channel for problems and wishes. It also provides information about the version, authors, and license of Kooka and KDE.

17.4  The Gallery

The gallery window shows the default folder where Kooka stores all its image files. An example is shown in Figure 17.4 on the following page. To save an image to your personal home directory, click the thumbnail to select it then select ‘File’ → ‘Save Image’. Then enter your personal home directory and give the file a descriptive name.

To add images to the gallery, simply drag and drop them from Konqueror. Start Konqueror, navigate to the directory containing the images to add to the gallery, and drag them with the mouse to a folder of the Kooka gallery.
17.5 Optical Character Recognition

If the character recognition module is installed, documents can be scanned in ‘lineart’ mode, saved in the proposed format, then processed for text recognition from the ‘Image’ menu. Process the entire document or only a previously selected area. A configuration dialog tells the module whether the original text is in printed type, handwriting, or standardized type. Also set the language so the module can process the document correctly. See Figure 17.5 on the next page.

Switch to the ‘OCR Result Text’ window and check the text, which may need to be proofread. To do this, save the text with ‘File’ → ‘Save OCR Result Text’. The text can then be processed with OpenOffice.org or KWrite.
**Figure 17.5: OCR with Kooka**
The GIMP (The GNU Image Manipulation Program) is a program for creating and editing pixel graphics. In most aspects, its features are comparable to those of Adobe Photoshop and other commercial programs. Use it to resize and retouch photographs, design graphics for Web pages, make covers for your custom CDs, or almost any other graphics project. It meets the needs of both amateurs and professionals.
Like many other Linux programs, The GIMP is developed as a cooperative effort of developers worldwide who volunteer their time and code to the project. The program is under constant development, so the version included in your SUSE LINUX may vary slightly from the version discussed here. The layout of the individual windows and window sections is especially likely to vary.

The GIMP is an extremely complex program. Only a small range of features, tools, and menu items are discussed in this chapter. See Section 18.6 on page 241 for ideas of where to find more information about the program.

18.1 Graphics Formats

There are two main formats for graphics—pixel and vector. The GIMP works only with pixel graphics, which is the normal format for photographs and scanned images. Pixel graphics consist of small blocks of color that together create the entire image. The files can easily become quite large because of this. It is also not possible to increase the size of a pixel image without losing quality.

Unlike pixel graphics, vector graphics do not store information for all individual pixels. Instead, they store information about how image points, lines, or areas are grouped together. Vector images can also be scaled very easily. The drawing application of OpenOffice.org, for example, uses this format.

18.2 Starting GIMP

Start GIMP from the main menu. Alternatively, enter `gimp` & in a command line.

18.2.1 Initial Configuration

When starting GIMP for the first time, a configuration wizard opens for preparatory configuration. The default settings are acceptable for most purposes. Press ‘Continue’ in each dialog unless you are familiar with the settings and prefer another setup.
18.2.2 The Default Windows

Three windows appear by default. They can be arranged on the screen and, except the toolbox, closed if no longer needed. Closing the toolbox closes the application. In the default configuration, GIMP saves your window layout when you exit. Dialogs left open reappear when you next start the program.

The Toolbox

The main window of GIMP, shown in Figure 18.1 on the current page, contains the main controls of the application. Closing it exits the application. At the very top, the menu bar offers access to file functions, extensions, and help. Below that, find icons for the various tools. Hover the mouse over an icon to display information about it.

Figure 18.1: The Main Window
The current foreground and background color are shown in two overlapping boxes. The default colors are black for the foreground and white for the background. Click the box to open a color selection dialog. Swap the foreground and background color with the bent arrow symbol to the upper right of the boxes. Use the black and white symbol to the lower left to reset the colors to the default.

To the right, the current brush, pattern, and gradient are shown. Click the displayed one to access the selection dialog. The lower portion of the window allows configuration of various options for the current tool.

**Layers, Channels, Paths, Undo**

In the first section, use the drop-down box to select the image to which the tabs refer. By clicking ‘Auto’, control whether the active image is chosen automatically. By default, ‘Auto’ is enabled.

‘Layers’ shows the different layers in the current images and can be used to manipulate the layers. ‘Channels’ shows and can manipulate the color channels of the image.

Paths are an advanced method of selecting parts of an image. They can also be used for drawing. ‘Paths’ shows the paths available for an image and provides access to path functions. ‘Undo’ shows a limited history of modifications made to the current image.

The bottom portion of the window contains three tabs. With them, select the current brush, gradient, and pattern.

**18.3 Getting Started in GIMP**

Although GIMP can be a bit overwhelming for new users, most quickly find it easy to use once they work out a few basics. Crucial basic functions are creating, opening, and saving images.

**18.3.1 Creating a New Image**

To create a new image, select ‘File’ → ‘New’ or press (Ctrl+Shift+N). This opens a dialog in which to make settings for the new image. If desired, use ‘Template’ to select a template on which to base the new image. The GIMP includes a number of templates, ranging from an A4 sheet of paper to a CD cover, from which to choose.
Manipulating Graphics with The GIMP

To create a custom template, select ‘File’ → ‘Dialogs’ → ‘Templates’ and use the controls offered by the window that opens.

In the ‘Image Size’ section, set the size of the image to create in pixels or another unit. Click the unit to select another unit from the list of available units. The ratio between pixels and a unit is set in ‘Resolution’, which appears when the ‘Advanced Options’ section is open. A resolution of 72 pixels per inch corresponds to screen display. It is sufficient for Web page graphics. A higher resolution should be used for images to print. For most printers, a resolution of 300 pixels per inch results in an acceptable quality.

In ‘Colorspace’, select whether the image should be in color (‘RGB’) or ‘Grayscale’. Select the ‘Fill Type’ for the new image. ‘Foreground Color’ and ‘Background Color’ use the colors selected in the toolbox. ‘White’ uses a white background in the image. ‘Transparent’ creates a clear image. ‘Transparency’ is represented by a gray checkerboard pattern. Enter a comment for the new image in ‘Comment’.

When the settings meet your needs, press ‘OK’. To restore the default settings, press ‘Reset’. Pressing ‘Cancel’ aborts creation of a new image.

18.3.2 Opening an Existing Image

To open an existing image, select ‘File’ → ‘Open’ or press `Ctrl-O`. In the dialog that opens, select the desired file. Click ‘OK’ to open the selected image. Press ‘Cancel’ to skip opening an image.

18.3.3 The Image Window

The new or opened image appears in its own window. The menu bar in the top of the window provides access to all image functions. Alternatively, access the menu by right-clicking the image or clicking the small arrow button in the left corner of the rulers.

‘File’ offers the standard file options, such as ‘Save’ and ‘Print’. ‘Close’ closes the current image. ‘Quit’ closes the entire application.

With the items in the ‘View’ menu, control the display of the image and the image window. ‘New View’ opens a second display window of the current image. Changes made in one view are reflected in all other views of that image. Alternate views are useful for magnifying a part of an image for manipulation while seeing the complete image in another view. Adjust the magnification level of the
current window with ‘Zoom’. When ‘Shrink Wrap’ is selected, the image window is resized to fit the current image display exactly.

18.4 Saving Images

No image function is as important as ‘File’ ➔ ‘Save’. It is better to save too often than too rarely. Use ‘File’ ➔ ‘Save as’ to save the image with a new filename. It is a good idea to save image stages under different names or make backups in another directory so you can easily restore a previous state.

When saving for the first time or using ‘Save as’, a dialog opens in which to specify the filename and type. Enter the filename in the field at the top. For ‘Save in folder’, select the directory in which to save the file from a list of commonly used directories. To use a different directory or create a new one, open ‘Browse for other folders’. It is recommended to leave ‘Select File Type’ set to ‘By Extension’. With that setting, GIMP determines the file type based on the extension appended to the filename. The following file types are frequently useful:

**XCF** This is the native format of the application. It saves all layer and path information along with the image itself. Even if you need an image in another format, it is usually a good idea to save a copy as XCF to simplify future modifications.

**PAT** This is the format used for GIMP patterns. Saving an image in this format enables using the image as a fill pattern in GIMP.

**JPG** JPG or JPEG is a common format for photographs and Web page graphics without transparency. Its compression method enables reduction of file sizes, but information is lost when compressing. It may be a good idea to use the preview option when adjusting the compression level. Levels of 85% to 75% often result in an acceptable image quality with reasonable compression. Saving a backup in a lossless format, like XCF, is also recommended. If editing an image, save only the finished image as JPG. Repeatedly loading a JPG then saving can quickly result in poor image quality.

**GIF** Although very popular in the past for graphics with transparency, GIF is less often used now because of license issues. GIF is also used for animated images. The format can only save indexed images. The file size can often be quite small if only a few colors are used.
PNG With its support for transparency, lossless compression, free availability, and increasing browser support, PNG is replacing GIF as the preferred format for Web graphics with transparency. An added advantage is that PNG offers partial transparency, which is not offered by GIF. This enables smoother transitions from colored areas to transparent areas (antialiasing).

To save the image in the chosen format, press ‘Save’. To abort, press ‘Cancel’. If the image has features that cannot be saved in the chosen format, a dialog appears with choices for resolving the situation. Choosing ‘Export’, if offered, normally gives the desired results. A window then opens with the options of the format. Reasonable default values are provided.

18.5 Printing Images

To print an image, select ‘File’ → ‘Print’ from the image menu. If your printer is configured in SUSE, it should appear in the list. In some cases, it may be necessary to select an appropriate driver with ‘Setup Printer’. Select the appropriate paper size with ‘Media Size’ and the type in ‘Media Type’. Other settings are available in the ‘Image / Output Settings’ tab.

In the bottom portion of the window, adjust the image size. Press ‘Use Original Image Size’ to take these settings from the image itself. This is recommended if you set an appropriate print size and resolution in the image. Adjust the image’s position on the page with the fields in ‘Position’ or by dragging the image in ‘Preview’.

When satisfied with the settings, press ‘Print’. To save the settings for future use, instead use ‘Print and Save Settings’. ‘Cancel’ aborts printing.

18.6 For More Information

The following are some resources that may be useful for a GIMP user. Unfortunately, many resources apply to older versions.

- ‘Help’ provides access to the internal help system. This documentation is also available in HTML and PDF formats at http://docs.gimp.org.
Figure 18.2: The Print Dialog

- http://www.gimp.org is the official home page of The GIMP.

- Grokking the GIMP by Carey Bunks is an excellent book based on an older GIMP version. Although some aspects of the program have changed, it can provide excellent guidance for image manipulation. An online version is available at http://gimp-savvy.com/BOOK/.

- http://gimp-print.sourceforge.net is the Web page for the GIMP print plug-in. The user manual available from the site provides detailed information about configuring and using the program.
Part V

Excursions
Graphical user interfaces are increasingly becoming important for Linux, but using the mouse is not always the best way to perform daily tasks. The command line provides high flexibility and efficiency. The first part of this chapter provides an introduction to the Bash shell. It is followed by an explanation of the user permission concept in Linux and a list of the most important commands. The chapter closes with a description of the vi text editor.
Text-based applications are especially important for controlling older Linux computers that do not have the resources for demanding display systems. Virtual consoles are used in this case. Six of them are available in text mode. Press (Alt)-F1 through (Alt)-F6. The seventh console is reserved for X.

19.1 Introduction to Bash

In the KDE taskbar, there is an icon depicting a monitor with a seashell. When you click this icon, a console window opens in which to enter commands. The console normally runs Bash (Bourne again shell), a program developed as part of the GNU project. Once you have opened the shell, see the prompt on the first line. The prompt usually consists of the username, hostname, and current path, but it can be customized. When the cursor is after this prompt, you can send commands directly to your computer system.

19.1.1 Commands

A command consists of several elements. The first element is always the actual command, followed by parameters or options. Commands are executed when you press Enter. Before doing so, easily edit the command line, add options, or correct typing errors. One of the most frequently used commands is ls, which can be used with or without arguments. Entering the plain ls command in the console shows the contents of the current directory.

Options are prefixed with a hyphen. The command ls -l, for instance, shows the contents of the same directory in full detail. Next to each filename, see the date when the file was created, the file size in bytes, and further details, which are covered later. One very important option that exists for many commands is --help. By entering ls --help, display all the options for the ls command.

Also use the ls command to view the contents of other directories. To do so, the directory must be specified as a parameter. For example, to see the contents of Desktop, enter ls -l Desktop.

19.1.2 Files and Directories

To use the shell efficiently, it is really useful to have some knowledge of the file and directory structures of a Linux system. You can think of directories as electronic folders in which files, programs, and subdirectories are stored. The top
level directory in the hierarchy is the root directory, referred to as / . This is the place from which all other directories can be accessed.

The /home directory contains the directories in which the individual users can store their personal files. Figure 19.1 on this page shows the standard directory tree in Linux, with the home directories of the example users xyz, linux, and tux. The directory tree of a Linux system has a functional structure that follows the Filesystem Hierarchy Standard. The following list provides a brief description of the standard directories in Linux.

```
/home (private) directories of users
/dev  device files that represent hardware components
/etc  important files for system configuration
/etc/init.d  boot scripts
/usr/bin  generally accessible programs
```

**Figure 19.1:** Excerpt from a Standard Directory Tree
/bin programs needed early in the boot process
/usr/sbin programs reserved for the system administrator
/sbin programs reserved for the system administrator and needed for booting
/usr/include header files for the C compiler
/usr/include/g++ header files for the C++ compiler
/usr/share/doc various documentation files
/usr/share/man system manual pages (man pages)
/usr/src source code of system software
/usr/src/linux kernel source code
/tmp, /var/tmp temporary files
/usr all application programs
/var configuration files (such as those linked from /usr)
/var/log system log files
/var/adm system administration data
/lib shared libraries (for dynamically linked programs)
/proc process file system
/sys “system” file system where all device information for the kernel is gathered
/usr/local local, distribution-independent extensions
/opt optional software, larger add-on program packages (such as KDE, GNOME, Netscape)
19.1.3 Bash Functions

There are two important functions of the shell that can make your work a lot easier:

**History**  To repeat a command that has been entered before, press ↑ until the previous command appears at the prompt. Move forward through the list of previously entered commands by pressing ↓. To edit the command line, just move the cursor to the desired position using the arrow keys and start typing. Use Ctrl-R to search in the history.

**Expansion**  Expand a filename to its full length after typing its first letters until it can be uniquely identified. To do so, type the first letters then hit Tab. If there are several filenames starting with the same letters, obtain a list of them by hitting Tab twice.

**First Example: Managing Files**

Now that you know what a command looks like, which directories exist in SUSE LINUX, and how to speed up things when using Bash, put this knowledge into practice with a small exercise.

1. Open a console from the KDE desktop by clicking the shell icon.
2. Enter the `ls` command to see the contents of your home directory.
3. Use the command `mkdir` (which stands for *make directory*) to create a new subdirectory called `test` by entering `mkdir test`.
4. Now launch the Kate editor by pressing Alt-F2 and entering `kate` in the input field. Type a few letters in the editor then save the file as `Testfile` in your home directory. Linux distinguishes between uppercase and lowercase. For this example, use an uppercase T.
5. View the contents of your home directory again. Instead of typing `ls` again, just press ↑ twice and the `ls` command should reappear at the prompt. To execute the command, hit Enter. The newly created directory `test` should appear in blue letters and `Testfile` in black. This is how directories and files can be distinguished in a console.
6. Move Testfile into the subdirectory test with the command `mv`. To speed this up, use the expansion function: just enter `mv T` and press \( \text{Tab} \). As long as there is no other file beginning with this letter in the directory, the shell expands the filename and adds the string `estfile`. Otherwise, add a letter or two yourself and test \( \text{Tab} \) each time to see whether the shell can now expand the name. Finally, type a space then \texttt{test} after the expanded filename and press \( \text{Enter} \) to execute the command.

7. At this point, Testfile should no longer be in the directory. Check this by entering \texttt{ls} again.

8. To see whether the file has been successfully moved, change into the directory test with the command `cd test`. Now enter \texttt{ls} again. You should see Testfile in the listing. Change back to your home directory at any point by entering only \texttt{cd}.

9. To make a copy of a file, use \texttt{cp}. For instance, enter \texttt{cp Testfile Testbackup} to copy Testfile to Testbackup. Once again, the command \texttt{ls} can be used to see whether both files are in the directory.

### 19.1.4 Specifying Paths

When working with files or directories, it is important specify the correct path. However, you do not need to enter the entire (absolute) path from the root directory to the respective file. You can start from the current directory. Address your home directory directly with \( \sim \). This means that there are two ways to list the file Testfile in the directory test: by entering the relative path with \texttt{ls test} or by specifying the absolute path with \texttt{ls ~/test}.

To list the contents of home directories of other users, enter \texttt{ls \~username}. In the above-mentioned directory tree, one of the sample users is \texttt{tux}. In this case, \texttt{ls \~tux} would list the contents of the home directory of \texttt{tux}.

Refer to the current directory with a dot. The next higher level in the tree is represented by two dots. By entering \texttt{ls ..}, see the contents of the parent directory of the current directory. The command \texttt{ls ../..} shows the contents of the directory two levels higher in the hierarchy.

**Second Example: Working with Paths**

Here is another example to illustrate how to move around in the directories of your SUSE LINUX system.
1. Change into your home directory with the command `cd`. Then create a directory in it with the name `test2` by entering `mkdir test2`.

2. Change into the new directory with `cd test2` and create a subdirectory in it with the name `subdirectory`. To change into it, use the expansion function: enter `cd su` then press (Tab). The shell expands the rest of the directory name.

3. Now try to move the previously created file `Testbackup` into the current directory (`subdirectory`) without changing the directory again. To achieve this, specify the relative path to that file: `mv ../../test/Testbackup .`. The dot at the end of this command is required to tell the shell that the current directory is the destination to which to move the file. `../../`, in this example, refers to your home directory.

### 19.1.5 Wild Cards

Another convenience offered by the shell is wild cards. There are four different types of these in Bash:

- `?` Matches exactly one arbitrary character
- `*` Matches any number of characters
- `[set]` Matches one of the characters from the group specified inside the square brackets, which is represented here by the string `set`
- `![set]` Matches one character other than those identified by `set`

Assuming that your `test` directory contains the files `Testfile`, `Testfile1`, `Testfile2`, and `datafile`, the command `ls Testfile?` lists the files `Testfile1` and `Testfile2`. With `ls Test*`, the list also includes `Testfile`. `ls *fil*` shows all the sample files. Finally, you can use the `set` wild card to address all sample files whose last character is a number: `ls Testfile[1-9]`.

Of the four types of wild cards, the most inclusive one is the asterisk. It could be used to copy all files contained in one directory to another one or to delete all files with one command. The command `rm *fil*`, for instance, would delete all files in the current directory whose name includes the string `fil`. 
19.1.6 Less and More

Linux includes two small programs for viewing text files directly in the shell. Rather than starting an editor to read a file like Readme.txt, simply enter `less Readme.txt` to display the text in the console window. Use `Space` to scroll down one page. Use `Page Up` and `Page Down` to move forward or backward in the text. To exit less, press `Q`.

Instead of less, you can also use the older program more. However, it is less convenient because it does not allow you to scroll backwards.

The program less got its name from the the precept that less is more and can also be used to view the output of commands in a convenient way. To see how this works, read Section 19.1.7 on the current page.

19.1.7 Pipes

Normally, the standard output in the shell is your screen or the console window and the standard input is the keyboard. To forward the output of a command to an application like less, use a pipeline.

To view the files in the `test` directory, enter the command `ls test | less`. The contents of the `test` directory are then displayed with less. This only makes sense if the normal output with `ls` would be too lengthy. For instance, if you view the contents of the `dev` directory with `ls /dev`, you only see a small portion in the window. View the entire list with `ls /dev | less`.

It is also possible to save the output of commands to a file. For example, `ls test > Content` generates a new file called `Content` that contains a list of the files and directories in `test`. View the file with `less Content`.

You can also use a file as the input for a command. For example, sort the text lines in `Testfile` with `sort < Testfile`. The output of the command `sort` is sent to the screen. The text is sorted by the first letters of the individual lines.

If you need a new file containing the sorted list, pipe the output of the command `sort` to a file. To test this, create an unsorted name list in an editor and save it under `list` in the `test` directory. Then change into `test` and enter the command `sort < unsortedlist > sortedlist`. Finally, view the sorted list with `less`.

Just like the standard output, the standard error output is sent to the console as well. However, to redirect the standard error output to a file named `errors`, append `2> errors` to the corresponding command. Both standard output
and standard error are saved to one file named alloutput if you append `&> alloutput`. Finally, to append the output of a command to an already existing file, the command must be followed by `>>` instead of a single `>.

**19.1.8 Archives and Data Compression**

Now that you have already created a number of files and directories, consider the subject of archives and data compression. Suppose you want to have the entire `test` directory packed in one file that you can save on a floppy disk as a backup copy or send by e-mail. To do so, use the command `tar` (for *tape archiver*). With `tar --help`, view all the options for the `tar` command. The most important of these options are explained here:

- `-c` (for create) Create a new archive.
- `-t` (for table) Display the contents of an archive.
- `-x` (for extract) Unpack the archive.
- `-v` (for verbose) Show all files on screen while creating the archive.
- `-f` (for file) Choose a filename for the archive file. When creating an archive, this option must always be given as the last one.

To pack the `test` directory with all its files and subdirectories into an archive named `testarchive.tar`, use the options `-c` and `-f`. For testing purposes, also add `-v` to follow the progress of the archiving, although this option is not mandatory. After using `cd` to change to your home directory where the `test` directory is located, enter `tar -cvf testarchive.tar test`. After that, view the contents of the archive file with `tar -tf testarchive.tar`. The test directory with all its files and directories has remained unchanged on your hard disk. To unpack the archive, enter `tar -xvf testarchive.tar`, but do not try this yet.

For file compression, the obvious choice on Linux is the popular gzip program. Just enter `gzip testarchive.tar`. With `ls`, now see that the file `testarchive.tar` is no longer there and that the file `testarchive.tar.gz` has been created instead. This file is much smaller and therefore much better suited for transfer via e-mail or storage on a floppy.

Now, unpack this file in the `test2` directory created earlier. To do so, enter `cp testarchive.tar.gz test2` to copy the file to that directory.
Change to the directory with `cd test2`. A compressed archive with the `.tar.gz` extension can be unzipped with the `gunzip` command. Enter `gunzip testarchive.tar.gz`, which results in the file `testarchive.tar`, which then needs to be extracted or *untarred* with `tar -xvf testarchive.tar`. You can also unzip and extract a compressed archive in one step by adding the `-z` option. The complete command would be `tar -xzvf testarchive.tar.gz`. With `ls`, you can see that a new `test` directory has been created with the same contents as your `test` directory in your home directory.

### 19.1.9 mtools

*mtools* are a set of commands for working with MS-DOS file systems. The commands included in *mtools* allow you to address the first floppy drive as `a:`, just like under MS-DOS, and the commands are like MS-DOS commands except they are prefixed with an *m*:

- `mdir a:` displays the contents of the floppy disk in drive `a:`
- `mcopy Testfile a:` copies the file `Testfile` to the floppy disk
- `mdel a:Testfile` deletes `Testfile` in `a:`
- `mformat a:` formats the floppy disk in MS-DOS format (using the `fdformat` command)
- `mcd a:` makes `a:` your current directory
- `mmd a:test` creates the subdirectory `test` on the floppy disk
- `mrda test` deletes the subdirectory `test` from the floppy disk

### 19.1.10 Cleaning Up

After this crash course, you should be familiar with the basics of the Linux shell or command line. You may want to clean up your home directory by deleting the various test files and directories using the `rm` and `rmdir` commands. At the end of this chapter, find a list of the most important commands and a brief description of their functions.
19.2 Users and Access Permissions

Since its inception in the early 1990s, Linux has been developed as a multiuser system. Any number of users can work on it simultaneously. Users need to log in to the system before starting a session at their workstations. Each user has a username with a corresponding password. This differentiation of users guarantees that unauthorized users cannot see files for which they do not have permission. Larger changes to the system, such as installing new programs, are also usually impossible or restricted for normal users. Only the root user, or super user, has the unrestricted capacity to make changes to the system and has unlimited access to all files. Those who use this concept wisely, only logging in with full root access when necessary, can cut back the risk of unintentional loss of data. Because under normal circumstances only root can delete system files or format hard disks, the threat from the Trojan horse effect or from accidentally entering destructive commands can be significantly reduced.

19.2.1 File System Permissions

Basically, every file in a Linux file system belongs to a user and a group. Both of these proprietary groups and all others can be authorized to write, read, or execute these files.

A group, in this case, can be defined as a set of connected users with certain collective rights. For example, call a group working on a certain project project3. Every user in a Linux system is a member of at least one proprietary group, normally users. There can be as many groups in a system as needed, but only root is able to add groups. Every user can find out, with the command groups, of which groups he is a member.

File Access The organization of permissions in the file system differs for files and directories. File permission information can be displayed with the command ls -l. The output could appear as in Example 19.1 on this page.

Example 19.1: Sample Output Showing File Permissions

```
-rw-r----- 1 tux project3 14197 Jun 21 15:03 Roadmap
```

As shown in the third column, this file belongs to user tux. It is assigned to the group project3. To discover the user permissions of the Roadmap file, the first column must be examined more closely.
This column is comprised of one leading character followed by nine characters grouped in threes. The first of the ten letters stands for the type of file system component. The hyphen (−) shows that this is a file. A directory (d), a link (l), a block device (b), or a character device could also be indicated.

The next three blocks follow a standard pattern. The first three characters refer to whether the file is readable (r) or not (−). A w in the middle portion symbolizes that the corresponding object can be edited and a hyphen (−) means it is not possible to write to the file. An x in the third position denotes that the object can be executed. Because the file in this example is a text file and not one that is executable, executable access for this particular file is not needed.

In this example, tux has, as owner of the file Roadmap, read (r) and write access (w) to it, but cannot execute it (x). The members of the group project3 can read the file, but they cannot modify it or execute it. Other users do not have any access to this file. Other permissions can be assigned by means of ACLs (access control lists). See Section 19.2.6 on page 259 for details and refer to the chapter in the Administration Guide for further background information.

**Directory Permissions** Access permissions for directories have the type d. For directories, the individual permissions have a slightly different meaning.

**Example 19.2:** Sample Output Showing Directory Permissions

drwxrwxr-x 1 tux project3 35 Jun 21 15:15 ProjectData

In Example 19.2 on this page, the owner (tux) and the owning group (project3) of the directory ProjectData are easy to recognize. In contrast to the file access permissions from on the page before, the set reading permission (r) means that the contents of the directory can be shown. The write permission (w) means new files can be created. The executable permission (x) means the user can change to this directory. In the above example, this means the user tux as well as the members of the group project3 can
change to the ProjectData directory (x), view the contents (r), and add or delete files (w). The rest of the users, on the other hand, are given less access. They may enter the directory (x) and browse through it (r), but not insert any new files (w).

### 19.2.2 Modifying File Permissions

#### Changing Access Permissions

The access permissions of a file or directory can be changed by the owner and, of course, by root with the command `chmod` followed by the parameters changing the permissions and one or more filenames. The parameters form different categories:

1. **users concerned**
   - u (user)—owner of the file
   - g (group)—group that owns the file
   - o (others)—additional users (if no parameter is given, the changes apply to all categories)

2. **a character for deletion (−), setting (=), or insertion (+)**

3. **the abbreviations**
   - r—read
   - w—write
   - x—execute

4. **filename or filenames separated by spaces**

If, for example, the user **tux** in Example 19.2 on the facing page also wants to grant other users write (w) access to the directory ProjectData, he can do this using the command `chmod o+w ProjectData`.

If, however, he wants to deny all users other than himself write permissions, he can do this by entering the command `chmod go-w ProjectData`. To prohibit all users from adding a new file to the folder ProjectData, enter `chmod -w ProjectData`. Now, not even the owner can write to the file without first reestablishing write permissions.

#### Changing Ownership Permissions

Other important commands to control the ownership and permissions of the file system components are `chown` (change owner) and `chgrp` (change group). The command `chown` can be used to transfer ownership of a file to another user. However, only root is permitted to perform this change.
Suppose the file Roadmap from Example 19.2 on page 256 should no longer belong to tux, but to the user geeko. root should then enter chown geeko Roadmap.

chgrp changes the group ownership of the file. However, the owner of the file must be a member of the new group. In this way, the user tux from Example 19.1 on page 255 can switch the group owning the file ProjectData to project4 with the command chgrp project4 ProjectData, as long as he is a member of this new group.

19.2.3 The setuid Bit

In certain situations, the access permissions may be too restrictive. Therefore, Linux has additional settings that enable the temporary change of the current user and group identity for a specific action. For example, the passwd program normally requires root permissions to access /etc/passwd. This file contains some important information, like the home directories of users and user and group IDs. Thus, a normal user would not be able to change passwd, because it would be too dangerous to grant all users direct access to this file. A possible solution to this problem is the setuid mechanism. setuid (set user ID) is a special file attribute that instructs the system to execute programs marked accordingly under a specific user ID. Consider the passwd command:

```
-rwsr-xr-x 1 root shadow 80036 2004-10-02 11:08 /usr/bin/passwd
```

You can see the s bit set for the user permission. By means of the setuid bit, all users starting the passwd command execute it as root.

19.2.4 The setgid Bit

The setuid attribute applies to users. However, there is also an equivalent property for groups: the setgid attribute. A program for which this attribute was set runs under the group ID under which it was saved, no matter which user starts it. Therefore, in a directory with the setgid bit, all newly created files and subdirectories are assigned to the group to which the directory belongs. Consider the following example directory:

```
drwxrws--- 2 tux archive 48 Nov 19 17:12 backup
```

19.2. Users and Access Permissions
You can see the s bit set for the group permission. The owner of the directory and members of the group archive may access this directory. Users that are not members of this group are “mapped” to the respective group. The effective group ID of all written files will be archive. For example, a backup program that runs with the group ID archive is able to access this directory even without root privileges.

19.2.5 The Sticky Bit

There is also the sticky bit. It makes a difference whether it belongs to an executable program or a directory. If it belongs to a program, a file marked in this way is loaded to RAM to avoid needing to get it from the hard disk each time it is used. This attribute is used rarely, because modern hard disks are fast enough. If this attribute is assigned to a directory, it prevents users from deleting each other’s files. Typical examples include the /tmp and /var/tmp directories:

```
  drwxrwxrwt 2 root root 1160 2002-11-19 17:15 /tmp
```

19.2.6 Access Control Lists

The traditional permission concept for Linux file system objects, such as files or directories, can be expanded by means of ACLs (access control lists). They allow the assignment of permissions to individual users or groups other than the original owner or owning group of a file system object.

Files or directories bearing extended access permissions can be detected with a simple ls -l command:

```
-rw-r--r--+ 1 tux project3 14197 Jun 21 15:03 Roadmap
```

The output of ls does not reveal much of a change compared to an ls on a file without an ACL. Roadmap is owned by tux who belongs to the group project3. tux holds both write and read access to this file and his group as well as all other users have read access. The only difference that distinguishes this file from a file without an ACL is the additional + in the first column holding the permission bits.

Get details about the ACL by executing getfacl Roadmap:
The first three lines of the output do not hold any information not available with `ls -l`. These lines only state filename, owner, and owning group. Lines 4 to 9 hold the ACL entries. Conventional access permissions represent a subset of those possible when using ACLs. The example ACL grants read and write access to the owner of the file as well as to user `jane` (lines 4 and 5). The conventional concept has been expanded allowing access to an extra user. The same applies to the handling of group access. The owning group holds read permissions (line 6) and the group `djungle` holds read and write permissions. The `mask` entry in line 8 reduces the effective permissions for the user `jane` and the group `djungle` to read access. Other users and groups do not get any kind of access to the file (line 9).

Only very basic information has been provided here. Find more detailed information about ACLs in the *Administration Guide*.

### 19.3 Important Linux Commands

This section gives insight into the most important commands of your SUSE LINUX system. Along with the individual commands, parameters are listed and, where appropriate, a typical sample application is introduced. To learn more about the various commands, use the manual pages, accessed with `man` followed by the name of the command, for example, `man ls`.

In the man pages, move up and down with `PgUp` and `PgDn`. Move between the beginning and the end of a document with `Home` and `End`. End this viewing mode by pressing `Q`. Learn more about the `man` command itself with `man man`.

There are many more commands than listed in this chapter. For information about other commands or more detailed information, the O'Reilly publication *Linux in a Nutshell* is recommended. In the following overview, the individual command elements are written in different typefaces.
The actual command and its mandatory options are always printed as `command option`. Specifications or parameters that are not required are placed in `[square brackets]`.

Adjust the settings to your needs. It makes no sense to write `ls file(s)`, if no file named `file(s)` actually exists. You can usually combine several parameters, for example, by writing `ls -la` instead of `ls -l -a`.

### 19.3.1 File Commands

The following section lists the most important commands for file management. It covers anything from general file administration to manipulation of file system ACLs.

**File Administration**

*ls [option(s)] [file(s)]* If you run `ls` without any additional parameters, the program lists the contents of the current directory in short form.

- `-l` Detailed list
- `-a` Displays hidden files

*cp [option(s)] source target* Copies `source` to `target`.

- `-i` Waits for confirmation, if necessary, before an existing `target` is overwritten
- `-r` Copies recursively (includes subdirectories)

*mv [option(s)] source target* Copies `source` to `target` then deletes the original `source`.

- `-b` Creates a backup copy of the `source` before moving
- `-i` Waits for confirmation, if necessary, before an existing `target` file is overwritten

*rm [option(s)] file(s)* Removes the specified files from the file system. Directories are not removed by `rm` unless the option `-r` is used.

- `-r` Deletes any existing subdirectories
- `-i` Waits for confirmation before deleting each file.
ln [option(s)] source target  Creates an internal link from source to target. Normally, such a link points directly to source on the same file system. However, if ln is executed with the –s option, it creates a symbolic link that only points to the directory in which source is located, enabling linking across file systems.

-s  Creates a symbolic link

cd [options(s)] [directory]  Changes the current directory. cd without any parameters changes to the user’s home directory.

mkdir [option(s)] directoryname  Creates a new directory.

rmdir [option(s)] directoryname  Deletes the specified directory, if it is already empty.

chown [option(s)] username[:[group]] file(s)  Transfers ownership of a file to the user with the specified username.

-R  Changes files and directories in all subdirectories

chgrp [option(s)] groupname file(s)  Transfers the group ownership of a given file to the group with the specified group name. The file owner can only change group ownership if a member of both the current and the new group.

chmod [options] mode file(s)  Changes the access permissions.

The mode parameter has three parts: group, access, and access type. group accepts the following characters:

u  user

G  group

o  others

For access, grant access with + and deny it with –.

The access type is controlled by the following options:

r  read

w  write

x  execute—executing files or changing to the directory
Set uid bit—the application or program is started as if it were started by the owner of the file.

As an alternative, a numeric code can be used. The four digits of this code are composed of the sum of the values 4, 2, and 1—the decimal result of a binary mask. The first digit sets the set user ID (SUID) (4), the set group ID (2), and the sticky (1) flags. The second digit defines the permissions of the owner of the file. The third digit defines the permissions of the group members and the last digit sets the permissions for all other users. The read permission is set with 4, the write permission with 2, and the permission for executing a file is set with 1. The owner of a file would usually receive a 6 or a 7 for executable files.

`gzip [parameters] file(s)` This program compresses the contents of files using complex mathematical algorithms. Files compressed in this way are given the extension `.gz` and need to be un compressed before they can be used. To compress several files or even entire directories, use the `tar` command.

`-d` Decompresses the packed gzip files so they return to their original size and can be processed normally (like the command `gunzip`)

`tar options archive file(s)` `tar` puts one or more files into an archive. Compression is optional. `tar` is a quite complex command with a number of options available. The most frequently used options are:

`-f` Writes the output to a file and not to the screen as is usually the case
`-c` Creates a new tar archive
`-r` Adds files to an existing archive
`-t` Outputs the contents of an archive
`-u` Adds files, but only if they are newer than the files already contained in the archive
`-x` Unpacks files from an archive (extraction)
`-z` Packs the resulting archive with `gzip`
`-j` Compresses the resulting archive with `bzip2`
`-v` Lists files processed
The archive files created by tar end with .tar. If the tar archive was also compressed using gzip, the ending is .tgz or .tar.gz. If it was compressed using bzip2, the ending is .tar.bz2. Application examples can be found in Section 19.1.8 on page 253.

**locate pattern(s)** This command is only available if you have installed the findutils-locate package. The locate command can find in which directory a specified file is located. If desired, use wild cards to specify filenames. The program is very speedy, because it uses a database specifically created for the purpose (rather than searching through the entire file system). This very fact, however, also results in a major drawback: locate is unable to find any files created after the latest update of its database. The database can be generated by root with updatedb.

**updatedb [options(s)]** This command performs an update of the database used by locate. To include files in all existing directories, run the program as root. It also makes sense to place it in the background by appending an ampersand (&), so you can immediately continue working on the same command line (updatedb &). This command usually runs as a daily cron job (see cron.daily).

**find [option(s)]** With find, search for a file in a given directory. The first argument specifies the directory in which to start the search. The option -name must be followed by a search string, which may also include wild cards. Unlike locate, which uses a database, find scans the actual directory.

### Commands to Access File Contents

**cat [option(s)] file(s)** The cat command displays the contents of a file, printing the entire contents to the screen without interruption.

- **-n** Numbers the output on the left margin

**less [option(s)] file(s)** This command can be used to browse the contents of the specified file. Scroll half a screen page up or down with (PgUp) and (PgDn) or a full screen page down with (Space). Jump to the beginning or end of a file using (Home) and (End). Press (Q) to exit the program.

**grep [option(s)] searchstring filenames**

The grep command finds a specific search string in the specified file(s). If the search string is found, the command displays the line in which the searchstring was found along with the filename.
-i  Ignores case
-H  Only displays the names of the respective files, but not the text lines
-n  Additionally displays the numbers of the lines in which it found a hit
-l  Only lists the files in which searchstring does not occur

diff [option(s)] file1 file2  The diff command compares the contents of any two files. The output produced by the program lists all lines that do not match. This is frequently used by programmers who need only send their program alterations and not the entire source code.

-q  Only reports whether the two files differ
-u  Produces a “unified” diff, which makes the output more readable

File Systems

mount [option(s)] [device] mountpoint
  This command can be used to mount any data media, such as hard disks, CD-ROM drives, and other drives, to a directory of the Linux file system.

-r  mount read-only
-t  filesystem  Specifies the file system, commonly ext2 for Linux hard disks, msdos for MS-DOS media, vfat for the Windows file system, and iso9660 for CDs

For hard disks not defined in the file /etc/fstab, the device type must also be specified. In this case, only root can mount it. If the file system should also be mounted by other users, enter the option user in the appropriate line in the /etc/fstab file (separated by commas) and save this change. Further information is available in mount(1).

umount [option(s)] mountpoint  This command unmounts a mounted drive from the file system. To prevent data loss, run this command before taking a removable data medium from its drive. Normally, only root is allowed to run the commands mount and umount. To enable other users to run these commands, edit the /etc/fstab file to specify the option user for the respective drive.

19.3.2 System Commands

The following section lists a few of the most important commands needed for retrieving system information and process and network control.
System Information

**df [option(s)] [directory]**  The `df` (disk free) command, when used without any options, displays information about the total disk space, the disk space currently in use, and the free space on all the mounted drives. If a directory is specified, the information is limited to the drive on which that directory is located.

- `-h`  Shows the number of occupied blocks in gigabytes, megabytes, or kilobytes—in human-readable format
- `-T`  Type of file system (ext2, nfs, etc.)

**du [option(s)] [path]**  This command, when executed without any parameters, shows the total disk space occupied by files and subdirectories in the current directory.

- `-a`  Displays the size of each individual file
- `-h`  Output in human-readable form
- `-s`  Displays only the calculated total size

**free [option(s)]**  The command `free` displays information about RAM and swap space usage, showing the total and the used amount in both categories.

- `-b`  Output in bytes
- `-k`  Output in kilobytes
- `-m`  Output in megabytes

**date [option(s)]**  This simple program displays the current system time. If run as root, it can also be used to change the system time. Details about the program are available in man date(1).

Processes

**top [options]**  `top` provides a quick overview of the currently running processes. Press `H` to access a page that briefly explains the main options to customize the program.

**ps [option(s)] [process ID]**  If run without any options, this command displays a table of all your own programs or processes—those you started. The options for this command are not preceded by hyphen.
aux Displays a detailed list of all processes, independent of the owner

**kill [option(s)] process ID**  Unfortunately, sometimes a program cannot be terminated in the normal way. In most cases, you should still be able to stop such a runaway program by executing the `kill` command, specifying the respective process ID (see `top` and `ps`). `kill` sends a `TERM` signal that instructs the program to shut itself down. If this does not help, the following parameter can be used:

-9  Sends a `KILL` signal instead of a `TERM` signal, bringing the specified process to an end in almost all cases

**killall [option(s)] processname**
This command is similar to `kill`, but uses the process name (instead of the process ID) as an argument, killing all processes with that name.

**Network**

**ping [option(s)] hostname|IP address**
The `ping` command is the standard tool for testing the basic functionality of TCP/IP networks. It sends a small data packet to the destination host, requesting an immediate reply. If this works, `ping` displays a message to that effect, which indicates that the network link is basically functioning.

- c  number  Determines the total number of packages to send and ends after they have been dispatched (by default, there is no limitation set)

- f  flood ping: sends as many data packages as possible; a popular means, reserved for `root`, to test networks

- i  value  Specifies the interval between two data packages in seconds (default: one second)

**nslookup** The domain name system resolves domain names to IP addresses. With this tool, send queries to information servers (DNS servers).

**telnet [option(s)] hostname or IP address [Port]**
Telnet is actually an Internet protocol that enables you to work on remote hosts across a network. `telnet` is also the name of a Linux program that uses this protocol to enable operations on remote computers.
Warning

Do not use telnet over a network on which third parties can eavesdrop. Particularly on the Internet, use encrypted transfer methods, such as ssh, to avoid the risk of malicious misuse of a password (see the man page for ssh).

Warning

Miscellaneous

passwd [option(s)] [username] Users may change their own passwords at any time using this command. The administrator root can use the command to change the password of any user on the system.

su [option(s)] [username] The su command makes it possible to log in under a different username from a running session. Specify a username and the corresponding password to use the environment of the respective user. The password is not required from root, because root is authorized to assume the identity of any user. When using the command without specifying a username, you are prompted for the root password and change to the superuser (root).

halt [option(s)] To avoid loss of data, you should always use this program to shut down your system.

reboot [option(s)] Does the same as halt except the system performs an immediate reboot.

clear This command cleans up the visible area of the console. It has no options.

19.4 The vi Editor

Operating the vi editor takes some practice. For many, it is the preferred editor, partly because it is available on any UNIX-like operating system and is included in default Linux installations. Also, if nothing else works, vi will. The short instructions that follow should enable you to edit various configuration files and other types of files with vi.

vi provides three operating modes. In command mode keys are interpreted as command elements. Insert mode interprets all keys as text entries. Last line mode is used for more complex commands, which are entered in the last line.
The most important commands in command mode are shown in Table 19.2 on this page. Each command can be preceded by a number specifying on how many objects the following command should operate. Delete three words at once by...
entering 3dw. The command 10x deletes ten characters after the cursor position and 20dd deletes twenty lines.

The most important commands in last line mode are shown in Table 19.3 on the current page.

**Table 19.3: Complex Commands of the vi Editor**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>:q!</td>
<td>exits vi without saving any changes</td>
</tr>
<tr>
<td>:w ⟨filename⟩</td>
<td>saves as ⟨filename⟩</td>
</tr>
<tr>
<td>:x</td>
<td>saves the modified file and exits the editor</td>
</tr>
<tr>
<td>:e ⟨filename⟩</td>
<td>edits (loads) ⟨filename⟩</td>
</tr>
<tr>
<td>:u</td>
<td>undoes the last edit command</td>
</tr>
</tbody>
</table>
Additional Information

Where do I find general and up-to-date information for SUSE LINUX?
In addition to this FAQ chapter, SUSE provides a comprehensive FAQ Web site at http://www.novell.com/products/linuxprofessional/faq/index.html.

Are the SUSE manuals also available as PDF or HTML files?
Our manuals are included on the CDs and are also available through the SUSE help center. To start the help center, press (Alt) + (F2) and enter the command susehelp. The HTML versions are available in the packages suselinux-adminguide_en and suselinux-userguide_en. In the installed system, go to the directory /usr/share/doc/manual/suselinux-adminguide_en or /usr/share/doc/manual/suselinux-userguide_en. The PDF versions can be found in suselinux-adminguide_en-pdf and suselinux-userguide_en-pdf.

Where can I get more information about SUSE LINUX?
Most of the information about the installation and features of SUSE LINUX is provided in the manuals. Documentation for applications is available in /usr/share/doc/packages and the HowTos are located in /usr/share/doc/howto/en. Read these files with a command like less /usr/share/doc/howto/en/DOS-to-Linux-HOWTO.txt.gz. Terminate the command by pressing (Esc).
Hardware

Is my hardware supported? It is best to refer to the component database at http://cdb.suse.de/index.php?LANG=en_EN or http://cdb.suse.de. less /usr/share/doc/howto/en/Hardware-HOWTO.gz can also provide some information. Also check the hardware section of the SUSE LINUX FAQ at http://www.novell.com/products/linuxprofessional/faq/index.html.

Installation

Where do I find the current system requirements for an installation of SUSE LINUX?
Refer to http://www.novell.com/products/linuxprofessional/sysreqs.html for the system requirements of the most recent SUSE LINUX distribution.

How much disk space do I need for Linux?
This depends on how many and which packages you want to install. A standard installation with office applications requires about 2 GB. 2.5 GB is recommended if you want space for your own data as well. To install just about everything, you need 3–6 GB, depending on the version.

What is meant by partitioning? Partitioning is dividing the hard disk into smaller sections. For the default configuration, SUSE LINUX requires at least two partitions (one for Linux itself and one swap partition for the virtual main memory).

Which file system do you recommend?
The file system best suited for you highly depends on the scenario in which your system will be run. ReiserFS tends to be best suited for home users, but if you intend to run a high performance server, you might want to use another file system. Refer to File Systems in Linux in the Administration Guide for more information about the file systems supported by SUSE LINUX.

How can I get a short information on all software packages contained in SUSE LINUX?
SUSE maintains a list of all packages contained in the current version under http://www.novell.com/products/linuxpackages/professional/index.html. Either enter a package name or use one of
the sort methods available. Then view a short description of the package similar to the one you would get in YaST.

**I want to remove Linux. How does this work?**

With `fdisk`, delete the Linux partitions. You might need to run `fdisk` in Linux. Afterwards, boot from the MS-DOS disk and run `fdisk /MBR` in DOS or Windows.

---

**System Configuration and Administration**

**Do I need to be afraid of a virus in Linux?**

In Linux, there have been no serious viruses found. Also, viruses cannot cause any serious damage if they are not activated by `root`. The only virus scanners available in Linux search e-mails for Windows viruses (if Linux is used as a router or server). Nevertheless, you should back up important data and configurations.

**I cannot find any `.exe` files. Where are all the applications?**

In Linux, executable files normally do not have file extensions. Most programs are located in `/usr/bin` and `/usr/X11R6/bin`.

**How can I recognize executable files?**

The command `ls -l` returns all executable files in the directory `/usr/bin` in green. Also recognize them by the `x` in the first column.

```
-rwxr-xr-x 1 root root 64412 Jul 23 15:23 /usr/bin/ftp
```

**How do I start a service or an application at boot?**

To start certain services at boot, use the YaST module ‘System Services (Runlevel)’. Find a detailed description of this module and some background information about the boot and runlevel concept of Linux in the Administration Guide.

To configure GNOME to start any application automatically when it starts, open the GNOME Control Center and choose ‘System’ ➝ ‘Sessions’. Open the tab named ‘Startup Programs’ and enter the application you want started.

In KDE, start Konqueror and open the folder `.kde/Autostart` in your home directory. Drag the application icon from the main menu into the Konqueror window and choose ‘Link Here’. The application will be started the next time you log in to KDE.
I only have an application in source code. How can I install it?
Before trying to compile an application on your own check whether it already exist as installable RPM. Try Web sites like
http://packman.links2linux.org/ or http://rpmfind.net.
Decompress the archive with `tar xzvf name.tar.gz`, read the
INSTALL or README files, and follow the instructions. If compiling on your
own, note that neither the compilation nor the resulting application are covered
by the installation support.

Do I need to compile a kernel myself?
No, it is usually unnecessary and strongly discouraged for inexperienced
users to recompile the kernel. Do so only at your own risk. In cases of
custom compiled kernels, SUSE cannot provide any installation support.

How can I defragment my hard disk?
Linux file systems prevent fragmentation. However, make sure that you
do not use more than 80% of each partition. The fuller your hard disk,
the more “fragmentation” you get, even under Linux. Use `df -h` to view
information about used and available hard disk space.

I need more space for Linux. How can I add another hard disk?
To make more space available, integrate a new hard disk or parts of it (partitions)
into your Linux system at any time. For example, if it turns out that
you need more space in `/opt`, mount an additional hard disk partition to
this directory. To do so, follow this procedure:

1. Install your hard disk following the instructions of the manufacturer
then start Linux.
2. Log in as the `root` user.
3. Partition the new hard disk with `fdisk`. For further information, refer
to the manual page of `fdisk` with `man fdisk`.
4. Format the partition with `mke2fs /dev/hdb1`.
5. Enter the following commands:

   ```
   cd /opt
   mkdir /opt2
   mount /dev/hdb1 /opt2
   cp -axv . /opt2
   ```

   Check thoroughly to see whether all the data has been copied. Afterwards,
move the old directory and add a new one—an empty mount point:
mv /opt /opt.old
mkdir /opt

Use an editor to add the new partitions in /etc/fstab. This could resemble the line in Example A.1 on this page.

**Example A.1:** Sample Line in /etc/fstab for an Additional Partition
/dev/hdb1 /opt ext2 defaults 1 2

Now, shut down the computer and reboot.

6. After rebooting, check that /dev/hdb1 has actually been mounted to /opt using the command `mount`. If everything is working as desired, remove the old data from /opt.old:

```
cd /
rm -fr opt.old
```

**How can I find out how much space is available in Linux?**
Use the `df -hT` command. `-h` converts the byte sizes into human readable format (such as 1K, 234M, or 2G) and `-T` prints the type of file system.

**Applications**

**How can I install applications?** Applications included in the SUSE LINUX CDs are best installed with YaST.

**How can I enter commands in GNOME or KDE?**
In KDE, click the screen with shell icon in the panel to start the Bash shell. Alternative terminals can be started via the main menu. In GNOME, select a terminal from the main menu. To run a single command in KDE or GNOME, press `Alt-F2` then enter the command.

**I cannot find many programs in GNOME or KDE.**
You can start all programs from a terminal window by entering the program name and pressing `Enter`.

**How do I connect to the Internet in Linux?**
Section KInternet—Connecting to the Internet on page 24 provides information about this. Alternatively, use QInternet.
Can I copy and paste in Linux? Yes, this is possible. Highlight the text block by clicking and dragging with the left mouse button then insert by clicking with the middle mouse button. The right mouse button has a special function in most programs and applications.

How can I switch from a virtual text console to the graphical user interface? By default, there are six virtual text consoles that can be accessed with Control-Alt-F1 to Control-Alt-F6. Press Control-Alt-F7 to go to the graphical user interface.

Why isn’t there a movie player that supports encoded DVDs? Movie player applications on SUSE LINUX are unable to play a number of movie file formats, especially movie DVDs. Due to patented codecs and copy protection, SUSE is not allowed to deliver full-featured movie players with the distribution.

Troubleshooting

Where can I see the system messages? System messages are logged under /var/log/. To access this directory and all information stored there, log in as root. The most important messages are logged in messages. To view the most recent entries, enter tail -f /var/log/messages in the terminal window. To view messages relating to the boot process, apply this command to the file boot.msg.

To monitor the processes running on your system, enter top in a terminal window. If you need to access information located under /proc, use procinfo.xosview monitors the status of CPU usage, load average, memory usage, and more.

How can I find a specific file on my system? There are two possibilities. One is to use the KDE or GNOME search tool. Find them in the main menu. Alternatively, use the command find, described in man find(1).

I am searching for a specific file (libfoo.so.2). How do I find out what package this file is in? Use the command pin (Package Information) to locate a file:

pin libfoo.so.2

The above command tries to find a package or filenames and paths. Use man pin(1) for more information.
My computer crashed. Can I just press the reset button without risking anything?

If your computer no longer reacts to your mouse or keyboard, this does not necessarily mean that your entire system has crashed. Possibly one program is blocking the mouse or the keyboard, but all other programs are still running. If your machine can be accessed remotely (serial terminal, network), log in elsewhere, identify the crashed application by `ps` or `top`, and abort the respective program with `killall <program name>`. If this does not work, try `killall -9 <program name>`.

If this is not possible, try switching to another console using `Ctrl-Alt-F2` to kill the faulty process from there. If the computer does not respond to any of the keys and network intervention is not possible, wait at least ten seconds before pressing reset to make sure that there is no hard disk activity.

To avoid possible damage to your file system, make sure that all data is safely written to disk before resetting the system. This can be done using the `SysReq` option of the Linux kernel. The kernel support for this feature must be enabled first. Open the file `/etc/sysconfig/sysctl` as root and set `ENABLE_SYSRQ` to `yes`. Use the key combination `Alt-SysRQ-U` to empty all data buffers safely by writing the data to disk and unmount the file system. `SysRQ` may also be labeled `Print Screen` on some keyboards. After the file system is unmounted, press the reset button to reboot your system.

I cannot log in to my computer with `telnet`. I always get the answer `Login incorrect`.

You are probably trying to log in as `root`. For security reasons, this is not possible via `telnet` by default. With YaST, set up a normal user account. Log in with this username. Then change to the user `root` with `su`. It is much better and safer, however, to use the program `ssh` instead of `telnet`. The `ssh` program uses encrypted, secure connections.

Contacting SUSE

I found a bug in SUSE LINUX. Where should I report it?

First, ascertain whether it is actually a bug in the program or just an error in operation or faulty configuration settings. Also read the documentation in `/usr/share/doc/packages` and `/usr/share/doc/howto`. The bug may already have been discovered. Check in the support

What is a mirror? Why shouldn’t I get these things from ftp.suse.com?
As there are many users who need to retrieve things from the server at the same time, its capacity limit would be reached very quickly. For this reason, there are a number of other FTP servers that contain a duplicate of the SUSE server. These servers are referred to as mirrors. Select a mirror in your vicinity (same country) to speed up the download. A list of mirrors is available at http://www.novell.com/products/linuxprofessional/downloads/ftp/int_mirrors.html.

I might have a problem or question that isn’t referenced here. Is there a way to submit this information so others can benefit from it?
Submit your questions by contacting the writers of this book via an e-mail to mailto:documentation@suse.de?subject=FAQ. Future editions of this FAQ will benefit from your feedback. Note that the editors will not provide support of any kind in answer to your mail. Refer to the support team if in need of help.
Index

A
access permissions ........ see permissions
accessibility
- GNOME ........................................... 65–67
- KDE .................................................. 93–96
alevt ..................................................... 200
alsamixer ............................................. 179
amaroK .................................................. 182
applications ...................................... 31–46
  - development ..................................... 45
    · CVS ................................................. 45
    · Eclipse ........................................... 45
    · GTK ................................................ 45
    · KDevelop ......................................... 45
    · Mono .............................................. 46
    · Qt .................................................. 45
    · Subversion ...................................... 46
  - graphics ........................................... 49
    · Blender .......................................... 42
    · Dia ................................................. 41
    · Digikam ......................................... 42, 219
    · GIMP ............................................. 41, 235
    · gThumb ........................................... 42
    · Gwview .......................................... 42
    · Inkscape ......................................... 41
    · Kooka .............................................. 42, 227
    · POV-Ray .......................................... 41
  - installing ......................................... 275
  - multimedia ....................................... 37
    · amaroK .......................................... 39, 182
    · Audacity ......................................... 39
    · audacity ......................................... 192
    · Grip .............................................. 38, 189
    · K3b ............................................... 38, 209
    · Kaffeine ......................................... 39
    · kdetv ............................................ 40
    · KMix ............................................... 178
    · KsCD .............................................. 38, 188
    · LilyPond ......................................... 39
    · MainActor ....................................... 40
    · motv ............................................. 40
    · Noteedit .......................................... 39
    · Rosegarden ....................................... 39
    · Totem ............................................. 63
    · tvtime ............................................ 40
    · xawtv4 .......................................... 40
    · XMMS .............................................. 39, 186
    · zapping ......................................... 40
  - network .......................................... 35–37
    · Evolution ...................................... 36, 117
    · Firefox .......................................... 35, 157
    · Gaim .............................................. 56, 62
    · gftp .............................................. 37
    · GnomeMeeting ................................... 37
    · kbear ........................................... 37
    · Konqueror ....................................... 35, 151
    · Kontakt .......................................... 36, 129
    · Kopete ........................................... 36, 91
    · KPhone .......................................... 37
    · Opera ............................................ 36
    · XChat ............................................. 37
  - office ............................................. 32–34
    · Evolution ...................................... 36, 117
    · GnuCash ......................................... 34
    · Gnuplot .......................................... 33
    · knoda .......................................... 33
<table>
<thead>
<tr>
<th>Index</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>· Kontakt</td>
<td>36, 129</td>
</tr>
<tr>
<td>· moneyplex</td>
<td>34</td>
</tr>
<tr>
<td>· OpenOffice.org</td>
<td>33, 109</td>
</tr>
<tr>
<td>· Planner</td>
<td>34</td>
</tr>
<tr>
<td>· PostgreSQL</td>
<td>34</td>
</tr>
<tr>
<td>· Rekall</td>
<td>33</td>
</tr>
<tr>
<td>· StarOffice</td>
<td>33</td>
</tr>
<tr>
<td>· Taskjuggler</td>
<td>34</td>
</tr>
<tr>
<td>· VYM</td>
<td>33</td>
</tr>
<tr>
<td>· starting</td>
<td>17, 50</td>
</tr>
<tr>
<td>arecord</td>
<td>195</td>
</tr>
<tr>
<td>Audacity</td>
<td>192</td>
</tr>
<tr>
<td>audacity</td>
<td>192</td>
</tr>
</tbody>
</table>

| B | Bash | 246, 254 |
|   | commands | 246 |
|   | functions | 249 |
|   | pipes | 252 |
|   | wild cards | 251 |
| browsers | see Web browsers |
| bugs | 277 |

| C | calendars | 119, 125 |
|   | Evolution | 132, 138 |
|   | Kontakt | 132, 138 |
| cat | 264 |
| cd | 262 |
| CDs | 262 |
|   | copying | 213 |
|   | creating | 209, 213 |
|   | audio | 212 |
|   | data | 59, 210 |
|   | ISO images | 213 |
|   | players | 188 |
|   | playing | 187, 191 |
|   | ripping | 187, 191 |
| chgrp | 257, 262 |
| chmod | 257, 262 |
| chown | 257, 262 |
| clear | 268 |
| commands | 260, 268 |
|   | bzip2 | 44 |
|   | cat | 264 |
|   | cd | 262 |
|   | chgrp | 257, 262 |
|   | chmod | 257, 262 |
|   | chown | 257, 262 |
|   | clear | 268 |
| cp | 261 |
| crashes | 277 |

| D | date | 266 |
|   | desktops | 7 |
|   | configuring | 10, 43 |
|   | GNOME | 10 |
|   | KDE | 11 |
|   | switching users | 14 |

<p>| configuration files | 265, 275 |
| /etc/fstab | 265, 275 |
| /etc/sysconfig/sysctl | 277 |
| cp | 261 |
| crashes | 277 |</p>
<table>
<thead>
<tr>
<th>Index</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>GIMP</td>
<td>41, 235–242</td>
</tr>
<tr>
<td>fonts</td>
<td>- installing</td>
</tr>
<tr>
<td>free</td>
<td>266</td>
</tr>
<tr>
<td>G</td>
<td>52</td>
</tr>
<tr>
<td>GNOME</td>
<td>47, 62</td>
</tr>
<tr>
<td></td>
<td>- accessibility</td>
</tr>
<tr>
<td></td>
<td>· Dasher</td>
</tr>
<tr>
<td></td>
<td>· Gnopernicus</td>
</tr>
<tr>
<td></td>
<td>· GOK</td>
</tr>
<tr>
<td></td>
<td>· applets</td>
</tr>
<tr>
<td></td>
<td>· applications, default</td>
</tr>
<tr>
<td></td>
<td>· CD player</td>
</tr>
<tr>
<td></td>
<td>· commands</td>
</tr>
<tr>
<td></td>
<td>· configuring</td>
</tr>
<tr>
<td></td>
<td>· accessibility</td>
</tr>
<tr>
<td></td>
<td>· background</td>
</tr>
<tr>
<td></td>
<td>· fonts</td>
</tr>
<tr>
<td></td>
<td>· keyboard</td>
</tr>
<tr>
<td></td>
<td>· keyboard shortcuts</td>
</tr>
<tr>
<td></td>
<td>· menus</td>
</tr>
<tr>
<td></td>
<td>· mouse</td>
</tr>
<tr>
<td></td>
<td>· system alerts</td>
</tr>
<tr>
<td></td>
<td>· themes</td>
</tr>
<tr>
<td></td>
<td>· toolbars</td>
</tr>
<tr>
<td></td>
<td>· windows</td>
</tr>
<tr>
<td></td>
<td>· desktop menu</td>
</tr>
<tr>
<td></td>
<td>· dictionary</td>
</tr>
<tr>
<td></td>
<td>· File Roller</td>
</tr>
<tr>
<td></td>
<td>· icons</td>
</tr>
<tr>
<td></td>
<td>· Nautilus</td>
</tr>
<tr>
<td></td>
<td>· notes</td>
</tr>
<tr>
<td></td>
<td>· panels</td>
</tr>
<tr>
<td></td>
<td>· printing</td>
</tr>
<tr>
<td></td>
<td>· sessions</td>
</tr>
<tr>
<td></td>
<td>· sound</td>
</tr>
<tr>
<td>graphics</td>
<td>236</td>
</tr>
<tr>
<td></td>
<td>- albums</td>
</tr>
<tr>
<td></td>
<td>- digital cameras</td>
</tr>
<tr>
<td></td>
<td>- editing</td>
</tr>
<tr>
<td></td>
<td>- file formats</td>
</tr>
<tr>
<td></td>
<td>- galleries</td>
</tr>
<tr>
<td></td>
<td>- pixel</td>
</tr>
<tr>
<td></td>
<td>- vector</td>
</tr>
<tr>
<td></td>
<td>- core</td>
</tr>
<tr>
<td></td>
<td>-中级</td>
</tr>
<tr>
<td></td>
<td>- tutorials</td>
</tr>
<tr>
<td></td>
<td>· camera selection</td>
</tr>
<tr>
<td></td>
<td>· installing</td>
</tr>
<tr>
<td></td>
<td>· gunzip</td>
</tr>
<tr>
<td></td>
<td>· gzip</td>
</tr>
<tr>
<td>H</td>
<td>99, 102</td>
</tr>
<tr>
<td>halt</td>
<td>268</td>
</tr>
<tr>
<td>hard disks</td>
<td>274</td>
</tr>
<tr>
<td></td>
<td>- adding</td>
</tr>
<tr>
<td></td>
<td>- defragmenting</td>
</tr>
<tr>
<td>hardware</td>
<td>272</td>
</tr>
<tr>
<td></td>
<td>- supported</td>
</tr>
<tr>
<td>help</td>
<td>102, 271</td>
</tr>
<tr>
<td></td>
<td>- FAQs</td>
</tr>
<tr>
<td></td>
<td>- HOWTOs</td>
</tr>
<tr>
<td></td>
<td>- info pages</td>
</tr>
<tr>
<td></td>
<td>- Linux documentation</td>
</tr>
<tr>
<td></td>
<td>- man pages</td>
</tr>
<tr>
<td></td>
<td>- manuals</td>
</tr>
<tr>
<td></td>
<td>- OpenOffice.org</td>
</tr>
<tr>
<td></td>
<td>- SUSE Help Center</td>
</tr>
<tr>
<td></td>
<td>- Usenet</td>
</tr>
<tr>
<td></td>
<td>- Wikipedia</td>
</tr>
<tr>
<td>I</td>
<td>155</td>
</tr>
<tr>
<td>Internet</td>
<td>62, 91</td>
</tr>
<tr>
<td></td>
<td>- chatting</td>
</tr>
<tr>
<td></td>
<td>- connecting to</td>
</tr>
<tr>
<td></td>
<td>- wireless</td>
</tr>
<tr>
<td>J</td>
<td>155</td>
</tr>
<tr>
<td>Java</td>
<td>155</td>
</tr>
<tr>
<td>JavaScript</td>
<td>155</td>
</tr>
<tr>
<td>K</td>
<td>38, 209, 213</td>
</tr>
<tr>
<td>K3b</td>
<td>38, 209, 213</td>
</tr>
<tr>
<td>Index</td>
<td></td>
</tr>
<tr>
<td>-------</td>
<td></td>
</tr>
<tr>
<td>- installing programs with</td>
<td>147</td>
</tr>
<tr>
<td>- KAddressBook</td>
<td>144</td>
</tr>
<tr>
<td>- KOrganizer</td>
<td>145</td>
</tr>
<tr>
<td>- syncing</td>
<td>146</td>
</tr>
<tr>
<td>KsCD</td>
<td>188</td>
</tr>
<tr>
<td>L</td>
<td></td>
</tr>
<tr>
<td>less</td>
<td>252, 264</td>
</tr>
<tr>
<td>Linux</td>
<td></td>
</tr>
<tr>
<td>- removing</td>
<td>273</td>
</tr>
<tr>
<td>ln</td>
<td>262</td>
</tr>
<tr>
<td>locate</td>
<td>264</td>
</tr>
<tr>
<td>login</td>
<td></td>
</tr>
<tr>
<td>- GDM</td>
<td>3</td>
</tr>
<tr>
<td>- KDM</td>
<td>5</td>
</tr>
<tr>
<td>- sessions</td>
<td>4, 6</td>
</tr>
<tr>
<td>ls</td>
<td>246, 261</td>
</tr>
<tr>
<td>M</td>
<td></td>
</tr>
<tr>
<td>man pages</td>
<td>260</td>
</tr>
<tr>
<td>mirrors</td>
<td>278</td>
</tr>
<tr>
<td>mkdir</td>
<td>249, 262</td>
</tr>
<tr>
<td>more</td>
<td>252</td>
</tr>
<tr>
<td>motd</td>
<td>198, 201</td>
</tr>
<tr>
<td>- audio</td>
<td>199</td>
</tr>
<tr>
<td>- launchers</td>
<td>200</td>
</tr>
<tr>
<td>- proportions</td>
<td>199</td>
</tr>
<tr>
<td>- seeking channels</td>
<td>198</td>
</tr>
<tr>
<td>- video source</td>
<td>198</td>
</tr>
<tr>
<td>mount</td>
<td>265</td>
</tr>
<tr>
<td>Mozilla</td>
<td>see Firefox</td>
</tr>
<tr>
<td>MS-DOS</td>
<td></td>
</tr>
<tr>
<td>- commands</td>
<td>254</td>
</tr>
<tr>
<td>- file systems</td>
<td>254</td>
</tr>
<tr>
<td>mtools</td>
<td>254</td>
</tr>
<tr>
<td>mv</td>
<td>261</td>
</tr>
<tr>
<td>N</td>
<td></td>
</tr>
<tr>
<td>Nautilus</td>
<td>57, 61</td>
</tr>
<tr>
<td>- CD creation</td>
<td>59</td>
</tr>
<tr>
<td>- configuring</td>
<td>60</td>
</tr>
<tr>
<td>- MIME types</td>
<td>59</td>
</tr>
<tr>
<td>- navigating</td>
<td>57</td>
</tr>
<tr>
<td>networks</td>
<td>24, 27</td>
</tr>
<tr>
<td>- configuring</td>
<td>24</td>
</tr>
<tr>
<td>- Internet</td>
<td>24</td>
</tr>
<tr>
<td>- wireless</td>
<td>26, 27</td>
</tr>
<tr>
<td>nslookup</td>
<td>267</td>
</tr>
<tr>
<td>nvtvepg</td>
<td>201</td>
</tr>
<tr>
<td>- filters</td>
<td>202</td>
</tr>
<tr>
<td>O</td>
<td></td>
</tr>
<tr>
<td>Ogg Vorbis</td>
<td>189</td>
</tr>
<tr>
<td>oggenc</td>
<td>189</td>
</tr>
<tr>
<td>OpenOffice.org</td>
<td>see LibreOffice</td>
</tr>
<tr>
<td>- application modules</td>
<td>110</td>
</tr>
<tr>
<td>- Base</td>
<td>115</td>
</tr>
<tr>
<td>- Calc</td>
<td>115</td>
</tr>
<tr>
<td>- help</td>
<td>115</td>
</tr>
<tr>
<td>- Impress</td>
<td>115</td>
</tr>
<tr>
<td>- Microsoft document formats</td>
<td>110</td>
</tr>
<tr>
<td>- Navigator</td>
<td>113</td>
</tr>
<tr>
<td>- selecting text</td>
<td>112</td>
</tr>
<tr>
<td>- styles</td>
<td>113</td>
</tr>
<tr>
<td>- wizards</td>
<td>111</td>
</tr>
<tr>
<td>- Writer</td>
<td>111–114</td>
</tr>
<tr>
<td>P</td>
<td></td>
</tr>
<tr>
<td>partitioning</td>
<td>272</td>
</tr>
<tr>
<td>- GNU Parted</td>
<td>141</td>
</tr>
<tr>
<td>passwd</td>
<td>268</td>
</tr>
<tr>
<td>passwords</td>
<td></td>
</tr>
<tr>
<td>- changing</td>
<td>268</td>
</tr>
<tr>
<td>paths</td>
<td>250</td>
</tr>
<tr>
<td>- absolute</td>
<td>250</td>
</tr>
<tr>
<td>- relative</td>
<td>250</td>
</tr>
<tr>
<td>- working with</td>
<td>250</td>
</tr>
<tr>
<td>PDAs</td>
<td></td>
</tr>
<tr>
<td>- Evolution</td>
<td>126</td>
</tr>
<tr>
<td>- Kontakt</td>
<td>140</td>
</tr>
<tr>
<td>- KPlanner</td>
<td>141–147</td>
</tr>
<tr>
<td>PDF viewers</td>
<td>90</td>
</tr>
<tr>
<td>permissions</td>
<td>255, 259</td>
</tr>
<tr>
<td>- access control lists</td>
<td>239</td>
</tr>
<tr>
<td>- changing</td>
<td>257, 262</td>
</tr>
<tr>
<td>- directories</td>
<td>256</td>
</tr>
<tr>
<td>- file systems</td>
<td>255</td>
</tr>
<tr>
<td>- files</td>
<td>255</td>
</tr>
<tr>
<td>- viewing</td>
<td>255</td>
</tr>
<tr>
<td>ping</td>
<td>257</td>
</tr>
<tr>
<td>power management</td>
<td>28, 29, 76</td>
</tr>
<tr>
<td>printing</td>
<td>18, 21</td>
</tr>
<tr>
<td>- Firefox</td>
<td>164</td>
</tr>
<tr>
<td>- GIMP</td>
<td>241</td>
</tr>
<tr>
<td>- GNOME</td>
<td>18</td>
</tr>
<tr>
<td>- KDE</td>
<td>18</td>
</tr>
<tr>
<td>processes</td>
<td></td>
</tr>
<tr>
<td>- killing</td>
<td>266</td>
</tr>
<tr>
<td>- overview</td>
<td>266</td>
</tr>
<tr>
<td>Q</td>
<td>qaRecord</td>
</tr>
<tr>
<td>R</td>
<td>reboot</td>
</tr>
<tr>
<td>R</td>
<td>rm</td>
</tr>
<tr>
<td>R</td>
<td>rmdir</td>
</tr>
<tr>
<td>S</td>
<td>scanning</td>
</tr>
<tr>
<td>S</td>
<td>- character recognition</td>
</tr>
<tr>
<td>S</td>
<td>- GOOCR</td>
</tr>
<tr>
<td>S</td>
<td>- Kooka</td>
</tr>
<tr>
<td>S</td>
<td>shells</td>
</tr>
<tr>
<td>S</td>
<td>- Bash</td>
</tr>
<tr>
<td>S</td>
<td>- commands</td>
</tr>
<tr>
<td>S</td>
<td>- paths</td>
</tr>
<tr>
<td>S</td>
<td>- pipes</td>
</tr>
<tr>
<td>S</td>
<td>- wild cards</td>
</tr>
<tr>
<td>sound</td>
<td></td>
</tr>
<tr>
<td>sound</td>
<td>- chips</td>
</tr>
<tr>
<td>sound</td>
<td>- Audigy</td>
</tr>
<tr>
<td>sound</td>
<td>- envy24</td>
</tr>
<tr>
<td>sound</td>
<td>- on-board</td>
</tr>
<tr>
<td>sound</td>
<td>- Soundblaster Live</td>
</tr>
<tr>
<td>sound</td>
<td>- data compression</td>
</tr>
<tr>
<td>sound</td>
<td>- Grip</td>
</tr>
<tr>
<td>sound</td>
<td>- KAudioCreator</td>
</tr>
<tr>
<td>sound</td>
<td>- Konqueror</td>
</tr>
<tr>
<td>sound</td>
<td>- Ogg Vorbis</td>
</tr>
<tr>
<td>sound</td>
<td>- oggenc</td>
</tr>
<tr>
<td>sound</td>
<td>- editing files</td>
</tr>
<tr>
<td>sound</td>
<td>- mixers</td>
</tr>
<tr>
<td>sound</td>
<td>- alsamixer</td>
</tr>
<tr>
<td>sound</td>
<td>- envy24control</td>
</tr>
<tr>
<td>sound</td>
<td>- GNOME</td>
</tr>
<tr>
<td>sound</td>
<td>- KMix</td>
</tr>
<tr>
<td>sound</td>
<td>- players</td>
</tr>
<tr>
<td>sound</td>
<td>- amarok</td>
</tr>
<tr>
<td>sound</td>
<td>- GNOME</td>
</tr>
<tr>
<td>sound</td>
<td>- KsCD</td>
</tr>
<tr>
<td>sound</td>
<td>- XMMS</td>
</tr>
<tr>
<td>- recording</td>
<td></td>
</tr>
<tr>
<td>- arecord</td>
<td>195</td>
</tr>
<tr>
<td>- audacity</td>
<td>192</td>
</tr>
<tr>
<td>- qaRecord</td>
<td>195</td>
</tr>
<tr>
<td>- ssh</td>
<td>277</td>
</tr>
<tr>
<td>- su</td>
<td>268</td>
</tr>
<tr>
<td>- SuSEWatcher</td>
<td>13</td>
</tr>
<tr>
<td>- system</td>
<td></td>
</tr>
<tr>
<td>- messages</td>
<td>276</td>
</tr>
<tr>
<td>- rebooting</td>
<td>268</td>
</tr>
<tr>
<td>- requirements</td>
<td>272</td>
</tr>
<tr>
<td>- security</td>
<td>23</td>
</tr>
<tr>
<td>- services</td>
<td>273</td>
</tr>
<tr>
<td>- shutdown</td>
<td>268</td>
</tr>
<tr>
<td>- system administration</td>
<td>22</td>
</tr>
<tr>
<td>- installing applications</td>
<td>22</td>
</tr>
<tr>
<td>- updates</td>
<td>22</td>
</tr>
<tr>
<td>T</td>
<td>tar</td>
</tr>
<tr>
<td>T</td>
<td>telnet</td>
</tr>
<tr>
<td>T</td>
<td>TLDP</td>
</tr>
<tr>
<td>T</td>
<td>top</td>
</tr>
<tr>
<td>T</td>
<td>TV</td>
</tr>
<tr>
<td>T</td>
<td>- alevt</td>
</tr>
<tr>
<td>T</td>
<td>- EPG</td>
</tr>
<tr>
<td>T</td>
<td>- motv</td>
</tr>
<tr>
<td>T</td>
<td>- nxtvepg</td>
</tr>
<tr>
<td>T</td>
<td>- teletext</td>
</tr>
<tr>
<td>T</td>
<td>- xawtv4</td>
</tr>
<tr>
<td>U</td>
<td>umount</td>
</tr>
<tr>
<td>U</td>
<td>updatedb</td>
</tr>
<tr>
<td>USB</td>
<td>- digital cameras</td>
</tr>
<tr>
<td>users</td>
<td></td>
</tr>
<tr>
<td>users</td>
<td>- concept</td>
</tr>
<tr>
<td>users</td>
<td>- root</td>
</tr>
<tr>
<td>users</td>
<td>- superuser</td>
</tr>
<tr>
<td>users</td>
<td>- switching</td>
</tr>
<tr>
<td>V</td>
<td>vi</td>
</tr>
<tr>
<td>virtual consoles</td>
<td></td>
</tr>
<tr>
<td>virtual consoles</td>
<td>- navigating</td>
</tr>
<tr>
<td>W</td>
<td>Web browsers</td>
</tr>
<tr>
<td>W</td>
<td>- Firefox</td>
</tr>
</tbody>
</table>